Give Candies
时间限制: 1 Sec 内存限制: 128 MB
提交: 243 解决: 92
[提交] [状态] [命题人:admin]
题目描述
There are N children in kindergarten. Miss Li bought them N candies。To make the process more interesting, Miss Li comes up with the rule: All the children line up according to their student number (1…N), and each time a child is invited, Miss Li randomly gives him some candies (at least one). The process goes on until there is no candy. Miss Li wants to know how many possible different distribution results are there.
输入
The first line contains an integer T, the number of test case.
The next T lines, each contains an integer N.
1 ≤ T ≤ 100
1 ≤ N ≤ 10^100000
输出
For each test case output the number of possible results (mod 1000000007).
样例输入
复制样例数据
1
4
样例输出
8
题目大意:
有nnn块饼干,将其分给nnn个人,问有多少种分法,顺序不同算两种分法。
例如:有三块饼干,则分法为:
1+1+1
2+1
1+2
3
共4种
解题思路:
通过列举前几项,很容易发现,若有nnn块饼干,则有2n−12^{n-1}2n−1种分法,由于nnn的范围很大,所以需知道一个定理,即: ab=aφ(b)a^b = a^{\varphi(b)}ab=aφ(b)
而对于质数100000000710000000071000000007来说,φ(1000000007)=1000000007−1\varphi(1000000007)=1000000007-1φ(1000000007)=1000000007−1
所以可以先将指数缩小,再使用快速幂即可
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
char s[100100];
ll quickpow(ll n,ll p) {ll base=2;ll ans=1;while(n) {if(n&1) ans=(ans*base)%p;n>>=1;base=(base*base)%p;}return ans;
}
int main()
{#ifndef ONLINE_JUDGEfreopen("in.txt", "r", stdin);#endif//freopen("out.txt", "w", stdout);//ios::sync_with_stdio(0),cin.tie(0);int T;scanf("%d",&T);while(T--) {scanf("%s",s);ll nape=0;ll p=1000000007;int len=strlen(s);for(int i=0;i<len;i++) {ll x=(ll)(s[i]-'0');nape=(nape*10LL+x)%(p-1);}nape=(nape-1+p-1)%(p-1);ll ans=quickpow(nape,p);printf("%lld\n",ans);}return 0;
}