Transport Ship
时间限制: 1 Sec 内存限制: 128 MB
提交: 175 解决: 65
[提交] [状态] [命题人:admin]
题目描述
There are N different kinds of transport ships on the port. The i^th kind of ship can carry the weight of V[i] and the number of the ith kind of ship is 2C[i]-1. How many different schemes there are if you want to use these ships to transport cargo with a total weight of S? It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.
输入
The first line contains an integer T(1≤T≤20), which is the number of test cases.
For each test case:
The first line contains two integers: N(1≤N≤20), Q(1≤Q≤10000), representing the number of kinds of ships and the number of queries.
For the next N lines, each line contains two integers: V[i] (1≤V[i]≤20), C[i] (1≤C[i]≤20), representing the weight the i^th kind of ship can carry, and the number of the i^th kind of ship is 2C[i]-1.
For the next Q lines, each line contains a single integer: S (1≤S≤10000), representing the queried weight.
输出
For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 1000000007.
样例输入
复制样例数据
1
1 2
2 1
1
2
样例输出
0
1
题目大意:
有TTT组测试数据,对于每组测试数据,先输入两个整数N,QN,QN,Q,其下NNN行每行输入两个整数V[i],C[i]V[i],C[i]V[i],C[i],代表容量为V[i]V[i]V[i]的船共有2C[i]−12^{C[i]}-12C[i]−1艘,再往后QQQ行,代表有QQQ组查询,每行输入一个数字VVV,问运输体积为VVV的货物共有多少种方案。
解题思路:
每种船的个数固定,运送固定体积,很明显是一道背包问题,不过此时的dp[i]dp[i]dp[i]数组代表的是运送体积为iii时的方案数。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
ll dp[10100];
ll V[10010],C[10010];
int main()
{#ifndef ONLINE_JUDGEfreopen("in.txt", "r", stdin);#endif//freopen("out.txt", "w", stdout);//ios::sync_with_stdio(0),cin.tie(0);int T;scanf("%d",&T);while(T--) {int N,Q;scanf("%d %d",&N,&Q);rep(i,1,N) {scanf("%lld %lld",&V[i],&C[i]);}ms(dp);dp[0]=1;for(int i=1;i<=N;i++) {if(V[i]*((1LL<<C[i])-1)>=10000) {for(ll j=V[i];j<=10000;j++) {dp[j]=(dp[j-V[i]]+dp[j])%mod;}}else{for(int k=0;k<C[i];k++) {for(ll j=10000;j>=(1LL<<k)*V[i];j--) {dp[j]=(dp[j]+dp[j-(1LL<<k)*V[i]])%mod;}}}}//for(int i=1;i<=10;i++) cout<<dp[i]<<endl;while(Q--) {int s;scanf("%d",&s);printf("%lld\n",dp[s]);}}return 0;
}