Simple Addition expression
时间限制: 1 Sec 内存限制: 128 MB
提交: 355 解决: 80
[提交] [状态] [命题人:admin]
题目描述
A luxury yacht with 100 passengers on board is sailing on the sea in the twilight. The yacht is ablaze with lights and there comes out laughers and singing from the hall where an evening party is in full swing. People are singing, dancing and enjoying themselves.
The yacht is equipped with the most advanced navigation and driving system which can all be manipulated by a computer. When the captain notices that there is only gentle breeze and the sea waves are not high, he starts the autopilot. The yacht sails forward smoothly, ploughs the waves. When it’s completely dark, the passengers start to feel a little funny for sudden forward rushes or sudden decelerations or slight swings. The captain immediately walks to the driving platform and switches the autopilot to human manipulation. The yacht returns back to normal and the party restarts. Laughers come back, too.
The captain summons the engineer on board to do a thorough check of the navigation system. It turns out that only the computer is out of order, but the exact failure is still unclear. There is a computer scientist among the passengers who is also invited to the cab to give a hand. He first inputs several groups of data to test the computer. When he inputs 1+2+3, the computer outputs 6, which is exactly right. But when he inputs 4+5+6, the computer outputs 5, which is wrong. Then he inputs 12+13+14, and gets 39, another right answer, while he inputs 14+15+16, and gets 35, another wrong answer. After the test, the computer scientist says smilingly: “the failure is clear now. The computer’s adder can not carry." After excluding the failure, the captain restarts the autopilot and the yacht returns back to normal, sailing smoothly on the sea.
The captain and the engineer invite the computer scientist to sit down and have a talk. The computer scientist tells a story as following:
A former mathematician defined a kind of simple addition expression.
If there is an expression (i) + (i+1) + (i+2), i>=0, when carried out additive operations, no position has a carry, it is called simple addition expression.
For instance, when i equals 0, 0+1+2 is a simple addition expression, meanwhile when i equals 11, 11+12+13 is a simple addition expression, too. Because of that no position has a carry.
However, when i equals 3, 3+4+5 is not a simple addition expression, that is because 3+4+5 equals 12, there is a carried number from unit digit to tens digit. In the same way, when i equals 13, 13+14+15 is not a simple addition expression, either. However, when i equals 112, 112+113+114 is a simple addition expression. Because 112+113+114 equals 339, there is no carry in the process of adding.
when the students have got the definition of simple addition expression, the mathematician puts forward a new question: for a positive integer n, how many simple addition expressions exist when i<n. In addition, i is the first number of a simple addition expression.
when the value of n is large enough, the problem needs to be solved by means of computer.
输入
There are several test cases, each case takes up a line, there is an integer n (n<10^10).
输出
Output the number of all simple addition expressions when i<n.
样例输入
复制样例数据
1
2
3
4
10
11
样例输出
1
2
3
3
3
4
题目大意:
对一个数iii,如果i+(i+1)+(i+2)i+(i+1)+(i+2)i+(i+1)+(i+2)没有进位如i=0(0+1+2),i=1(1+2+3),i=2(2+3+4)i=0(0+1+2),i=1(1+2+3),i=2(2+3+4)i=0(0+1+2),i=1(1+2+3),i=2(2+3+4),则称这样的式子为简单加法,注i=3(3+4+5)i=3(3+4+5)i=3(3+4+5)不行,因为有进位。现输入一个数nnn,问有多少个i(i<n)i(i<n)i(i<n)满足简单式子。
解题思路:
由题意可知,对于这样的iii,其个位只能为0,1,20,1,20,1,2,其他位只能为0,1,2,30,1,2,30,1,2,3,而这个数最多只有十位,所以最暴力的方法即遍历每一位的值,将其放入一个数组中,最后根据nnn的值二分即可。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
ll num[12];
ll arr[10010000];
int main()
{#ifndef ONLINE_JUDGEfreopen("in.txt", "r", stdin);#endif//freopen("out.txt", "w", stdout);//ios::sync_with_stdio(0),cin.tie(0);int id=0;for(ll i1=0;i1<=3;i1++) {num[1]=i1;for(ll i2=0;i2<=3;i2++) {num[2]=i2;for(ll i3=0;i3<=3;i3++) {num[3]=i3;for(ll i4=0;i4<=3;i4++) {num[4]=i4;for(ll i5=0;i5<=3;i5++) {num[5]=i5;for(ll i6=0;i6<=3;i6++) {num[6]=i6;for(ll i7=0;i7<=3;i7++) {num[7]=i7;for(ll i8=0;i8<=3;i8++) {num[8]=i8;for(ll i9=0;i9<=3;i9++) {num[9]=i9;for(ll i0=0;i0<3;i0++) {num[10]=i0;ll nape=0;for(int k=1;k<=10;k++) {nape=nape*10LL+num[k];}id++;arr[id]=nape;}}}}}}}}}}sort(arr+1,arr+1+id);ll n;while(scanf("%lld",&n)!=EOF) {int id1=lower_bound(arr+1,arr+1+id,n)-arr-1;printf("%d\n",id1);}return 0;
}
方法二:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<cmath>
#include<cstring>
#include<set>
#include<queue>
#include<stack>
#include<map>
#define rep(i,a,b) for(int i=a;i<=b;i++)
typedef long long ll;
using namespace std;
const int N=1e5+10;
const int INF=0x3f3f3f3f;
ll dp[20],a[20];
void init(){dp[1]=3;dp[0]=1;for(int i=2;i<=11;i++){ll t=3;for(int j=1;j<i;j++)t*=4;dp[i]=t;}
}
int main()
{#ifndef ONLINE_JUDGEfreopen("in.txt","r",stdin);#endif // ONLINE_JUDGEll n;init();
// for(int i=0;i<=11;i++)
// cout<<dp[i]<<" ";
// cout<<endl;while(scanf("%lld",&n)!=EOF){int cnt=0;ll m=n;while(m){a[cnt++]=m%10;m/=10;}ll ans=0;
// for(int i=cnt-1;i>=0;i--)
// cout<<a[i]<<" ";
// cout<<endl;for(int i=cnt-1;i>=0;i--){if(a[i]>=4) a[i-1]=9;if(a[i]<=3)ans+=a[i]*dp[i];elseans+=3*dp[i];}printf("%lld\n",ans);}return 0;
}