题干:
Dearboy was so busy recently that now he has piles of clothes to wash. Luckily, he has a beautiful and hard-working girlfriend to help him. The clothes are in varieties of colors but each piece of them can be seen as of only one color. In order to prevent the clothes from getting dyed in mixed colors, Dearboy and his girlfriend have to finish washing all clothes of one color before going on to those of another color.
From experience Dearboy knows how long each piece of clothes takes one person to wash. Each piece will be washed by either Dearboy or his girlfriend but not both of them. The couple can wash two pieces simultaneously. What is the shortest possible time they need to finish the job?
Input
The input contains several test cases. Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes. The next line contains M strings which are not longer than 10 characters and do not contain spaces, which the names of the colors. Then follow N lines describing the clothes. Each of these lines contains the time to wash some piece of the clothes (less than 1,000) and its color. Two zeroes follow the last test case.
Output
For each test case output on a separate line the time the couple needs for washing.
Sample Input
3 4
red blue yellow
2 red
3 blue
4 blue
6 red
0 0
Sample Output
10
题目大意:
Dearboy和他的女朋友用一个盆一起洗m件衣服,共有n总颜色(每件衣服只有一种颜色)。 为了放置不同颜色互染,每次只能洗一种颜色的衣服,在这件衣服洗完之前不能洗另外一种衣服。 Dearboy和他女朋友可以同时一起洗衣服,但是不能同时洗同一件衣服,也不能同时洗不同种颜色的衣服。
一只每件衣服所需时间,问最少花费多少时间可以全部洗完。
(ps:这里建议自己,如果还能看得到这篇题解,自己再读一遍题,有很多的地方可以帮助自己提升阅读速度和理解题意,比如The couple can wash two pieces simultaneously. 这一句刚开始就理解错了,理解成了可以同时洗两种,即两种不能同时一个人洗,但是可以男生洗一种,女票洗一种 这样。但是其实人家的意思是,可以同时洗两件,而不是两种!。因为你看题目区分不同种的用词是color,而区分每一件,都用的是piece这种的!所以读到这里不用仔细纠结量词,直接看上文的这个词表示的是什么意思,那在这里就表示啥意思了。。。再举个例子,Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes.这句中的the number of 就是英语老师教过的 ...的数量 的意思,但是有的题目中,他的意思是,....的编号,因为比如他会说 把1~n这些物品编号成number 1 ~ n 所以这时候就要注意一下了!!,the number of A 是不是 有可能是别的意思)
解题报告:
poj有毒,,,首先这题卡vector了,优化了很多地方还是只能934ms过。(澄清,,没卡vector,可以294ms飘过,但是卡memset了,需要你的数组开的不能太大,1e5就刚刚好,开1e6就炸了,tle妥妥的,应该是初始化dp的时候耗时太长了。。)所以还是老老实实的开一个num数组来辅助time这个二维数组的输入吧、、、相当于替代了vector的time[mp[col]].push_back(tm);这一步,其余的还好。相当于对每一种衣服做0-1背包记一个时间,然后每一种的这个时间求和即可。
AC代码1:(294ms)(vector + 二维的dp数组)
#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
map<string ,int> mp;
int n,m;
int top;
int tm;//每种颜色的衣服所洗的总共的时间
int dp[15][100000 + 5];
vector<int> time[50];
int sum[20];
int main()
{char col[50];while(scanf("%d%d",&m,&n)) {if(m == 0 && n == 0 ) break;mp.clear();for(int i = 1; i<=20; i++) time[i].clear();memset(dp,0,sizeof dp);memset(sum,0,sizeof sum);top = 0;for(int i = 1; i<=m; i++) {scanf("%s",col);//if(mp.find(col) == mp.end()) mp[col] = ++top;mp[col] = i;}for(int i = 1; i<=n; i++) {scanf("%d%s",&tm,col);time[mp[col]].push_back(tm);sum[mp[col]] += tm;}int ans = 0;for(int k = 1; k<=m; k++) {
// memset(dp,0,sizeof(dp));for(int i = 0; i<time[k].size(); i++) {for(int j = sum[k]/2; j>=time[k][i]; j--) {dp[k][j] = max(dp[k][j],dp[k][j-time[k][i]] + time[k][i]);}}ans +=(sum[k] - dp[k][sum[k]/2]);}printf("%d\n",ans); }return 0 ;
}
AC代码2:(63ms)(没用vector + 一维dp数组)
#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;int n,m;
int top;
int tm;//每种颜色的衣服所洗的总共的时间
int dp[100000 + 5];
int num[15];
int time[15][50];
int sum[50];
int main()
{char col[50];while(~scanf("%d%d",&m,&n)) {if(m == 0 && n == 0 ) break;map<string, int> mp;memset(num,0,sizeof num);
// for(int i = 1; i<=20; i++) time[i].clear();memset(dp,0,sizeof dp);memset(sum,0,sizeof sum);top = 0;for(int i = 1; i<=m; ++i) {scanf("%s",col);mp[col] = i;//if(mp.find(col) == mp.end()) mp[col] = ++top;}for(int i = 1; i<=n; i++) {scanf("%d%s",&tm,col);time[mp[col]][++num[mp[col]]] = tm;sum[mp[col]] += tm;}int ans = 0;for(int k = 1; k<=m; k++) {memset(dp,0,sizeof(dp));for(int i = 1; i<=num[k]; i++) {for(int j = sum[k]>>1; j>=time[k][i]; --j) {dp[j] = max(dp[j],dp[j-time[k][i]] + time[k][i]);}}ans +=(sum[k] - dp[sum[k]>>1]);}printf("%d\n",ans); }return 0 ;
}