题干:
You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.
Assumptions:
- number of tracks on the CD. does not exceed 20
- no track is longer than N minutes
- tracks do not repeat
- length of each track is expressed as an integer number
- N is also integer
Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD
Input
Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes
Output
Set of tracks (and durations) which are the correct solutions and string ``sum:" and sum of duration times.
Sample Input
5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2
Sample Output
1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45
解题报告:
这题本来想用排序去做(因为可以记录路径),但是发现排序了反而麻烦,而直接这样做就非常的巧妙。这样pre用一维数组相当于实时更新,所以最后输出的路径也是正确的,倒序读入反而就是错误的了。
AC代码:
#include<bits/stdc++.h>using namespace std;
int dp[100000 + 5],pre[100000 + 5];
int n,m;
struct Node {int id;int val;
} node[25];
bool cmp(Node a,Node b) {return a.val > b.val;
}
void print(int loc) {if(pre[loc] == 0) {printf("%d ",loc);return;}print(pre[loc]);printf("%d ",loc - pre[loc]);}
int main()
{while(~scanf("%d%d",&m,&n)) {memset(dp,0,sizeof(dp));for(int i = 1; i<=n; i++) {scanf("%d",&node[i].val);node[i].id = i;}
// sort(node+1,node+n+1,cmp);for(int i = 1; i<=n; i++) {for(int j = m; j>=node[i].val; j--) {
// if(dp[j] !=0) continue;
// dp[j] = max(dp[j],dp[j-node[i].val ] + node[i].val);
// poe[j] = j-node[i].val;if(dp[j-node[i].val ] + node[i].val > dp[j]) {dp[j] = dp[j-node[i].val ] + node[i].val;pre[j] = j - node[i].val;}}}print(dp[m]);printf("sum:%d\n",dp[m]);}return 0 ;}
错误代码:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 100005
using namespace std;
// 45 3 38 39 2
int dp[maxn];
int num[25];
int vis[25][maxn];
int n,m;
int main()
{while(scanf("%d%d",&n,&m)!=EOF){memset(dp,0,sizeof(dp));memset(vis,0,sizeof(vis));memset(num,0,sizeof(num));for(int i=0;i<m;i++)scanf("%d",&num[i]);for(int i=0;i<=m-1;i++)//这里正序是错的!!倒序是对的!用上面给的那个样例试一下就知道了。sum输出的是对的但是路径是错的。 for(int j=n;j>=num[i];j--){if(dp[j-num[i]]+num[i]>dp[j]){dp[j]=dp[j-num[i]]+num[i];vis[i][j]=1;}}
// printf("vis[1]][n] = %d\n",vis[0][n]);int j=n;for(int i=0;i<m;i++){if(vis[i][j]){printf("%d ",num[i]);j-=num[i];}} printf("sum:%d\n",dp[n]);}return 0;
}
这样做0-1背包的话sum的值是正确的但是输出的路径是错误的,因为你这里的vis不带更新(因为是二维的),所以还是旧值,要避免这个问题就是倒序做0-1背包。
(ps:其实这个题改动一下还是可以正序跑背包的,就是输出的时候倒序处理一下就行了,然后用栈存起来最后顺序输出就可以了 下面贴一下代码吧。。)
AC代码2:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 100005
using namespace std;
// 45 3 38 39 2
int dp[maxn];
int num[25];
int vis[25][maxn];
int n,m;
int main()
{while(scanf("%d%d",&n,&m)!=EOF){memset(dp,0,sizeof(dp));memset(vis,0,sizeof(vis));memset(num,0,sizeof(num));for(int i=0;i<m;i++)scanf("%d",&num[i]);for(int i=0; i<=m-1; i++)//这里正序是错的!!倒序是对的!用上面给的那个样例试一下就知道了。sum输出的是对的但是路径是错的。 for(int j=n;j>=num[i];j--){if(dp[j-num[i]]+num[i]>dp[j]){dp[j]=dp[j-num[i]]+num[i];vis[i][j]=1;
// printf("vis[%d][%d] = 1\n",i,j);}}
// printf("vis[1]][n] = %d\n",vis[0][n]);int j=n;
// for(int i = 1; i<=n; i++) {
// printf("dp[%d] = %d\n",i,dp[i]);
// }int cnt = 0;int ans[50] = {0};for(int i=m-1;i>=0;i--){if(vis[i][j]){ans[++cnt] = num[i];j-=num[i];}} for(int i = cnt; i>=1; i--) printf("%d ",ans[i]);printf("sum:%d\n",dp[n]);}return 0;
}
其实输出路径还有第三种写法,不针对这个题但是可以这样做:(还原成二维数组但是可以不开vis数组了)
这个题也可以这样做
45 3
38 38
39 39
2 2
这样输入就可以了。。。
其中x数组记录的是第i个物品在路径中是否用到了。
所以输出为:
0 1 1
#include<iostream>
#include<cstring>
using namespace std;
int main()
{int V,n;while(cin>>V>>n){int dp[100][100];int w[1000],v[1000];for(int i = 1;i <= n;i++)cin>>w[i]>>v[i];for(int i = 0;i <= V;i++)dp[0][i]=0;for(int i = 1;i <= n;i++){for(int j = V; j>=w[i];j--){dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i]);}}cout<<dp[n][V]<<endl;int j=V;int x[1000];memset(x,0,sizeof(x));for(int i = n;i >= 1;i--){if(dp[i][j]>dp[i-1][j]){x[i]=1;j-=w[i];}}for(int i = 1;i <= n;i++)cout<<x[i]<<" ";cout<<endl;}return 0;
}
总结:
其实很多背包问题之所以需要排序(其实倒序做背包问题也算是排序的一种啦~),有的是为了路径的正确性(比如说这一题),但是也有可能就是会影响到结果的正确性(比如:POJ 2392 Space Elevator (多重背包),或者HDU - 3466 Proud Merchants(蜜汁排序) )。