将一笔零钱换成5分、2分和1分的硬币,要求每种硬币至少有一枚。
输入格式:
输入在一行中给出待换的零钱数额x∈(8,100)。
输出格式:
要求按5分、2分和1分硬币的数量依次从大到小的顺序,输出各种换法。每行输出一种换法,格式为:“fen5:5分硬币数量, fen2:2分硬币数量, fen1:1分硬币数量, total:硬币总数量”。最后一行输出“count = 换法个数”。
输入样例:
13
输出样例:
fen5:2, fen2:1, fen1:1, total:4
fen5:1, fen2:3, fen1:2, total:6
fen5:1, fen2:2, fen1:4, total:7
fen5:1, fen2:1, fen1:6, total:8
count = 4
代码示例:
#换硬币方法
NumberTimes = 1 #方法数
InitialMoney = int(input()) #初始输入
Remainder5 = InitialMoney % 5
Quotient5 = int(InitialMoney / 5) #5个数
Count1 = Remainder5 % 2 #1个数
Quotient2 = int(Quotient5 / 2) #2个数
#第一个方法
print(f'fen5:{Quotient5}, fen2:{Quotient2}, fen1:{Count1}, total:{Quotient5+Quotient2+Count1}')
#循环递减大面值币
while True:if Quotient5 != 1:Quotient5 -= 1Quotient2 += 2Count1 += 1elif Quotient5 == 1 and Quotient2 != 1:Quotient2 -= 1Count1 += 2print(f'fen5:{Quotient5}, fen2:{Quotient2}, fen1:{Count1}, total:{Quotient5 + Quotient2 + Count1}')NumberTimes += 1if Quotient5 == 1 and Quotient2 == 1:print(f'count = {NumberTimes}')break
以上代码全为本人亲自手敲,可能有一些错误和不足之处,如有更好的方法和建议,欢迎您在评论区友善讨论。