题干:
Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.
Input
The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
Output
For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.
Sample Input
1 10 10 0 5 2 7 5 4 3 8 7 7 2 8 6 3 5 0 1 3 1 1 9 4 0 1 0 3 5 5 5 5 1 4 6 3 1 5 7 5 7 3
Sample Output
Case 1: 4 0 0 3 1 2 0 1 5 1
题目大意:
马里奥是一个举世闻名的管道工,他的跳跃能力让我们钦佩。在一条长度为n的道路上,在每个整数点i的位置都有一个高度为hi的障碍物。现在的问题是:假设马里奥可以跳跃的最高高度为H,在道路的[L,R] 区间内他可以跳跃过的障碍物有多少个(不要考虑他被挡住)?
Input
第一行是数据个数T。
对于每组数据:
第一行包含两个整数n, m (1 <= n <=10^5, 1 <= m <= 10^5), n 表示道路的程度, m是询问的个数.
第二行包含n个整数,表示每个障碍物的高度, 高度范围是 [0, 1000000000].
接着 m 行,每行3个整数 L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
Output
对于每组数据, 先输出"Case X: " ( X表示组数) 然后有m行, 每行包含一个整数. 第i个整数表示第i个询问的答案。
解题报告:
首先这题是可以离线做的(先对h排序优化掉一维,这样就只剩下一维偏序了,直接树状数组就ok),极其方便。
但是为了练习这个神奇的数据结构emmm、、写了一发主席树。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 1e5 + 5;
struct TREE {int l,r;int val;
} tr[MAX*40];int tot;
int a[MAX],b[MAX];
int root[MAX];
int build(int l,int r) {int cur = ++tot;tr[cur].val = 0;if(l == r) {tr[cur].l = tr[cur].r = 0;//这一步好像没啥用? return cur;}int m = (l+r)>>1;tr[cur].l = build(l,m);tr[cur].r = build(m+1,r);return cur;
}
void pushup(int cur) {tr[cur].val = tr[tr[cur].l].val + tr[tr[cur].r].val;
}
int update(int pre,int tar,int l,int r) {int cur = ++tot;tr[cur] = tr[pre];if(l == r) {tr[cur].val++;return cur;}int m = (l+r)>>1;if(tar <= m) tr[cur].l = update(tr[pre].l,tar,l,m);else tr[cur].r = update(tr[pre].r,tar,m+1,r);pushup(cur);return cur;
}
int query(int pl,int pr,int l,int r,int H) {if(l == r) return tr[pr].val - tr[pl].val;int m = (l+r)>>1;if(H <= m) return query(tr[pl].l,tr[pr].l,l,m,H);else return tr[tr[pr].l].val - tr[tr[pl].l].val + query(tr[pl].r,tr[pr].r,m+1,r,H);
}
int main()
{int n,m;int t,iCase=0;cin>>t;while(t--) {printf("Case %d:\n",++iCase);cin>>n>>m;tot=0;for(int i = 1; i<=n; i++) scanf("%d",a+i),b[i] = a[i];root[0] = build(1,n);sort(b+1,b+n+1);int LEN = unique(b+1,b+n+1) - b - 1;for(int i = 1; i<=n; i++) {int pos = lower_bound(b+1,b+LEN+1,a[i]) - b;root[i] = update(root[i-1],pos,1,n);}while(m--) {int l,r,H;scanf("%d%d%d",&l,&r,&H);l++,r++;int pos = upper_bound(b+1,b+LEN+1,H) - b - 1;if(pos) printf("%d\n",query(root[l-1],root[r],1,n,pos));else printf("0\n");}} return 0 ;
}
总结:
注意这里是因为可能在做前缀差的时候用到0(比如输入的L=1,R=1的情况,则需要用到root[1]-root[0]),所以你需要先建一个空树备用。这也是主席树当区间差机制用的时候需要这样用,但是一般的动态开点或许就不需要这样?
所以你这里pos==0的情况一定要特判,不能因为建了一棵root==0的树就可以不特判,因为可以这么理解:他那是线段树开了一个0号版本,但是你这个pos是要映射到值域上的,也正因为是权值线段树,所以必须要特判。也就是这俩=0不是一个东西。
第二个要注意的地方,那就是你build,update和query三个函数传参的时候一定是用的同一个右端点,别一会用离散化之后的一会用离散化之前的。因为你对应的l和r区间长度都不同了,怎么同时二分往下找?