题干:
Background
To The Moon is a independent game released in November 2011, it is a role-playing adventure game powered by RPG Maker.
The premise of To The Moon is based around a technology that allows us to permanently reconstruct the memory on dying man. In this problem, we'll give you a chance, to implement the logic behind the scene.
You‘ve been given N integers A [1], A [2],..., A [N]. On these integers, you need to implement the following operations:
1. C l r d: Adding a constant d for every {A i | l <= i <= r}, and increase the time stamp by 1, this is the only operation that will cause the time stamp increase.
2. Q l r: Querying the current sum of {A i | l <= i <= r}.
3. H l r t: Querying a history sum of {A i | l <= i <= r} in time t.
4. B t: Back to time t. And once you decide return to a past, you can never be access to a forward edition anymore.
.. N, M ≤ 10 5, |A [i]| ≤ 10 9, 1 ≤ l ≤ r ≤ N, |d| ≤ 10 4 .. the system start from time 0, and the first modification is in time 1, t ≥ 0, and won't introduce you to a future state.
Input
n m
A 1 A 2 ... A n
... (here following the m operations. )
Output
... (for each query, simply print the result. )
Sample Input
10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 42 4 0 0 C 1 1 1 C 2 2 -1 Q 1 2 H 1 2 1
Sample Output
4 55 9 150 1
题目大意:
1. 将l到r之间所有的数+d,同时时间戳+1。 2. 查询当前时间戳下l到r的所有数的总和。 3..查询时间戳d下的l到r的所有数的和。 4.将时间戳返回至t。
解题报告:
因为涉及到主席树的区间操作,所以肯定要lazy标记,但是下传的时候,如果按照线段树的写法直接照搬过来,那需要pushdown操作,也就是说涉及到了两个孩子节点的修改,也就是说需要动态开两个节点,然后分别递归下去。这样的话最差复杂度和建n棵线段树应该是同阶的。
考虑优化这个节点太多的问题,既然是下传标记使得需要修改的节点数增多,那么尝试不下传标记?发现可以将标记留在节点上,查询时往下递归的过程遇到lazy则累加就行了,最后把标记的影响加到总答案里。(想了想感觉线段树其实也可以这么干,只不过在pushup的时候比较麻烦就是了,详见下一段)
注意这个题的pushup函数也要改,因为你.val代表的是当前节点及其孩子节点的正确的值,但是不一定等于两个孩子节点的val值的和,因为还有cur中没有下传的lazy标记,也要算进去。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 1e5 + 5;
struct TREE {int l,r;ll val,lazy;
} tr[MAX*40];int tot;
int a[MAX];
int root[MAX];
void pushup(int cur,int l,int r) {tr[cur].val = tr[tr[cur].l].val + tr[tr[cur].r].val + tr[cur].lazy*(r-l+1);
}
int build(int l,int r) {int cur = ++tot;tr[cur].lazy = 0;if(l == r) {tr[cur].val = a[l];//这一步好像没啥用? return cur;}int m = (l+r)>>1;tr[cur].l = build(l,m);tr[cur].r = build(m+1,r);pushup(cur,l,r);return cur;
}
int update(int pre,int pl,int pr,ll val,int l,int r) {int cur = ++tot;tr[cur] = tr[pre];if(pl <= l && pr >= r) {tr[cur].val += (r-l+1)*val;tr[cur].lazy += val;return cur;}int m = (l+r)>>1;if(pl <= m) tr[cur].l = update(tr[pre].l,pl,pr,val,l,m);if(pr >= m+1) tr[cur].r = update(tr[pre].r,pl,pr,val,m+1,r);pushup(cur,l,r);return cur;
}
ll query(int cur,int pl,int pr,ll laz,int l,int r) {if(pl <= l && pr >= r) return tr[cur].val + laz * (r-l+1);ll res = 0;laz += tr[cur].lazy;int m = (l+r)>>1; if(pl <= m) res += query(tr[cur].l,pl,pr,laz,l,m);if(pr >= m+1) res += query(tr[cur].r,pl,pr,laz,m+1,r); return res;
}
int main()
{int n,m,l,r;ll d;char op[5];while(cin>>n>>m) {for(int i = 1; i<=n; i++) cin>>a[i];int T = 0,t; tot=0;root[T] = build(1,n);while(m--) {scanf("%s",op);if(op[0] == 'C') {scanf("%d%d%lld",&l,&r,&d);T++;root[T] = update(root[T-1],l,r,d,1,n);//注意这里的序列是1~n就行了,而不是1~m!!! }else if(op[0] == 'Q') {scanf("%d%d",&l,&r);printf("%lld\n",query(root[T],l,r,0,1,n));}else if(op[0] == 'H') {scanf("%d%d%d",&l,&r,&t);printf("%lld\n",query(root[t],l,r,0,1,n));}else scanf("%d",&T); } }return 0 ;
}
/*
2 4
0 0
C 1 1 1
C 2 2 -1
Q 1 2
H 1 2 1
*/