题干:
Find the sum of all the digits in all the integers between lowerBound and upperBound inclusive.
Input
Each line contains two integers lowerBound and upperBound (0 ≤ lowerBound ≤ upperBound ≤ 2·109).
Output
For each test case print in a separate line the sum of all the digits in all the integers between lowerBound and upperBound inclusive.
Example 1
Input example
0 3 14 53 24660 308357171
Output example
6 296 11379854844
题目大意;
多组输入,每组输出L和R,求L~R的数位和。
解题报告:
按位统计,统计时组合数算一下就好了。对每一个位a[p],枚举i分三种情况讨论,i<a[p] ,i==a[p] ,i>a[p]。分别求一下就好。
注意i==a[p]的时候不能和i<a[p]的形式统一,而且也不能像代码中那样用tmp记录、、因为那个只能从前往后读入的时候用,从后往前的时候肯定不行啊。
这题相当于做了一个简单的数位dp。(复现了一部分过程)
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
ll solve(ll x) { ll res = 0,xx=x;if(x<=0) return 0;ll tmp = 1,k=1;while(x) {for(int i = 1; i<=9; i++) {if(i < x%10) res += i*(xx / (k*10)) * k + i*k; else if(i == x%10) res += i*(xx / (k*10))*k+i*(xx%k+1);//(tmp-tmp%10)/10;else res += i*(xx / (k*10)) * k;}tmp = tmp*10+x%10;x/=10; k*=10;//10的k次方 }return res;
}
int main()
{ll L,R;while(~scanf("%lld%lld",&L,&R)) {printf("%lld\n",solve(R) - solve(L-1));}return 0 ;
}