题干:
When God made the first man, he put him on a beautiful garden, the Garden of Eden. Here Adam lived with all animals. God gave Adam eternal life. But Adam was lonely in the garden, so God made Eve. When Adam was asleep one night, God took a rib from him and made Eve beside him. God said to them, “here in the Garden, you can do everything, but you cannot eat apples from the tree of knowledge.”
One day, Satan came to the garden. He changed into a snake and went to live in the tree of knowledge. When Eve came near the tree someday, the snake called her. He gave her an apple and persuaded her to eat it. Eve took a bite, and then she took the apple to Adam. And Adam ate it, too. Finally, they were driven out by God and began a hard journey of life.
The above is the story we are familiar with. But we imagine that Satan love knowledge more than doing bad things. In Garden of Eden, the tree of knowledge has n apples, and there are k varieties of apples on the tree. Satan wants to eat all kinds of apple to gets all kinds of knowledge.So he chooses a starting point in the tree,and starts walking along the edges of tree,and finally stops at a point in the tree(starting point and end point may be same).The same point can only be passed once.He wants to know how many different kinds of schemes he can choose to eat all kinds of apple. Two schemes are different when their starting points are different or ending points are different.
Input
There are several cases.Process till end of input.
For each case, the first line contains two integers n and k, denoting the number of apples on the tree and number of kinds of apple on the tree respectively.
The second line contains n integers meaning the type of the i-th apple. Types are represented by integers between 1 and k .
Each of the following n-1 lines contains two integers u and v,meaning there is one edge between u and v.1≤n≤50000, 1≤k≤10
Output
For each case output your answer on a single line.
Sample Input
3 2
1 2 2
1 2
1 3
Sample Output
6
题目大意:
给定N个节点的树,每个节点有颜色,共k种颜色,求树上所有满足从i到j所经过的点包含了所有颜色的点对,(i,j)和(j,i)视为不同且i可以等于j。(N<=5e4,k<=10)
解题报告:
k=10,考虑状态压缩,最多可以(1<<(10)-1)种状态,利用树分治保存每个点到节点的路径状态。比求路径之和等于k的点对要简单,因为不需要容斥,可以用蓝书上第一种方法去求(按照子树顺序分别处理),但是细节还是要注意,比如当前的根节点别被统计多次了,且别忘了从根节点当其中一个端点,开始往下一条链的那种情况,其实这种情况是不需要特判的,只需要在做当前根节点上的所有工作之前,让cnt[(1<<col[cur])]++即可。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 1e5 + 5;
int col[MAX],head[MAX],tot,size[MAX],n,k;
struct Node {int to,ne;
} e[MAX<<1];
bool vis[MAX];
int up,cnt[MAX],tmp[MAX];
void add(int u,int v) {e[++tot].to = v;e[tot].ne=head[u];head[u]=tot;
}
ll ans;
int rt,all,son[MAX];
//getRoot调用之前必须先rt=0;
void getRoot(int cur,int fa) {size[cur]=1;son[cur]=0;for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].to;if(v == fa || vis[v]) continue;getRoot(v,cur); size[cur] += size[v];son[cur] = max(son[cur],size[v]);}son[cur] = max(son[cur],all - size[cur]);//注意这里的all指的就是当前子树的节点个数 if(son[rt] == 0 || son[rt] > son[cur]) rt = cur;//值小,则更新根节点
}
void gx(int cur,int fa) {size[cur]=1;for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].to;if(v == fa || vis[v]) continue;gx(v,cur); size[cur] += size[v];}
}
void get(int cur,int fa,int sta) {tmp[sta]++;
// if(sta == (up-1)) ans++;for(int bit = 0; bit<up; bit++) {if((bit|sta) == (up-1)) ans += cnt[bit];} for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].to;if(v == fa || vis[v]) continue;get(v,cur,sta|(1<<col[v]));}
}
void cal(int cur) {for(int i = 0; i<up; i++) cnt[i] = 0;cnt[(1<<col[cur])]++;
// get(cur,0,1<<col[cur]);//注意这里不能等效处理,因为cur的子节点需要特殊处理,因为我们需要一个子树一个子树的处理。 for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].to; if(vis[v]) continue;for(int sta = 0; sta<up; sta++) tmp[sta]=0;
// tmp[(1<<col[cur])]++;//不能在这里加!不然就重复了! get(v,cur,(1<<col[cur]) | (1<<col[v]));for(int sta = 0; sta<up; sta++) cnt[sta] += tmp[sta];}
}
void dfs(int cur) {rt=0; getRoot(cur,0); cur=rt; vis[cur]=1; gx(cur,0);cal(cur);for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].to;if(vis[v]) continue;all = size[v]; dfs(v); }
}
int main()
{while(~scanf("%d%d",&n,&k)) {tot=0; up = 1<<k; ans = 0;for(int i = 1; i<=n; i++) head[i] = -1,vis[i]=size[i]=0;for(int i = 1; i<=n; i++) scanf("%d",col+i),col[i]--; for(int u,v,i = 1; i<=n-1; i++) scanf("%d%d",&u,&v),add(u,v),add(v,u);if(k == 1) {printf("%lld\n",1LL*n*(n-1)+n);continue;}all=n; dfs(1);printf("%lld\n",ans*2); } return 0 ;
}