题干:
Zhou xingxing is the successor of one style of kung fu called "Karate Kid".he is falling love with a beautiful judo student,after being humiliated by her boyfriend,a Taekwando master from Japan,Zhou is going to fight with his rival in love.The way they fight is to destroy the wooden plank between some wooden pegs,in order to cut these wooden pegs into two disconnected parts,and destroy each piece of plank need consume different energy.However Zhou xingxing is beginner after all,so he is turn to you for help,please calculate the minimum energy he need to destroy the wooden plank.
Input
The input consists of multiple test cases.
Each test case starts with two integers n (0 < n <= 100) and m in one line, where n、m are the number of wooden pegs and wooden plank.
Following are m lines, each line contains three integers s, e and q (0 <= s, e < n,q > 0), meaning that there need q energy to destroy the wooden plank between s and e.
Output
There is only one line for each test case, which contains the minimum energy they need to complete this fight.
Sample Input
2 1
0 1 50
3 2
0 1 50
1 2 10
Sample Output
50
10
题目大意:
给定一个无向图,删除一些边使得图不再连通,求最小的代价。(代价定义为删除的边权和)。
(即在最小割的前提下,没指定起点和终点)
解题报告:
算法过程如下(参考:http://m.blog.csdn.net/blog/u011483306/25697255):
1、设最小割ans=INF,任选一个点到集合A中,定义W(A,p)为A中的所有点到A外一点p的权值总和
2、对刚才选定的s,更新W(A,p)
3、选出A外一点p,且W(A,p)最大的作为新的s,若A!=G(V),则goto步骤2
4、把最后进入A的两点记为s和t,用W(A,t)更新ans
5、新建顶点u,边权w(u,v)=w(s,v)+w(t,v),删除顶点s和t,以及与它们相连的边(就是将s和t缩成点u)
6、若|V|!=1,则goto步骤1
最终的复杂度是O(N^2*N),若果加了优先队列优化找最大值那一步可以达到O(NlogN*N)
但是博主说有时优先队列STL会狂T……直接O(N^3)却不会……我也没有很多实战过。。就不清楚真假了
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 100 + 5;
const int INF = 0x3f3f3f3f;
int n, cost[MAX][MAX];
bool Read() {int m;if(!(cin>>n>>m)) return 0;memset(cost,0, sizeof(cost));for(int i = 1; i<=m; i++) {int u,v,c;scanf("%d%d%d",&u,&v,&c);cost[u][v]+=c;cost[v][u]+=c;}return 1;
}
int Solve() { // 0(n^3)int wage[MAX], micut=INF;bool inset[MAX], del[MAX];memset(del, 0, sizeof(del));for(int cnt = 0; cnt<n-1; cnt++) {memset(wage, 0, sizeof (wage));memset(inset, 0, sizeof(inset));int pre=0, last=0;while(1) {int u=-1, mx=-1;for(int i = 0; i<n; i++) {if(!inset[i]&&!del[i]) {if (wage[i]>mx) {u=i;mx=wage[i];}}}if(u==-1) break;pre=last;last=u;inset[u]=1;for(int i = 0; i<n; i++) if(!inset[i]) wage[i]+=cost[u][i];}micut=min( micut, wage[last]);for(int i = 0; i<n; i++) cost[i][pre]+=cost[i][last];for(int i = 0; i<n; i++) cost[pre][i]+=cost[last][i];del[last]=1;}return micut;
}
int main() {while(Read()) cout << Solve() << endl;return 0 ;
}