【HDU - 3002】King of Destruction(无向图全局最小割,SW算法,模板题)

题干:

Zhou xingxing is the successor of one style of kung fu called "Karate Kid".he is falling love with a beautiful judo student,after being humiliated by her boyfriend,a Taekwando master from Japan,Zhou is going to fight with his rival in love.The way they fight is to destroy the wooden plank between some wooden pegs,in order to cut these wooden pegs into two disconnected parts,and destroy each piece of plank need consume different energy.However Zhou xingxing is beginner after all,so he is turn to you for help,please calculate the minimum energy he need to destroy the wooden plank.

Input

The input consists of multiple test cases. 
Each test case starts with two integers n (0 < n <= 100) and m in one line, where n、m are the number of wooden pegs and wooden plank. 
Following are m lines, each line contains three integers s, e and q (0 <= s, e < n,q > 0), meaning that there need q energy to destroy the wooden plank between s and e.

Output

There is only one line for each test case, which contains the minimum energy they need to complete this fight.

Sample Input

2 1
0 1 50
3 2
0 1 50
1 2 10

Sample Output

50
10

题目大意:

给定一个无向图,删除一些边使得图不再连通,求最小的代价。(代价定义为删除的边权和)。

(即在最小割的前提下,没指定起点和终点)

解题报告:

算法过程如下(参考:http://m.blog.csdn.net/blog/u011483306/25697255):

1、设最小割ans=INF,任选一个点到集合A中,定义W(A,p)为A中的所有点到A外一点p的权值总和

2、对刚才选定的s,更新W(A,p)

3、选出A外一点p,且W(A,p)最大的作为新的s,若A!=G(V),则goto步骤2

4、把最后进入A的两点记为s和t,用W(A,t)更新ans

5、新建顶点u,边权w(u,v)=w(s,v)+w(t,v),删除顶点s和t,以及与它们相连的边(就是将s和t缩成点u)

6、若|V|!=1,则goto步骤1

最终的复杂度是O(N^2*N),若果加了优先队列优化找最大值那一步可以达到O(NlogN*N)

但是博主说有时优先队列STL会狂T……直接O(N^3)却不会……我也没有很多实战过。。就不清楚真假了

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 100 + 5;
const int INF = 0x3f3f3f3f;
int n, cost[MAX][MAX];
bool Read() {int m;if(!(cin>>n>>m)) return 0;memset(cost,0, sizeof(cost));for(int i = 1; i<=m; i++) {int u,v,c;scanf("%d%d%d",&u,&v,&c);cost[u][v]+=c;cost[v][u]+=c;}return 1;
}
int Solve() { // 0(n^3)int wage[MAX], micut=INF;bool inset[MAX], del[MAX];memset(del, 0, sizeof(del));for(int cnt = 0; cnt<n-1; cnt++) {memset(wage, 0, sizeof (wage));memset(inset, 0, sizeof(inset));int pre=0, last=0;while(1) {int u=-1, mx=-1;for(int i = 0; i<n; i++) {if(!inset[i]&&!del[i]) {if (wage[i]>mx) {u=i;mx=wage[i];}}}if(u==-1) break;pre=last;last=u;inset[u]=1;for(int i = 0; i<n; i++) if(!inset[i]) wage[i]+=cost[u][i];}micut=min( micut, wage[last]);for(int i = 0; i<n; i++) cost[i][pre]+=cost[i][last];for(int i = 0; i<n; i++) cost[pre][i]+=cost[last][i];del[last]=1;}return micut;
}
int main() {while(Read()) cout << Solve() << endl;return 0 ;
}

 

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/439577.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

一步步编写操作系统 58 门、调用门与RPL序 3

接前文&#xff1a; 并不是任何当前特权级都可以使用门结构&#xff0c; 在使用门结构之前&#xff0c;处理器要例行公事做特权级检查&#xff0c;参与检查的不只是CPL和DPL&#xff0c;还有RPL&#xff0c;为了说清楚这个检查过程&#xff0c;咱们得先介绍下RPL。 RPL&#…

详解车道线检测数据集和模型 VIL-100: A New Dataset and A Baseline Model for Video Instance Lane Detection

本文介绍一个新的车道线数据集 VIL-100 和检测模型 MMA-Net&#xff0c;论文已收录于 ICCV2021&#xff0c;重点是理解本文提出的 LGMA 模块&#xff0c;用于聚合局部和全局记忆特征。 论文链接&#xff1a;https://arxiv.org/abs/2108.08482 项目链接&#xff1a;https://gi…

【HDU - 6081】度度熊的王国战略(SW算法,全局最小割)

题干&#xff1a; Problem Description 度度熊国王率领着喵哈哈族的勇士&#xff0c;准备进攻哗啦啦族。 哗啦啦族是一个强悍的民族&#xff0c;里面有充满智慧的谋士&#xff0c;拥有无穷力量的战士。 所以这一场战争&#xff0c;将会十分艰难。 为了更好的进攻哗啦啦族&#…

七天入门图像分割(1):图像分割综述

最近在研究自动驾驶视觉语义地图构建&#xff0c;因为要使用到语义分割技术&#xff0c;趁此机会学习了百度飞桨的图像分割课程&#xff0c;课程蛮好的&#xff0c;收获也蛮大的。 课程地址&#xff1a;https://aistudio.baidu.com/aistudio/course/introduce/1767 1. 课程简要…

一步步编写操作系统 59 cpu的IO特权级1

在保护模式下&#xff0c;处理器中的“阶级”不仅体现在数据和代码的访问&#xff0c;还体现在指令中。 一方面将指令分级的原因是&#xff0c;有些指令的执行对计算机有着严重的影响&#xff0c;它们只有在0特权级下被执行&#xff0c;因此被称为特权指令&#xff08;Privile…

重读经典:《ImageNet Classification with Deep Convolutional Neural Networks》

9年后重读深度学习奠基作之一&#xff1a;AlexNet【下】【论文精读】这两天偶然间在B站看了李沐博士对AlexNet论文的重新解读&#xff0c;收获满满。AlexNet是当今深度学习浪潮奠基作之一&#xff0c;发表在2012年。在视频中&#xff0c;李沐博士主要是分享了他的三步法快速读论…

一步步编写操作系统 60 cpu的IO特权级2 什么是驱动程序

用户程序可以在由操作系统加载时通过指定整个eflags设置&#xff0c;操作系统如何设置自己的IOPL呢&#xff0c;即使内核IOPL为0也得写进去eflags寄存器中才生效。可惜的是&#xff0c;没有直接读写eflags寄存器的指令&#xff0c;不过可以通过将栈中数据弹出到eflags寄存器中来…

详解惯性导航论文 RINS-W: Robust Inertial Navigation System on Wheels

本文介绍一篇惯性导航定位论文 RINS-W&#xff0c;论文发表于 IROS2019。在本论文中作者提出了仅使用一个IMU进行长时间惯性导航的方法。方法主要包括两个部分&#xff1a; 检测器使用循环神经网络来检测IMU的运动状况&#xff0c;如零速或零横向滑移&#xff1b;使用Invarian…

【HDU - 5988】Coding Contest(网络流费用流,改模板)

题干&#xff1a; A coding contest will be held in this university, in a huge playground. The whole playground would be divided into N blocks, and there would be M directed paths linking these blocks. The i-th path goes from the uiui-th block to the vivi-t…

一步步编写操作系统 61 任务状态段 TSS

I/O位图是位于TSS中的&#xff0c;它可以存在也可以不存在&#xff0c;它只是用来设置对某些特定端口的访问&#xff0c;没有它的话便默认为禁止访问所有端口。正是由于它可有可用&#xff0c;所以TSS的段界限TSS limit&#xff08;即实际大小-1&#xff09;并不固定。当TSS中不…

重读经典:《Deep Residual Learning for Image Recognition》

ResNet论文逐段精读【论文精读】这是李沐博士论文精读的第二篇论文&#xff0c;这次精读的论文是ResNet。ResNet 是 CVPR2016 的最佳论文&#xff0c;目前谷歌学术显示其被引用数已经达到了90000。 ResNet论文链接为&#xff1a;https://arxiv.org/abs/1512.03385。 1.第一遍 …

【CodeForces - 1131F 】Asya And Kittens(并查集,思维)

题干&#xff1a; Asya loves animals very much. Recently, she purchased nn kittens, enumerated them from 11 and nn and then put them into the cage. The cage consists of one row of nncells, enumerated with integers from 11 to nn from left to right. Adjacent…

关于Xldown和Xlup的用法(Excel VBA)

Xldown和xlup是一对组合&#xff0c;用于寻找某个区间中的非空单元格。 首先我们在单元格的前7行填入如下数据&#xff1a; A1单元格&#xff1a; A2单元格&#xff1a;2 A3单元格&#xff1a;3 A4单元格&#xff1a;4 A5单元格&#xff1a; A6单元格&#xff1a;6 A7单元格&am…

详解道路标记数据集 CeyMo: See More on Roads -- A Novel Benchmark Dataset for Road Marking Detection

本文介绍一个新的道路标记检测数据集&#xff0c;论文收录于 WACV2022。Ceymo数据集总共包含2887张图片&#xff0c;标注了11类共4706个道路标记实例&#xff0c;图片分辨率为 192010801920\times108019201080。其中&#xff0c;对于每一个道路标记实例&#xff0c;作者采用了三…

VBA类之一(初识类)

第一章 开头篇 ——认识类 Visual Basic是基于对象的编程(注&#xff1a;本文所有的代码和讨论将都以VB为基础模型&#xff0c;不过我会尽量使用一些大家在VBA中常见的例子来做说明的。)&#xff0c;所以我们常见的一些东西其实都与类有关。不…

【HDU - 5009】Paint Pearls(dp,链表优化dp)

题干&#xff1a; Lee has a string of n pearls. In the beginning, all the pearls have no color. He plans to color the pearls to make it more fascinating. He drew his ideal pattern of the string on a paper and asks for your help. In each operation, he sele…

动手学无人驾驶(7):车道线检测

最近在研究视觉语义地图&#xff0c;需要进行车道线检测&#xff0c;发现这篇车道线检测论文效果蛮好的 &#xff08;Ultra Fast Structure-aware Deep Lane Detection&#xff09;。论文作者在知乎上已经介绍过了&#xff1a;https://zhuanlan.zhihu.com/p/157530787&#xff…

Coursera自动驾驶课程第16讲:LIDAR Sensing

在第15讲《Coursera自动驾驶课程第15讲&#xff1a;GNSS and INS Sensing for Pose Estimation》 我们学习了自动驾驶定位中常用的两种传感器&#xff1a;IMU&#xff08;惯性测量单元&#xff09; 和GNSS&#xff08;全球导航卫星系统&#xff09;。 本讲我们将学习自动驾驶汽…

DB、ETL、DW、OLAP、DM、BI关系结构图

在此大概用口水话简单叙述一下他们几个概念&#xff1a; &#xff08;1&#xff09;DB/Database/数据库——这里一般指的就是OLTP数据库&#xff0c;在线事物数据库&#xff0c;用来支持生产的&#xff0c;比如超市的买卖系统。DB保留的是数据信息的最新状态&#xff0c;只有一…

Tarjan 算法 常用模板

可以求每个点属于第几个强连通分量&#xff1a;https://blog.csdn.net/dellaserss/article/details/8267192 int Tarjan(int u){int v;dfn[u]low[u]Index;stack[Top]u;Instack[u]1;for(int i0;i<G[u].size();i){vG[u][i];if(!dfn[v]){Tarjan(v);low[u]min(low[u],low[v]);}…