题干:
Lee has a string of n pearls. In the beginning, all the pearls have no color. He plans to color the pearls to make it more fascinating. He drew his ideal pattern of the string on a paper and asks for your help.
In each operation, he selects some continuous pearls and all these pearls will be painted to their target colors. When he paints a string which has k different target colors, Lee will cost k 2 points.
Now, Lee wants to cost as few as possible to get his ideal string. You should tell him the minimal cost.
Input
There are multiple test cases. Please process till EOF.
For each test case, the first line contains an integer n(1 ≤ n ≤ 5×10 4), indicating the number of pearls. The second line contains a 1,a 2,...,a n (1 ≤ a i≤ 10 9) indicating the target color of each pearl.
Output
For each test case, output the minimal cost in a line.
Sample Input
3
1 3 3
10
3 4 2 4 4 2 4 3 2 2
Sample Output
2
7
题目大意:
给n个珍珠,每个珍珠刚开始没有颜色,每次操作可以任选连续的一段珍珠,然后涂上对应的颜色a[i],一次操作的代价是这一段珍珠中的颜色种数的平方。求每个珍珠被都涂色的最小代价。n<=5e4。
例:1 3 3
答:2
解题报告:
考虑dp。首先想到n^2的dp。然后考虑优化。因为每增加一个数字种类数,就要增加平方倍,所以种类数最多就是sqrt(1e5)这么多种类,再往前扫种类就没有意义了,因为还不如直接一个一个涂色。又因为从当前点 i 开始往前扫,数字种类数肯定是单调不减的,所以可以以每一个“颜色种类数”分块,这样有两个好处:一是优化了dp的搜索范围,二是块中的点一定是连续的(因为从后往前种类数单调不减),这也是为什么可以这样维护的原因。
下面考虑维护这些块:
方法1:先对每个数字都建一个块,也就是刚开始是最初的双向链表,发现当扫到第i个数字的时候,如果a[i]之前出现过,那么之前那个位置就没有用了,可以直接删除这个节点,合并对应的前驱和后继即可。也就是说现在链表中的每个数字的位置代表的是对应块的最后一个位置pos,代表的含义是先涂色到pos,然后pos+1一直到 i 用一次涂色。所以对应两个细节:先更新dp值再cnt++;维护链表的时候这样可以做到块的代表元是当前块的最后一个元素。换句话说,这样跳表,每次跳到的pos是 这个数字a[pos] 在后缀中第一次出现的位置。赋初值dp[0]=0别忘了。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<list>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int INF = 0x3f3f3f3f;
const int MAX = 2e5 + 5;
int n;
int dp[MAX],a[MAX];
const int UP = 250;
int pre[MAX],ne[MAX];
map<int,int> mp;
int main()
{while(~scanf("%d",&n)) {for(int i = 1; i<=n; i++) scanf("%d",a+i),pre[i] = i-1,ne[i] = i+1,dp[i] = INF;pre[0]=ne[n]=-1;mp.clear();for(int i = 1; i<=n; i++) {if(mp.find(a[i]) == mp.end()) mp[a[i]]=i;else {ne[pre[mp[a[i]]]] = ne[mp[a[i]]];pre[ne[mp[a[i]]]] = pre[mp[a[i]]];mp[a[i]]=i;}int cnt = 1;for(int j = pre[i]; ~j; j=pre[j]) {dp[i] = min(dp[i],dp[j] + cnt*cnt);cnt++;if(cnt > UP) break;}}printf("%d\n",dp[n]);}return 0 ;
}