题干:
A coding contest will be held in this university, in a huge playground. The whole playground would be divided into N blocks, and there would be M directed paths linking these blocks. The i-th path goes from the uiui-th block to the vivi-th block. Your task is to solve the lunch issue. According to the arrangement, there are sisicompetitors in the i-th block. Limited to the size of table, bibi bags of lunch including breads, sausages and milk would be put in the i-th block. As a result, some competitors need to move to another block to access lunch. However, the playground is temporary, as a result there would be so many wires on the path.
For the i-th path, the wires have been stabilized at first and the first competitor who walker through it would not break the wires. Since then, however, when a person go through the i - th path, there is a chance of pipi to touch
the wires and affect the whole networks. Moreover, to protect these wires, no more than cici competitors are allowed to walk through the i-th path.
Now you need to find a way for all competitors to get their lunch, and minimize the possibility of network crashing.
Input
The first line of input contains an integer t which is the number of test cases. Then t test cases follow.
For each test case, the first line consists of two integers N (N ≤ 100) and M (M ≤ 5000). Each of the next N lines contains two integers si and bibi (sisi , bibi ≤ 200).
Each of the next M lines contains three integers uiui , vivi and ci(cici(ci ≤ 100) and a float-point number pipi(0 < pipi < 1).
It is guaranteed that there is at least one way to let every competitor has lunch.
Output
For each turn of each case, output the minimum possibility that the networks would break down. Round it to 2 digits.
Sample Input
1
4 4
2 0
0 3
3 0
0 3
1 2 5 0.5
3 2 5 0.5
1 4 5 0.5
3 4 5 0.5
Sample Output
0.50
题目大意:
给定n个点,m条有向边,每个点是一个吃饭的地方,每个人一盒饭。每个点有S个人,有B盒饭。每条边只能被走c次,每条边上都有电线,
第一个人通过的时候,不会破坏电线,从第二个人开始,每次都有概率p破坏掉电线。使得每个人都能吃饭,求最小破坏电线的概率。
解题报告:
最大费用最大流
AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<unordered_map>
#define mod (1000000007)
using namespace std;
typedef long long ll;
const int MAX = 2e5 + 5;
const int inf = 0x3f3f3f3f;
struct node {int u,v,f,nxt;double w;
} e[50005<<2];
int n,m,N;
int head[MAX],vis[MAX],tot=1,p[MAX];
double d[MAX];
void add(int u,int v,int f,double cost=0.0) {e[++tot].v = v;e[tot].u = u;e[tot].f = f;e[tot].w = cost;e[tot].nxt = head[u];head[u] = tot;e[++tot].v = u;e[tot].u = v;e[tot].f = 0; e[tot].w = -cost;e[tot].nxt = head[v];head[v] = tot;
}
bool bfs(int s,int t) {for(int i = 0; i<=N; i++) d[i]=0,vis[i]=0;d[s]=1;queue<int>q;q.push(s);while(!q.empty()) {int u=q.front();q.pop();vis[u]=0;for(int i=head[u]; ~i; i=e[i].nxt) {int j=e[i].v;if(e[i].f&&d[j]<d[u]*e[i].w) {d[j]=d[u]*e[i].w;p[j]=i;if(!vis[j])vis[j]=1,q.push(j);}}}return d[t]>0;
}
double MCMF(int s,int t,int &flow) {double ans=1;while(bfs(s,t)) {int x=t,f=inf;while(x!=s) {f = min(f,e[p[x]].f),x=e[p[x]^1].v;}flow += f;ans*=pow(d[t],f);x=t;while(x!=s) {e[p[x]].f-=f,e[p[x]^1].f+=f;x=e[p[x]^1].v;}}return ans;
}int main() {int t;cin>>t;while(t--){scanf("%d%d",&n,&m);int st=0,ed=n+1,fl=0,x;N=ed;tot=1;for(int i=0;i<=ed;i++) head[i]=-1;for(int i=1;i<=n;i++){double s,b;scanf("%lf%lf",&s,&b);add(st,i,s,1);add(i,ed,b,1);}double ci,pi;for(int i=1;i<=m;i++){int u,v;scanf("%d%d%lf%lf",&u,&v,&ci,&pi);add(u,v,1,1);add(u,v,ci-1,1-pi);}printf("%.2f\n",1-MCMF(st,ed,fl));}return 0 ;
}