题目:
给定一个N x M的01矩阵,其中1表示陆地,0表示水域。对于每一个位置,求出它距离最近的水域的距离是多少。
矩阵中每个位置与它上下左右相邻的格子距离为1。
Input
第一行包含两个整数,N和M。
以下N行每行M个0或者1,代表地图。
数据保证至少有1块水域。
对于30%的数据,1 <= N, M <= 100
对于100%的数据,1 <= N, M <= 800
Output
输出N行,每行M个空格分隔的整数。每个整数表示该位置距离最近的水域的距离。
Sample Input
4 4
0110
1111
1111
0110
Sample Output
0 1 1 0
1 2 2 1
1 2 2 1
0 1 1 0
分析:
拿到题我最先想到的使用记忆化搜索,但由于没有条件限制,导致回路陷入死循环,用book标记后,交上去超时了,下来补题求教后,这道题用广搜。
1.利用队列先进先出的性质,先将所有水域地点存入队列中,走过的存入队列,这样自然就求的点最近的水域的距离。
AC代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
const int M=8e2+10;
int n,m;
char s[M][M];
int dp[M][M];
bool book[M][M];
int c[4][2]= {0,1,0,-1,1,0,-1,0};
struct node
{int x,y,step;
};
void bfs()
{queue<node>q;node u,v;for(int i=0; i<n; i++)for(int j=0; j<m; j++){if(s[i][j]=='0'){book[i][j]=1;u.x=i;u.y=j;u.step=0;dp[i][j]=0;q.push(u);}}while(!q.empty()){u=q.front();q.pop();for(int i=0; i<4; i++){int a=u.x+c[i][0];int b=u.y+c[i][1];if(a<0||b<0||a>=n||b>=m||book[a][b])continue;book[a][b]=1;v.x=a;v.y=b;v.step=u.step+1;dp[a][b]=v.step;q.push(v);}}
}
int main()
{scanf("%d%d",&n,&m);for(int i=0; i<n; i++)scanf("%s",s[i]);bfs();for(int i=0; i<n; i++)for(int j=0; j<m; j++)j==m-1?printf("%d\n",dp[i][j]):printf("%d ",dp[i][j]);return 0;
}