题意:
给你n个数,然后问一段区间的最大的差值是多少。
题目:
For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Line 1: Two space-separated integers, N and Q.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
分析:
基本模板,但容易进入思维误区,区间最大和最小分开查询,最后求差值。
AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int M=4e5+10;
int t,n,m,l,r;
int dp[M],s[M];
void build(int l,int r,int x)
{if(l==r){int a;scanf("%d",&a);dp[x]=s[x]=a;return;}int mid=(l+r)>>1;build(l,mid,x<<1);build(mid+1,r,x<<1|1);dp[x]=max(dp[x<<1],dp[x<<1|1]);s[x]=min(s[x<<1],s[x<<1|1]);
}
int query(int mi,int ma,int l,int r,int x)
{if(mi<=l&&ma>=r)return s[x];int mid=(r+l)>>1;int ans=inf;if(mid>=mi)ans=query(mi,ma,l,mid,x<<1);if(mid<ma)ans=min(ans,query(mi,ma,mid+1,r,x<<1|1));return ans;
}
int update(int mi,int ma,int l,int r,int x)
{if(l>=mi&&r<=ma)return dp[x];int mid=(r+l)>>1;int ans=-inf;if(mi<=mid)ans=update(mi,ma,l,mid,x<<1);if(ma>mid)ans=max(ans,update(mi,ma,mid+1,r,x<<1|1));return ans;
}
int main()
{scanf("%d%d",&n,&m);build(1,n,1);while(m--){scanf("%d%d",&l,&r);printf("%d\n",update(l,r,1,n,1)-query(l,r,1,n,1));}return 0;
}