Assign the task HDU - 3974(线段树+dfs建树+单点查询+区间修改)

题意:

染色问题:给一个固定结构的树,现在有两个操作:
(1) y 将结点x及其所有后代结点染成颜色y;
(2)查询结点x当前的颜色。
其实就是区间染色问题,不过需要dfs预处理,

题目:

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

“C x” which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3

Sample Output

Case #1:
-1
1
2

分析:

1.由于题目给的是一个固定的树,所以我们需要对它进行处理,使之成为我们好处理的区间问题。
2.关于预处理我采用的是先用vector容器进行存边,之后dfs,用两个数组分别存储以某点为“”祖宗节点“”的区间起始(类似时间戳的思想,将某个点的编号)
3.预处理之后就是线段树模板啦嘿嘿,这个没啥好说的,这里不再赘述: 区间修改+单点查询

AC代码:

#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
const int M=5e4+10;
int t,n,m,ans,a,b,k;
vector<int>ve[M];
int L[M],R[M],dp[M<<2],lazy[M<<2];
bool vis[M];
char s[5];
void dfs(int x)
{L[x]=++ans;for(int i=0; i<ve[x].size(); i++)dfs(ve[x][i]);R[x]=ans;
}
void pushdown(int x)
{if(lazy[x]){lazy[x<<1]=lazy[x<<1|1]=lazy[x];dp[x<<1]=dp[x<<1|1]=dp[x];lazy[x]=0;}
}
void update(int mi,int ma,int l,int r,int x,int value)
{if(l>=mi&&r<=ma){dp[x]=lazy[x]=value;return;}pushdown(x);int mid=(l+r)>>1;if(mid>=mi)update(mi,ma,l,mid,x<<1,value);if(mid<ma)update(mi,ma,mid+1,r,x<<1|1,value);
}
int query(int now,int l,int r,int x)//单点修改
{if(l==r)return dp[x];pushdown(x);int mid=(l+r)>>1;if(mid>=now)return query(now,l,mid,x<<1);elsereturn query(now,mid+1,r,x<<1|1);
}
int main()
{scanf("%d",&t);k=0;while(t--){ans=0;memset(dp,-1,sizeof(dp));memset(lazy,0,sizeof(lazy));memset(vis,false,sizeof(vis));scanf("%d",&n);for(int i=1; i<=n; i++)ve[i].clear();for(int i=0; i<n-1; i++){int u,v;scanf("%d%d",&u,&v);ve[v].push_back(u);//接下来的N-1行每行包含两个整数u和v,这表示雇员v是雇员u(1 <= u,v <= N)的直接老板。vis[u]=true;}for(int i=1; i<=n; i++)if(!vis[i])dfs(i);scanf("%d",&m);printf("Case #%d:\n",++k);while(m--){scanf("%s",s);if(s[0]=='C'){scanf("%d",&a);printf("%d\n",query(L[a],1,ans,1));}else{scanf("%d%d",&a,&b);update(L[a],R[a],1,ans,1,b);}}}return 0;
}

备战ing,题目分析简略,见谅,转载请注明出处。。。。。

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/309616.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

Docker镜像讲解

此篇为Docker笔记&#xff0c;文章可能存在疏忽&#xff0c;建议直接观看原视频。 视频地址&#xff1a;https://www.bilibili.com/video/BV1og4y1q7M4?spm_id_from333.999.0.0 参考&#xff1a;https://blog.csdn.net/11b202/article/details/21389067 Docker镜像讲解 镜像是…

Making the Grade POJ - 3666(离散化+dp)

题意&#xff1a; 给你n个山的高度&#xff0c;单独的一个数可以任意加减&#xff0c;让经过对每座山峰任意加减高度后变成递增或递减的序列时&#xff0c;求对每个数的相加或相减的数目的最小和。 题目&#xff1a; A straight dirt road connects two fields on FJ’s far…

Kubernetes的安全性怎么解?从4个方面为你列出方案清单

导语Kubernetes中的安全性是一个多维问题&#xff0c;必须从各个不同的角度来解决才算完善&#xff0c;这篇文章将从4个方面为读者列出安全清单。正文Kubernetes&#xff0c;经过更快的采用和社区的更多贡献&#xff0c;正日益攀登到新的高度。不过&#xff0c;安全性仍然是Kub…

DDIA笔记—第六章 数据分区

第六章 数据分区 数据分区与数据复制 分区通常与复制结合使用&#xff0c;即每个分区在多个节点都存在副本&#xff0c;这就意味着某条记录属于特定的分区&#xff0c;而同样的内容会保存在不同的节点上以提高系统的容错性。 每个节点同时充当某些分区的主副本和其他分区的从…

Piggy-Bank POJ - 1384(完全背包+背包放满)

题意&#xff1a; 给出一个存钱罐的重量和没存钱之前存钱罐的重量&#xff0c;然后给出几种硬币的重量和币值&#xff0c;计算存钱罐里至少有多少钱。 题目&#xff1a; Before ACM can do anything, a budget must be prepared and the necessary financial support obtain…

Magicodes.IE 2.2发布

Magicodes.IE 2.2发布导入导出通用库&#xff0c;支持DTO导入导出以及动态导出&#xff0c;支持Excel、Word、PDF、CSV和HTML。已加入ncc开源组织.Magicodes.IE2.0发布Magicodes.IE2.1发布如何做好一个开源项目(一)GitHub&#xff1a;https://github.com/dotnetcore/Magicodes.…

C++ 基类,子对象,派生类构造函数调用顺序

#include <iostream> using namespace std;class A {public:A( ) {cout << "A Constructor………" << endl;}~A( ) {cout << "A Destructor………" << endl;} };class B: public A {public:B( ) {cout << "B …

牛客网 第十七届中国计量大学程序设计竞赛(同步赛)(重现赛)B题 Broken Pad 暴力+思维

题意&#xff1a; 给你两个01串&#xff0c;经过两种操作&#xff0c;1.直接让第一串经过操作变成目标串&#xff1b;2.可以点击空白处&#xff0c;即0的地方&#xff0c;使得操作串全部清空为0串&#xff0c;再变为目标串&#xff1b;最终比较两种方式&#xff0c;哪种需更少…

C++ 虚析构函数

代码如下: #include <iostream> using namespace std;class Base {public:Base() {cout << "Base" << endl;}~Base() {cout << "Base destructor" << endl;} };class Derived : public Base {public:Derived() {cout <&…

I - Interesting Permutation Gym - 102394I(排列组合)

题意&#xff1a; 纯数题 1≤i≤n, fimax{a1,a2,…,ai}; 1≤i≤n, gimin{a1,a2,…,ai}; 1≤i≤n, hifi−gi. 数列a是一个排列&#xff0c;问多少种排列方式满足h数列。 题目&#xff1a; DreamGrid has an interesting permutation of 1,2,…,n denoted by a1,a2,…,an. He …

Magicodes.SwaggerUI 已支持.NET Core 3.1

Magicodes.SwaggerUI 通过配置文件简单配置即可快速完成SwaggerUI的配置&#xff0c;包括&#xff1a;SwaggerUI的文档信息API分组API隐藏API JSON生成&#xff08;枚举、API架构Id&#xff09;验证自定义页面支持.NET Core 2.2和3.1。版本日志和使用教程见下文。注意&#xff…

PTA天梯赛L1-006 连续因子 (20分)

题目&#xff1a; 一个正整数 N 的因子中可能存在若干连续的数字。例如 630 可以分解为 3567&#xff0c;其中 5、6、7 就是 3 个连续的数字。给定任一正整数 N&#xff0c;要求编写程序求出最长连续因子的个数&#xff0c;并输出最小的连续因子序列。 输入格式&#xff1a; …

C++ 多态实现的三个条件

多态实现的三个条件&#xff1a; 1.必须是公有继承 2.必须是通过基类的指针或引用 指向派生类对象 访问派生类方法 3.基类的方法必须是虚函数&#xff0c;且完成了虚函数的重写

[推荐]大量 Blazor 学习资源(二)

继上一篇《[推荐]大量 Blazor 学习资源&#xff08;一&#xff09;》之后&#xff0c;社区反应不错&#xff0c;但因个人原因导致这篇文章姗姗来迟&#xff0c;不过最终还是来了&#xff01;这篇文章主要收集一些常用组件、书籍和电子书。资料来源&#xff1a;https://github.c…

Golang实现最大堆/最小堆

Golang实现最大堆/最小堆 参考&#xff1a; https://yangjiahao106.github.io/2019/01/15/golang-%E6%9C%80%E5%A4%A7%E5%A0%86%E5%92%8C%E6%9C%80%E5%B0%8F%E5%A0%86/ https://studygolang.com/articles/24288 方法一 此方法就是比较传统、常见的方法&#xff0c;下面来构建一…

团体程序设计天梯赛-练习集L1-011 A-B (20分)getline输入

little tips&#xff1a;关于天梯赛不能用gets 题目&#xff1a; 本题要求你计算A−B。不过麻烦的是&#xff0c;A和B都是字符串 —— 即从字符串A中把字符串B所包含的字符全删掉&#xff0c;剩下的字符组成的就是字符串A−B。 输入格式&#xff1a; 输入在2行中先后给出字…

Sql Server之旅——第八站 看公司这些DBA们设计的这些复合索引

这一篇再说下索引的最后一个主题&#xff0c;索引覆盖&#xff0c;当然学习比较好的捷径是看看那些大师们设计的索引&#xff0c;看从中能提取些什么营养的东西&#xff0c;下面我们看看数据库中一个核心的Orders表。一&#xff1a;查看表的架构1. 先查看这个表的大概架构信息-…

C++ setprecision()用法

io 流控制头文件, 主要是一些操纵用法如setw(int n),setprecision(int n) #include < iomanip > setw(n)用法&#xff1a; 通俗地讲就是预设宽度 #include<iostream> #include <iomanip> using namespace std;int main() {cout << setw(5) <<…