Just a Hook HDU - 1698(查询区间求和+最基础模板)

题意:

给你一个1~n的区间,起始区间内均为1,然后对子区间进行值更新,最后求区间和。

题目:

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
在这里插入图片描述

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

分析:

基础简单模板,懒惰标记下行要注意一下。

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int M=4e5+10;
int t,n,m,l,r,value,k;
int dp[M],lazy[M];
void build(int l,int r,int x)
{if(l==r){dp[x]=1;return;}int mid=(l+r)>>1;build(l,mid,x<<1);build(mid+1,r,x<<1|1);dp[x]=dp[x<<1]+dp[x<<1|1];
}
void pushdown(int x,int len)
{if(lazy[x]){lazy[x<<1]=lazy[x<<1|1]=lazy[x];dp[x<<1]=lazy[x]*(len-(len>>1));dp[x<<1|1]=lazy[x]*(len>>1);lazy[x]=0;}
}
void update(int mi,int ma,int l,int r,int x,int value)
{if(l>=mi&&r<=ma){dp[x]=value*(r-l+1);lazy[x]=value;return;}pushdown(x,r-l+1);int mid=(r+l)>>1;if(mi<=mid)update(mi,ma,l,mid,x<<1,value);if(ma>mid)update(mi,ma,mid+1,r,x<<1|1,value);dp[x]=dp[x<<1]+dp[x<<1|1];
}
int main()
{k=0;scanf("%d",&t);while(t--){memset(lazy,0,sizeof(lazy));scanf("%d%d",&n,&m);build(1,n,1);while(m--){scanf("%d%d%d",&l,&r,&value);update(l,r,1,n,1,value);}printf("Case %d: The total value of the hook is %d.\n",++k,dp[1]);}return 0;
}

备战ing,题目分析简略,见谅,转载请注明出处。。。。。

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/309621.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

DDIA笔记——数据复制

Table of Contents generated with DocToc 此篇为《数据密集型应用系统设计》&#xff08;DDIA&#xff09;读书笔记&#xff0c;笔记可能存在遗漏&#xff0c;建议直接阅读原书。 第五章 数据复制 主从复制 复制滞后复制滞后带来的问题 多主节点复制 适用场景处理写冲突拓扑结…

基于 abp vNext 和 .NET Core 开发博客项目 - 集成Hangfire实现定时任务处理

上一篇文章成功使用了Redis缓存数据&#xff0c;大大提高博客的响应性能。接下来&#xff0c;将完成一个任务调度中心&#xff0c;关于定时任务有多种处理方式&#xff0c;如果你的需求比较简单&#xff0c;比如就是单纯的过多少时间循环执行某个操作&#xff0c;可以直接使用.…

Docker基本组成 和 基本命令

此篇为Docker笔记&#xff0c;文章可能存在疏忽&#xff0c;建议直接观看原视频。 视频地址&#xff1a;https://www.bilibili.com/video/BV1og4y1q7M4?spm_id_from333.999.0.0 Docker基本组成 和 基本命令 镜像 image&#xff1a;就好比一个模板&#xff0c;可以通过这个模板…

Assign the task HDU - 3974(线段树+dfs建树+单点查询+区间修改)

题意&#xff1a; 染色问题&#xff1a;给一个固定结构的树&#xff0c;现在有两个操作&#xff1a; &#xff08;1&#xff09; y 将结点x及其所有后代结点染成颜色y&#xff1b; &#xff08;2&#xff09;查询结点x当前的颜色。 其实就是区间染色问题&#xff0c;不过需要d…

Docker镜像讲解

此篇为Docker笔记&#xff0c;文章可能存在疏忽&#xff0c;建议直接观看原视频。 视频地址&#xff1a;https://www.bilibili.com/video/BV1og4y1q7M4?spm_id_from333.999.0.0 参考&#xff1a;https://blog.csdn.net/11b202/article/details/21389067 Docker镜像讲解 镜像是…

Making the Grade POJ - 3666(离散化+dp)

题意&#xff1a; 给你n个山的高度&#xff0c;单独的一个数可以任意加减&#xff0c;让经过对每座山峰任意加减高度后变成递增或递减的序列时&#xff0c;求对每个数的相加或相减的数目的最小和。 题目&#xff1a; A straight dirt road connects two fields on FJ’s far…

Kubernetes的安全性怎么解?从4个方面为你列出方案清单

导语Kubernetes中的安全性是一个多维问题&#xff0c;必须从各个不同的角度来解决才算完善&#xff0c;这篇文章将从4个方面为读者列出安全清单。正文Kubernetes&#xff0c;经过更快的采用和社区的更多贡献&#xff0c;正日益攀登到新的高度。不过&#xff0c;安全性仍然是Kub…

DDIA笔记—第六章 数据分区

第六章 数据分区 数据分区与数据复制 分区通常与复制结合使用&#xff0c;即每个分区在多个节点都存在副本&#xff0c;这就意味着某条记录属于特定的分区&#xff0c;而同样的内容会保存在不同的节点上以提高系统的容错性。 每个节点同时充当某些分区的主副本和其他分区的从…

Piggy-Bank POJ - 1384(完全背包+背包放满)

题意&#xff1a; 给出一个存钱罐的重量和没存钱之前存钱罐的重量&#xff0c;然后给出几种硬币的重量和币值&#xff0c;计算存钱罐里至少有多少钱。 题目&#xff1a; Before ACM can do anything, a budget must be prepared and the necessary financial support obtain…

Magicodes.IE 2.2发布

Magicodes.IE 2.2发布导入导出通用库&#xff0c;支持DTO导入导出以及动态导出&#xff0c;支持Excel、Word、PDF、CSV和HTML。已加入ncc开源组织.Magicodes.IE2.0发布Magicodes.IE2.1发布如何做好一个开源项目(一)GitHub&#xff1a;https://github.com/dotnetcore/Magicodes.…

C++ 基类,子对象,派生类构造函数调用顺序

#include <iostream> using namespace std;class A {public:A( ) {cout << "A Constructor………" << endl;}~A( ) {cout << "A Destructor………" << endl;} };class B: public A {public:B( ) {cout << "B …

牛客网 第十七届中国计量大学程序设计竞赛(同步赛)(重现赛)B题 Broken Pad 暴力+思维

题意&#xff1a; 给你两个01串&#xff0c;经过两种操作&#xff0c;1.直接让第一串经过操作变成目标串&#xff1b;2.可以点击空白处&#xff0c;即0的地方&#xff0c;使得操作串全部清空为0串&#xff0c;再变为目标串&#xff1b;最终比较两种方式&#xff0c;哪种需更少…

C++ 虚析构函数

代码如下: #include <iostream> using namespace std;class Base {public:Base() {cout << "Base" << endl;}~Base() {cout << "Base destructor" << endl;} };class Derived : public Base {public:Derived() {cout <&…

I - Interesting Permutation Gym - 102394I(排列组合)

题意&#xff1a; 纯数题 1≤i≤n, fimax{a1,a2,…,ai}; 1≤i≤n, gimin{a1,a2,…,ai}; 1≤i≤n, hifi−gi. 数列a是一个排列&#xff0c;问多少种排列方式满足h数列。 题目&#xff1a; DreamGrid has an interesting permutation of 1,2,…,n denoted by a1,a2,…,an. He …

Magicodes.SwaggerUI 已支持.NET Core 3.1

Magicodes.SwaggerUI 通过配置文件简单配置即可快速完成SwaggerUI的配置&#xff0c;包括&#xff1a;SwaggerUI的文档信息API分组API隐藏API JSON生成&#xff08;枚举、API架构Id&#xff09;验证自定义页面支持.NET Core 2.2和3.1。版本日志和使用教程见下文。注意&#xff…

PTA天梯赛L1-006 连续因子 (20分)

题目&#xff1a; 一个正整数 N 的因子中可能存在若干连续的数字。例如 630 可以分解为 3567&#xff0c;其中 5、6、7 就是 3 个连续的数字。给定任一正整数 N&#xff0c;要求编写程序求出最长连续因子的个数&#xff0c;并输出最小的连续因子序列。 输入格式&#xff1a; …

C++ 多态实现的三个条件

多态实现的三个条件&#xff1a; 1.必须是公有继承 2.必须是通过基类的指针或引用 指向派生类对象 访问派生类方法 3.基类的方法必须是虚函数&#xff0c;且完成了虚函数的重写