stl set实现字符串搜索。。效率一般。(附二分搜索。)
Time limit: | 1sec. | Submitted: | 233 |
Memory limit: | 32M | Accepted: | 81 |
You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a alien born less lien never nevertheless new newborn the zebraSample Output
alien newborn
说明:
在给出的词中找出可有有任意另外两个词拼接而成的词输出。
用set存储与搜索。
代码如下:
#include<iostream>
#include<set>
using namespace std;
int main() {
set<string> s;
string tmp;
while (cin >> tmp)
s.insert(tmp);
set<string>::iterator it = s.begin();
for (it; it != s.end(); it++) {
tmp = *it;
for (int i = 1; i < tmp.length(); i++) {
if (s.find(tmp.substr(0, i)) != s.end() && s.find(tmp.substr(i, tmp.length() - i)) != s.end()) {
cout << tmp << endl;
break;
}
}
}
return 0;
}
#include<set>
using namespace std;
int main() {
set<string> s;
string tmp;
while (cin >> tmp)
s.insert(tmp);
set<string>::iterator it = s.begin();
for (it; it != s.end(); it++) {
tmp = *it;
for (int i = 1; i < tmp.length(); i++) {
if (s.find(tmp.substr(0, i)) != s.end() && s.find(tmp.substr(i, tmp.length() - i)) != s.end()) {
cout << tmp << endl;
break;
}
}
}
return 0;
}
二分实现。效率高很多。。
View Code
#include<stdio.h>
#include<string.h>
char ss[120010][50];
bool Bsearch(char *s, int n);
int main() {
char s1[100], *s2;
int i = 0, j, k, n, len;
while (scanf("%s", ss[i]) != EOF) i++;
n = i;
for (i = 0; i < n; i++) {
len = strlen(ss[i]);
for (j = 0, k = 0; j < len - 1; j++) {
s1[k++] = ss[i][j];
s1[k] = '\0';
s2 = ss[i] + j + 1;
if (Bsearch(s1, n) && Bsearch(s2, n)) {
puts(ss[i]);
break;
}
}
}
return 0;
}
bool Bsearch(char *s, int n) {
int left = 0, right = n - 1, middle, r;
while (left <= right) {
middle = (left + right) / 2;
r = strcmp(s, ss[middle]);
if (r == 0) return true;
if (r < 0)
right = middle - 1;
else
left = middle + 1;
}
return false;
}
#include<string.h>
char ss[120010][50];
bool Bsearch(char *s, int n);
int main() {
char s1[100], *s2;
int i = 0, j, k, n, len;
while (scanf("%s", ss[i]) != EOF) i++;
n = i;
for (i = 0; i < n; i++) {
len = strlen(ss[i]);
for (j = 0, k = 0; j < len - 1; j++) {
s1[k++] = ss[i][j];
s1[k] = '\0';
s2 = ss[i] + j + 1;
if (Bsearch(s1, n) && Bsearch(s2, n)) {
puts(ss[i]);
break;
}
}
}
return 0;
}
bool Bsearch(char *s, int n) {
int left = 0, right = n - 1, middle, r;
while (left <= right) {
middle = (left + right) / 2;
r = strcmp(s, ss[middle]);
if (r == 0) return true;
if (r < 0)
right = middle - 1;
else
left = middle + 1;
}
return false;
}