描述
A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.(回文字符串)
A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I"are their own reverses, and "3" and "E" are each others' reverses.(镜像字符串)
A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string"ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.
Of course,"A","T", "O", and "Y" are all their own reverses.
A list of all valid characters and their reverses is as follows.
Note that 0 (zero) and O (the letter) are NOT considered the same character and therefore ONLY the letter "O" is a valid character.
输入
Input consists of several strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings, except some speical cases. Your program should read to the end of file.
输出
For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.
STRING CRITERIA " -- is not a palindrome." if the string is not a palindrome and is not a mirrored string " -- is a regular palindrome." if the string is a palindrome and is not a mirrored string " -- is a mirrored string." if the string is not a palindrome and is a mirrored string " -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.
In addition, after each output line, you must print an empty line.
样例输入
NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA
样例输出
NOTAPALINDROME -- is not a palindrome.ISAPALINILAPASI -- is a regular palindrome.2A3MEAS -- is a mirrored string.ATOYOTA -- is a mirrored palindrome.
思路
此题要注意在处理镜像字符串,我们在遍历每个字符时,记为c,若c没有对应的反转字符,则此字符忽略,在我的代码中体现在不加入到temp中
#define _CRT_SECURE_NO_WARNINGS 1
#include<iostream>
#include<string>
#include<algorithm>
#include <unordered_map>
using namespace std;
unordered_map<char, char> orignial_reverse{ {'A','A'},{'E','3'},{'H','H'},{'I','I'},\
{'J','L'},{'L','J'},{'M','M'},{'O','O'},{'S','2'},{'T','T'},{'U','U'},{'V','V'},\
{'W','W'},{'X','X'},{'Y','Y'},{'Z','5'},{'1','1'},{'2','S'},{'3','E'},{'5','Z'},\
{'8','8'} };
bool reverse_string(string input) {string temp=input;reverse(input.begin(), input.end());if (temp == input) return true;else return false;
}
bool mirror_string(string input) {string temp;for (char c:input) {auto it = orignial_reverse.find(c);if (it != orignial_reverse.end()) temp.push_back(it->second);}reverse(temp.begin(), temp.end());if (temp == input) return true;else return false;
}
int main()
{string input;while (getline(cin, input)) {bool flag1 = reverse_string(input);bool flag2 = mirror_string(input);if (!flag1 && !flag2) {cout << input << " -- is not a palindrome.\n" << endl;}else if (flag1 && !flag2) cout << input << " -- is a regular palindrome.\n" << endl;else if (!flag1 && flag2) cout << input << " -- is a mirrored string.\n" << endl;else if (flag1 && flag2) cout << input << " -- is a mirrored palindrome.\n" << endl;}return 0;
}