一,实验目的
在路由器的一个接口上通过配置子接口的方式,实现相互隔离的不同vlan之间互通。
二,设备配置
Switch1
Switch>enable 全局模式
Switch#configure terminal 配置模式
Switch(config)#vlan 10 创建vlan10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface f0/1 进入f0/1端口
Switch(config-if)#switchport mode access 将端口配置为access模式
Switch(config-if)#switchport access vlan 10 将端口放入vlan10
Switch(config-if)#exit
Switch(config)#interface range f0/2-3 进入f0/2,f0/3端口
Switch(config-if-range)#switchport mode trunk 将端口配置为trunk模式
Switch(config-if-range)#switchport trunk allowed vlan all 允许所有vlan通过
Switch(config-if-range)#end 退回全局
Switch#show running-config 查看配置
Switch2
Switch>enable
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface f0/2
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#end
Switch#show running-config
Router
Router>enable
Router#configure terminal
Router(config)#interface f0/0
Router(config-if)#no shutdown 开启该主端口
Router(config-if)#exit
Router(config)#int f0/0.10 创建子端口
Router(config-subif)#encapsulation dot1Q 10 封装vlan10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0 配置子端口网关
Router(config-subif)#exit
Router(config)#int f0/0.20 创建子端口
Router(config-subif)#encapsulation dot1Q 20 封装vlan20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0 配置子端口网关
Router(config-subif)#end
Router#show running-config
三,实验测试
PC1能够ping通PC2
四,优缺点分析
优点
- 实现不同vlan之间的通信:在VLAN划分后,不同VLAN之间不能直接通信,通过配置单臂路由可以实现不同VLAN之间的通信,满足了网络互通的需求。
- 扩展性强:单臂路由可以通过增加路由模块来扩展路由器的路由能力,从而支持更多的VLAN和用户。
- 灵活性高:单臂路由可以根据实际需求灵活配置路由规则,实现不同VLAN之间的灵活通信。
缺点
- 资源利用率低:由于单臂路由采用共享带宽的方式,所有接入的用户共享带宽资源,当用户数量较多时,带宽资源会变得非常紧张,导致网络性能下降。
- 管理复杂:单臂路由需要配置和管理多个VLAN的路由规则,相对于其他路由方式,管理更加复杂,需要较高的网络管理技能。
- 容易成为网络瓶颈:由于单臂路由采用共享带宽的方式,当用户数量较多时,路由器的路由能力会成为网络瓶颈,导致网络性能下降。