题目描述
输入
第二行输入N个无序的整数。
输出
示例输入
6 33 6 22 9 44 5
示例输出
5 6 9 22 33 44
提示
不得使用数组!
#include <iostream>
#include<bits/stdc++.h>
using namespace std;
struct node
{
int data;
node *next;
};
node *create(int n)
{
node *head,*tail,*p;
head=new node;
head->next=NULL;
tail=head;
for(int i=0;i<n;i++)
{
p=new node;
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
}
void print(node *head)
{
node *p=head->next;
while(p)
{
if(p->next==NULL)
printf("%d\n",p->data);
else
printf("%d ",p->data);
p=p->next;
}
}
node *sort(node *head)//有序链表的建立。
{
node *p,*q;
int t;
for(p=head->next;p;p=p->next)
for(q=p->next;q;q=q->next)
if(p->data>q->data)
{
t=p->data;
p->data=q->data;
q->data=t;
}
return head;
}
int main()
{
int n;
scanf("%d",&n);
node *h,*q;
h=create(n);
q=sort(h);
print(q);
return 0;
}