Message Flood

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

示例输出

3

来源



#include <iostream>
#include<string>
#include<algorithm>
#include<memory.h>
using namespace std;
bool cmp(string a,string b)//字符串的比较;
{
    return a<b;//升序比较;
}
string name[20001],t;//string定义字符串变量;
bool found [20001];
int n,m;
bool bi_search()//二分法查找;
{
    int start=0,mid,end=n-1;
    while(start<=end)
    {
        mid=(start+end)/2;
        if(t==name[mid])
        {
            if(!found[mid])
            {


            found[mid]=true;//查找到;
            return true;
            }
        else
            return false;
        }
        else if(t<name[mid])//前端查找;
            end=mid-1;
        else//后端查找;
            start=mid+1;
    }
    return false;
}
int main()
{
    int i,count;//统计剩下的人名;
    while(cin>>n&&n)
    {
        cin>>m;
        memset(found,false,sizeof(found));
        //memset(found,false,20001*sizeof(bool);//初始化;
        for(i=0;i<n;i++)
        {
            cin>>name[i];
            for(int j=0;j<name[i].length();j++)
                if(name[i][j]>='A'&&name[i][j]<='Z')
                name[i][j]+=32;
               // name[i][j]=tolower(name[i][j]);//将大写字符变为小写字符;
        }
        count=n;
        sort(name,name+n,cmp);//按照字典序升序排列;
        for(i=0;i<m;i++)
        {
            cin>>t;
            for(int j=0;j<t.length();j++)
                t[j]=tolower(t[j]);//将大写字符变为小写字符;
            if(bi_search())
                count--;
        }
       cout<<count<<endl;
    }
}

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/509387.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

关联和依赖的区别

最近研究设计模式&#xff0c;看类图有点发虚&#xff01;有些关系搞的不是很清楚。所以整理一下&#xff1a; 类与类之间由弱到强关系是: 没关系 > 依赖 > 关联 > 聚合 > 组合。 类和类之间八竿子打不着那就是没关系&#xff0c;这个没啥歧义。 依赖(dependenc…

Mybatis解决jdbc编程的问题以及mybatis与hibernate的不同

Mybatis解决jdbc编程的问题: 1、 数据库连接创建、释放频繁造成系统资源浪费从而影响系统性能&#xff0c;如果使用数据库连接池可解决此问题。 解决&#xff1a;在SqlMapConfig.xml中配置数据连接池&#xff0c;使用连接池管理数据库链接。 2、 Sql语句写在代码中造成代码不…

C++继承详解:共有(public)继承,私有(private)继承,保护(protected)继承

转自&#xff1a;http://www.cnblogs.com/qlwy/archive/2011/08/25/2153584.html C继承&#xff1a;公有&#xff0c;私有&#xff0c;保护 公有继承(public)、私有继承(private)、保护继承(protected)是常用的三种继承方式。 1. 公有继承(public) 公有继承的特点是基类的公有成…

Mybatis中Mapper动态代理方式

文章目录开发规范Mapper接口开发需要遵循以下规范Mapper.xml(映射文件)UserMapper(接口文件)加载UserMapper.xml文件总结selectOne和selectList:namespace:开发规范 Mapper接口开发方法只需要程序员编写Mapper接口&#xff08;相当于Dao接口&#xff09;&#xff0c;由Mybatis…

数据结构实验之数组二:稀疏矩阵

题目描述 对于一个n*n的稀疏矩阵M(1 < n < 1000)&#xff0c;采用三元组顺序表存储表示&#xff0c;查找从键盘输入的某个非零数据是否在稀疏矩阵中&#xff0c;如果存在则输出OK&#xff0c;不存在则输出ERROR。稀疏矩阵示例图如下&#xff1a; 输入 连续输入多组数据…

C++模板-Traits

转自&#xff1a;http://blog.csdn.net/my_business/article/details/7891687介绍traits的文章很多&#xff0c;但感觉大部分文章的说明都很晦涩难懂&#xff0c;把一个并不很复杂的C模板的应用描述的过于复杂。忍不住想把自己的理解跟大家分享一下&#xff0c;或许我也只是掌握…

Mybatis中SqlMapConfig.xml配置文件的使用

文章目录SqlMapConfig.xml中配置的内容和顺序如下properties&#xff08;属性)SqlMapConfig.xml引用如下typeAliases&#xff08;类型别名)mybatis支持别名&#xff1a;自定义别名mappers&#xff08;映射器)Mapper引入映射器的几种方法:1.通过resource属性引入classpath路径的…

数据结构实验之数组三:快速转置

题目描述 转置运算是一种最简单的矩阵运算&#xff0c;对于一个m*n的矩阵M( 1 < m < 10000,1 < n < 10000 )&#xff0c;它的转置矩阵T是一个n*m的矩阵&#xff0c;且T( i , j )M( j , i )。显然&#xff0c;一个稀疏矩阵的转置仍然是稀疏矩阵。你的任务是对给…

主流服务器框架总结

libevent 编辑Libevent 是一个用C语言编写的、轻量级的开源高性能网络库&#xff0c;主要有以下几个亮点&#xff1a;事件驱动&#xff08; event-driven&#xff09;&#xff0c;高性能;轻量级&#xff0c;专注于网络&#xff0c;不如 ACE 那么臃肿庞大&#xff1b;源代码相当…

Mybatis输入映射和输出映射

Mapper.xml映射文件中定义了操作数据库的sql&#xff0c;每个sql是一个statement&#xff0c;映射文件是mybatis的核心。输入参数映射parameterType(输入类型)传递简单类型&#xff1a;如&#xff1a;<select id"queryUserById" parameterType"Integer"…

树结构练习——排序二叉树的中序遍历

题目描述 在树结构中&#xff0c;有一种特殊的二叉树叫做排序二叉树&#xff0c;直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树&#xff08;如果存在的话&#xff09;的关键值小于该节点的关键值 (3).任意一个节点的右子树&#xff08;如果存在的…

陈硕知乎专栏

https://www.zhihu.com/people/giantchen/answers

Mybatis动态sql的使用

通过mybatis提供的各种标签方法实现动态拼接sql。 为什么用if标签? UserMapper.xml配置sql&#xff0c;如下&#xff1a; <!-- 根据条件查询用户 --> <select id"queryUserByWhere" parameterType"user" resultType"user">SELEC…

面向对象设计之CRC卡片

1.什么是 CRC card&#xff1f; CRC (Class-Responsibility-Collaborator) Card是目前比较流行的面向对象分析建模方法。在CRC建模中&#xff0c;用户、设计者、开发人员都有参与&#xff0c;完成对整个面向对象工程的设计。 CRC卡是一个标准索引卡集合&#xff0c;包括三个部分…

川藏线徒搭

http://www.mafengwo.cn/i/6296156.html

删数问题

Problem Description 键盘输入一个高精度的正整数n&#xff08;≤100位&#xff09;&#xff0c;去掉其中任意s个数字后剩下的数字按照原来的左右次序组成一个新的正整数。编程对给定的n与s&#xff0c;寻找一种方案&#xff0c;使得剩下的数字组成的新数最小。Input 输入有多组…

面试70问 经典回答

http://group.cnblogs.com/topic/37628.html

Mybatis整合spring

整合思路 1、SqlSessionFactory对象应该放到spring容器中作为单例存在。 2、传统dao的开发方式中&#xff0c;应该从spring容器中获得sqlsession对象。 3、Mapper代理形式中&#xff0c;应该从spring容器中直接获得mapper的代理对象。 4、数据库的连接以及数据库连接池事务…

最少拦截系统

某国为了防御敌国的导弹袭击,发展出一种导弹拦截系统.但是这种导弹拦截系统有一个缺陷:虽然它的第一发炮弹能够到达任意的高度,但是以后每一发炮弹都不能超过前一发的高度.某天,雷达捕捉到敌国的导弹来袭.由于该系统还在试用阶段,所以只有一套系统,因此有可能不能拦截所有的导弹…

云计算的理解

原文&#xff1a;http://www.chinacloud.cn/show.aspx?id15917&cid17 老叟发现&#xff0c;即使是一些搞计算机的人&#xff0c;也不了解“云”是什么。于是&#xff0c;俺卖车之余就写了一篇科普&#xff1a; 到底什么是云(云计算) 有很多关于云的介绍。然而&#xff0c;…