题干:
晨晨在纸上写了一个长度为N的非负整数序列{aiai}。对于这个序列的一个连续子序列{al,al+1,…,aral,al+1,…,ar}晨晨可以求出其中所有数异或的结果 alxoral+1xor...xoraralxoral+1xor...xorar其 中xor表示位异或运算,对应C、C++、 Java等语言中的^运算。
小璐提出了M个询问,每个询问用一个整数 xixi描述。
对于每个询问,晨晨需要找到序列{aiai}的所有连续子序列,求出每个子序列异或的结果,找到所有的结果中与 xixi之差的绝对值最小的一个,并告诉小璐相应子序列的长度。
若有多个满足条件的连续子序列,则告诉小璐这些子序列中最长的长度。
Input
包含多组测试数据,第一行一个正整数T,表示数据组数。
每组数据共两行。
第一行包含N+1个非负整数。其中第一个数为N,表示序列的长度;接下来N 个数,依次描述序列{ aiai}中的每个数。
第二行包含M+1个整数。其中第一个数为M,表示询问的个数;接下来M个数 xixi,每个数对应题目描述中的一个询问。
保证 1 <= N <= 100,1 <= M <= 100,aiai <= 1024,|xixi| <= 1024,数据组数 <= 100。
Output
对于每组数据输出M + 1行。前M行对应晨晨M个询问的回答,第M + 1行为空行
Sample Input
2 2 1 1 2 0 2 3 1 2 4 3 10 5 1
Sample Output
2 13 2 1
解题报告:
直接记录每一个异或值下的最长长度,最后二分查找输出就可以。注意并不是样例之间有空行,而是每一个样例后面都输出空行!时间复杂度O(T*(n^2log(n^2)+mlog(n^2)))
其实这题也可以不带log。
有一个O(T*m*n^2)的做法,先预处理异或和,然后对于每个询问,n^2暴力。这样可以过。
第二种方法是O(T*n^2)的做法,不用map,直接用数组,然后用并查集优化一下,对于每次查询就可以O1了,但是实现比较复杂,可能没人会写吧、、、
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
int n,m;
map<int,int> mp;
int a[MAX];
int main()
{int T;cin>>T;while(T--) {scanf("%d",&n);mp.clear();for(int i = 1; i<=n; i++) scanf("%d",a+i);for(int i = 1; i<=n; i++) {int Xor=0;for(int j = i; j<=n; j++) {Xor ^= a[j];if(mp.find(Xor) != mp.end()) mp[Xor] = max(mp[Xor],j-i+1);else mp[Xor] = j-i+1;}}scanf("%d",&m);int x;while(m--) {scanf("%d",&x);auto it = mp.lower_bound(x);if(it == mp.end()) --it;auto itt = it;if(itt != mp.begin()) --itt;int cha1 = abs(it->FF - x),cha2 = abs(itt->FF - x);if(cha1 < cha2) printf("%d\n",it->SS);else if(cha1 > cha2) printf("%d\n",itt->SS);else printf("%d\n",max(it->SS,itt->SS));}puts("");}return 0 ;
}