【POJ - 2965】The Pilots Brothers' refrigerator(暴力枚举,思维)

题干:

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

题目大意:

一个冰箱上有4*4共16个开关,改变任意一个开关的状态(即开变成关,关变成开)时,此开关的同一行、同一列所有的开关也会同时改变状态。要想打开冰箱,要所有开关全部打开才行。‘+’代表关闭,‘-’代表打开。

解题报告:

直接2^16暴力枚举,注意状态的更新,不要全部更新一遍,而是只记录行和列的更新即可。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
const int up = 1<<16; 
char s[5][5];
int R[5],C[5],ok[5][5],ansk=1e8,ans;
bool tt[5][5];
int main()
{
//	printf("%lld\n",(1<<15)+(1<<14)+(1<<12)+(1<<0)+(1<<2)+(1<<3));for(int i = 0; i<=3; i++) {scanf("%s",s[i]);}for(int i = 0; i<=3; i++) {for(int j = 0; j<=3; j++) {if(s[i][j] == '-') ok[i][j]=1;else ok[i][j]=0;}}for(int bit = 0; bit<up; bit++) {
//		if(bit == 53261) {
//			printf("ok\n");
//		}int k=0,flag = 1,zs=0;for(int i = 0; i<=3; i++) R[i]=C[i]=0;memset(tt,0,sizeof tt);for(int x=bit;x;x>>=1,k++) {if(x%2 == 1) {zs++;int row = k/4,col = k%4;R[row]++,C[col]++;tt[row][col]=1;}}for(int i = 0; i<=3; i++) {for(int j = 0; j<=3; j++) {if((R[i]+C[j]+ok[i][j]+tt[i][j])%2 == 0) {flag = 0;break;}}if(flag == 0) break;}if(flag == 1) {if(zs < ansk) {ansk=zs;ans=bit;}}}printf("%d\n",ansk);int k=0;for(int x = ans;x;x>>=1) {if(x%2 == 1) {int row = k/4,col=k%4; printf("%d %d\n",row+1,col+1);}k++;}return 0 ;
}

 

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/439680.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

动手学无人驾驶(5):多传感器数据融合

本系列的前4篇文章主要介绍了深度学习技术在无人驾驶环境感知中的应用&#xff0c;包括交通标志识别&#xff0c;图像与点云3D目标检测。关于环境感知部分的介绍本系列暂且告一段落&#xff0c;后续如有需要再进行补充。 现在我们开启新的篇章&#xff0c;在本文中将会介绍无人…

一步步编写操作系统 52 深入浅出cpu的特权级

所谓保护模式下的“保护”&#xff0c;主要体现在特权级上&#xff0c;以后随着后面工作的展开&#xff0c;会越来越多的和它们打交道&#xff0c;现在是时候说道说道了。 在人类社会中出现恶势力时&#xff0c;人们总是希望出现一位具有神力的英雄来拯救世人、主持公道。阶级…

详解两阶段3D目标检测网络PVRCNN:Point-Voxel Feature Set Abstraction for 3D Object Detection

在《动手学无人驾驶&#xff08;4&#xff09;&#xff1a;基于激光雷达点云数据3D目标检测》一文中介绍了3D目标检测网络PointRCNN。今天介绍该作者新提出的3D检测模型&#xff1a;PVRCNN&#xff0c;论文已收录于CVPR2020。 作者个人主页为&#xff1a;https://sshaoshuai.gi…

【Codeforces - 755C】PolandBall and Forest(并查集)

题干&#xff1a; PolandBall lives in a forest with his family. There are some trees in the forest. Trees are undirected acyclic graphs with k vertices and k - 1 edges, where k is some integer. Note that one vertex is a valid tree. There is exactly one …

一步步编写操作系统 53 任务状态段TSS介绍

操作系统是利用PCB来维护所有任务的&#xff0c;包括进程和线程&#xff0c;但cpu提供的是TSS&#xff0c;linux系统可没用它&#xff0c;因为效率太低。但是还是要了解下TSS才清楚操作系统中某些操作的原因。 本节中所讲的特权级与它有着密不可分的联系&#xff0c;TSS作用不…

动手学无人驾驶(6):基于IMU和GPS数据融合的自车定位

在上一篇博文《动手学无人驾驶&#xff08;5&#xff09;&#xff1a;多传感器数据融合》介绍了如何使用Radar和LiDAR数据对自行车进行追踪&#xff0c;这是对汽车外界运动物体进行定位。 对于自动驾驶的汽车来说&#xff0c;有时也需要对自身进行更精确的定位&#xff0c;今天…

【Codeforces - 798C】 Mike and gcd problem(思维,贪心)

题干&#xff1a; Mike has a sequence A  [a1, a2, ..., an] of length n. He considers the sequence B  [b1, b2, ..., bn] beautiful if the gcd of all its elements is bigger than 1, i.e. . Mike wants to change his sequence in order to make it beauti…

一步步编写操作系统 48 加载内核1

其实&#xff0c;我们等了这一刻好久好久&#xff0c;即使我不说&#xff0c;大家也有这样的认识&#xff0c;linux内核是用c 语言写的&#xff0c;咱们肯定也要用c语言。其实...说点伤感情的话&#xff0c;今后的工作只是大部分&#xff08;99%&#xff09;都要用c语言来写&am…

Coursera自动驾驶课程第1讲:Welcome to the self-driving cars specialization

本专栏为Coursera自动驾驶课程笔记&#xff0c;B站上也有配套课程视频&#xff0c;对自动驾驶技术感兴趣的朋友可以看看。 本讲对应视频&#xff1a; https://www.bilibili.com/video/BV1WE411D74g?p1https://www.bilibili.com/video/BV1WE411D74g?p2https://www.bilibili.…

【CodeForces - 999D】Equalize the Remainders(思维,贪心)

题干&#xff1a; You are given an array consisting of nn integers a1,a2,…,ana1,a2,…,an, and a positive integer mm. It is guaranteed that mm is a divisor of nn. In a single move, you can choose any position ii between 11 and nn and increase aiai by 11. …

Coursera自动驾驶课程第2讲:The Requirements for Autonomy

上一讲《Coursera自动驾驶课程第1讲&#xff1a;Welcome to the self-driving cars specialization》对本课程进行了整体概述&#xff0c;同时回顾了自动驾驶汽车的发展历史。 从本讲我们开始进入正式的学习&#xff0c;我们将首先了解到如何划分自动驾驶汽车等级、以及自动驾…

一步步编写操作系统 51 加载内核4

咱们的内容都是连栽的&#xff0c;如果您没看过我之前的文章&#xff0c;本节您是看不懂的。 接上节。 介绍完内核初始化的函数kernel_init后&#xff0c;本节代码部分还差一点点没说啦&#xff0c;下面看代码&#xff1a; …略 179 ;在开启分页后&#xff0c;用gdt新的地址…

【CodeForces - 777C】Alyona and Spreadsheet(思维,前缀和)

题干&#xff1a; During the lesson small girl Alyona works with one famous spreadsheet computer program and learns how to edit tables. Now she has a table filled with integers. The table consists of n rows and mcolumns. By ai, j we will denote the integ…

Coursera自动驾驶课程第3讲:Self-Driving Hardware and Software Architectures

在上一讲《Coursera自动驾驶课程第2讲&#xff1a;The Requirements for Autonomy》中我们了解到了如何划分自动驾驶汽车等级、以及自动驾驶三大模块&#xff1a;感知、决策和执行。 本讲我们将学习新的模块&#xff1a;自动驾驶汽车的硬件和软件架构。 B站视频链接&#xff…

一步步编写操作系统 54 CPL和DPL入门1

我们在工作中&#xff0c;公司都给员工配有员工卡&#xff0c;此员工卡就是员工身份的“标签”&#xff0c;用它来出入公司、食堂就餐等。给公司创造价值的是员工的生产力&#xff0c;不是员工卡&#xff0c;员工卡只是公司人事部门管理员工的一种手段而已。 现在说计算机&…

Coursera自动驾驶课程第4讲:Safety Assurance for Autonomous Vehicles

在上一讲《Coursera自动驾驶课程第3讲&#xff1a;Self-Driving Hardware and Software Architectures》中我们了解了自动驾驶汽车常用的传感器和硬件组件、软件系统。 本讲我们将学习新的模块&#xff0c;也是自动驾驶汽车最重要的模块之一&#xff1a;安全模块。 B站视频链…

【Codeforces - 1000C】Covered Points Count(思维,离散化,差分)

题干&#xff1a; You are given nn segments on a coordinate line; each endpoint of every segment has integer coordinates. Some segments can degenerate to points. Segments can intersect with each other, be nested in each other or even coincide. Your task i…

Coursera自动驾驶课程第5讲:Vehicle Dynamic Modeling

在上一讲《Coursera自动驾驶课程第4讲&#xff1a;Safety Assurance for Autonomous Vehicles》中我们了解了自动驾驶汽车中一个非常重要的模块&#xff1a;安全模块。 本讲我们将学习新的模块&#xff1a;汽车运动学和动力学模块。&#xff08;这部分可能需要一定的理论力学和…

详细解析电源滤波电容的选取与计算

电感的阻抗与频率成正比&#xff0c;电容的阻抗与频率成反比。所以&#xff0c;电感可以阻扼高频通过&#xff0c;电容可以阻扼低频通过。二者适当组合&#xff0c;就可过滤各种频率信号。如在整流电路中&#xff0c;将电容并在负载上或将电感串联在负载上&#xff0c;可滤去交…

【CodeForces - 124C】Prime Permutation(数学,思维,小结论)

题干&#xff1a; You are given a string s, consisting of small Latin letters. Lets denote the length of the string as |s|. The characters in the string are numbered starting from 1. Your task is to find out if it is possible to rearrange characters in st…