题干:
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
解题报告:
考察就是递归输出而已。注意输出格式的控制。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
ll ans;
char s[MAX];
char db[10][102] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
void out(ll x) {if(x <= 9) printf("%s",db[x]);else {out(x/10); printf(" %s",db[x%10]);}
}
int main()
{cin>>s+1;int len = strlen(s+1);for(int i = 1; i<=len; i++) {ans += s[i] - '0';}out(ans);return 0;
}