题干:
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a family member, K
(>0) is the number of his/her children, followed by a sequence of two-digit ID
's of his/her children. For the sake of simplicity, let us fix the root ID
to be 01
. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
题目大意:
给你一棵树,让你找到节点数最多的那个深度和对应的节点个数。
解题报告:
按照题意建树,然后dfs扫一遍得到深度,输出结果即可。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
int n,m;
int dep[MAX],cnt[MAX],mx,ans,ansd;
vector<int> vv[MAX];
void dfs(int cur,int fa) {dep[cur] = dep[fa] + 1;cnt[dep[cur]]++;mx = max(mx,dep[cur]);int up = vv[cur].size();for(int i = 0; i<up; i++) {int v = vv[cur][i];dfs(v,cur);}
}
int main()
{cin>>n>>m;for(int fa,num,i = 1; i<=m; i++) {scanf("%d%d",&fa,&num);for(int x,j = 1; j<=num; j++) {scanf("%d",&x);vv[fa].pb(x);}}dfs(1,0);for(int i = 1; i<=mx; i++) {if(cnt[i] > ans) {ansd = i;ans = cnt[i];}}printf("%d %d\n",ans,ansd);return 0 ;
}