题干:
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all.
Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
题目大意:
按照标号给定一棵二叉树,问你这是不是个堆,如果是,则是个大根堆还是小根堆。并让你输出所有的从根节点到叶子节点的路径。
解题报告:
注意因为是二叉树所以不需要建树,用一个栈按照要求存储路径即可。最后按照路径进行判断是不是堆,是大根堆还是小根堆。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
int n;
int val[MAX];
vector<int> stk;
vector<int> ans;
void dfs(int idx) {if(idx * 2 > n) {int up = stk.size(),flag = 1;for(int i = 0; i<up; i++) {printf("%d%c",stk[i],i == up-1 ? '\n' : ' ');}//MAX 5 4 3 2 1for(int i = 1; i<up; i++) {if(stk[i] > stk[i-1]) flag = 0;}if(flag == 1) {ans.push_back(1); return;}//MIN 1 2 3 4 5flag = 1;for(int i = 1; i<up; i++) {if(stk[i] < stk[i-1]) flag = 0;}if(flag == 1) {ans.push_back(2); return;}ans.push_back(-1);return;}if(idx * 2 + 1 <= n) {stk.push_back(val[idx*2+1]);dfs(idx*2+1);stk.pop_back();}if(idx * 2 <= n) {stk.push_back(val[idx*2]);dfs(idx*2);stk.pop_back();}
}
int main()
{cin>>n;for(int i = 1; i<=n; i++) scanf("%d",val+i);stk.push_back(val[1]);dfs(1);int Max = 1,Min = 1;for(auto x : ans) {if(x != 1) Max = 0;}for(auto x : ans) {if(x != 2) Min = 0;} if(Max == 1) printf("Max Heap\n");else if(Min == 1) printf("Min Heap\n");else printf("Not Heap\n");return 0 ;
}