【题目描述】
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s). where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the lineTrapped!
Sample Input
3 4 5
S....
.###.
.##..
###.######
#####
##.##
##...#####
#####
#.###
####E1 3 3
S##
#E#
###0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
【题目分析】
一道很简单的三维BFS,但是因为我刚开始的时候没有在入队的时候就设置该点已经入队导致疯狂入队然后一直爆空间,还完全找不到问题
代码
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;const int MAXN=35;
int a[MAXN][MAXN][MAXN];
char s[MAXN];
int L,R,C,u,v,w,x,y,z;
struct node
{int x,y,z;int step;
};
node S,E,p,t;const int drc[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
int ans;void BFS()
{queue<node> q;q.push(S);while(!q.empty()){p=q.front(); q.pop();if(p.x==E.x && p.y==E.y && p.z==E.z){ans=p.step;while(!q.empty()) q.pop();return;}x=p.x; y=p.y; z=p.z;//a[z][x][y]=0; //就因为这里一直错for(int i=0;i<6;i++){u=x+drc[i][0]; v=y+drc[i][1]; w=z+drc[i][2];if(u<0 || u>=R || v<0 || v>=C || w<0 || w>=L) continue;if(a[w][u][v]==0) continue;t.x=u; t.y=v; t.z=w; t.step=p.step+1;a[w][u][v]=0; //很重要q.push(t);}}
}int main()
{while(~scanf("%d%d%d",&L,&R,&C)){if(L==0 && R==0 && C==0) break;memset(a,0,sizeof(a));ans=0;for(int i=0;i<L;i++){for(int j=0;j<R;j++){scanf("%s",s);for(int k=0;k<C;k++){if(s[k]=='.') a[i][j][k]=1;else if(s[k]=='S'){S.z=i; S.x=j; S.y=k; S.step=0;a[i][j][k]=1;}else if(s[k]=='E'){E.z=i; E.x=j; E.y=k; E.step=0;a[i][j][k]=1;}}}}BFS();if(ans==0){printf("Trapped!\n");}else{printf("Escaped in %d minute(s).\n",ans);}}return 0;
}