【题目描述】
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
【题目分析】
很正常的判断负环,而且就算有重边也并不影响。
【AC代码】
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<climits>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;typedef long long ll;
const int MAXN=505;
const int MAXM=6005;
struct node
{int u,v,w;
}edge[MAXM],E;
int tot;
int n,m,k;
int dis[MAXN];inline void AddEdge(int u,int v,int w)
{edge[tot].u=u; edge[tot].v=v; edge[tot].w=w;tot++;
}bool Bellman()
{memset(dis,0x3f,sizeof(dis));dis[1]=0;bool flag;int T=n;while(T--){flag=false;for(int i=0;i<tot;i++){E=edge[i];if(dis[E.v]>dis[E.u]+E.w){dis[E.v]=dis[E.u]+E.w;flag=true;}}if(!flag) break;}return T==-1; //T的值最后是-1,我还以为是0.。。。
}int main()
{int T,u,v,w;scanf("%d",&T);while(T--){scanf("%d%d%d",&n,&m,&k);tot=0;for(int i=0;i<m;i++){scanf("%d%d%d",&u,&v,&w);AddEdge(u,v,w); AddEdge(v,u,w);}for(int i=0;i<k;i++){scanf("%d%d%d",&u,&v,&w);AddEdge(u,v,-w);}if(Bellman()){printf("YES\n");}else{printf("NO\n");}}return 0;
}