【题目描述】
“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.
“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
【题目分析】
刚开始看感觉像是一个递推,可是推半天没找到什么明显的关系。知道是要用到组合数学里面母函数的知识后就去学习了一下母函数,还是挺好理解的,关键在于怎么进行灵活的运用。
我们在进行组合的时候多进行的是加法,而幂函数乘积就是系数之和的性质可以帮助我们进行组合的分析,而且这种组合是他们将相同系数合并后的,可以直接得到我们的结果。
关于母函数的学习,可以看看其他大佬的文章,总结起来就两句话
1.“把组合问题的加法法则和幂级数的乘幂对应起来”2.“母函数的思想很简单 — 就是把离散数列和幂级数一 一对应起来,把离散数列间的相互结合关系对应成为幂级数间的运算关系,最后由幂级数形式来确定离散数列的构造. “
在这个问题里面,我们想要选出能凑出这个数字的和的所有的数字,为了防止重复,我们从小往大选,选出来到最后的结果就是答案
其实我们进行的是模拟幂级数的乘法运算。
这里为了优化复杂度,我用i0和i1进行翻滚
【AC代码】
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<climits>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;typedef long long ll;
const int MAXN=125;
int n;
int ans[2][MAXN<<2];
int i0,i1;int main()
{while(~scanf("%d",&n)){memset(ans,0,sizeof(ans));i0=0; i1=1;for(int i=0;i<=n;i++){ans[i0][i]=1;}for(int i=2;i<=n;i++){for(int j=0;j<=n;j++){for(int k=0;k+j<=n;k+=i){ans[i1][j+k]+=ans[i0][j];}}swap(i0,i1);for(int i=0;i<=n;i++){ans[i1][i]=0;}}printf("%d\n",ans[i0][n]);}return 0;
}