题意
求二进制表示中0的个数大于1的数的个数。
题目
The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.
They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.
A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.
Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.
Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).
Input
Line 1: Two space-separated integers, respectively Start and Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start… Finish
Sample Input
2 12
Sample Output
6
分析:
我们将二进制考虑成01串
我们先不考虑有前导零的情况:那么在k个空位中放i个0,别的都放1的方案数为CkiC{_{k}}^{i}Cki(我们将一个位置放0表示成取出这个位置的数)。
然后我们可以先计算1∼r,然后减去1∼l−1就是l∼r这个区间内的数量。
用数位dp+记忆化,得到求二进制表示中0的个数大于1的数的个数。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int M=50;
int n,m,tot;
int a[M],f[M][M][2];
int dfs(int pos,int sum,int pre,int lim)/**判断前导零,sum*/
{if(!pos) return sum>=0?1:0;///起始sum=0,当所有情况走一遍,最后sum>0,则满足,否则不满足。if(sum+pos<0) return 0;///若sum+pos<0,明显二进制表示中1的个数大于0的数的个数,剪枝。if(!lim&&f[pos][sum][pre]!=-1)return f[pos][sum][pre];int up=lim?a[pos]:1;int ans=0,now=pre,add=0;for(int i=0;i<=up;i++){if(i==0&&now) add=1;///若前导有1,且当前位为零,此时0可算入,sum+1else if(i==1) add=-1,now=1;///若当前位为1,则sum-1;ans+=dfs(pos-1,sum+add,now,lim&(i==up));}if(!lim) return f[pos][sum][pre]=ans;return ans;
}
int so(int x)
{tot=0;while(x){a[++tot]=x%2;x>>=1;}return dfs(tot,0,0,1);
}
int main()
{memset(f,-1,sizeof(f));scanf("%d%d",&n,&m);printf("%d\n",so(m)-so(n-1));return 0;
}