Round Numbers POJ - 3252(数位dp+判断前导零)

题意

求二进制表示中0的个数大于1的数的个数。

题目

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start… Finish

Sample Input

2 12

Sample Output

6

分析:

我们将二进制考虑成01串
我们先不考虑有前导零的情况:那么在k个空位中放i个0,别的都放1的方案数为CkiC{_{k}}^{i}Cki(我们将一个位置放0表示成取出这个位置的数)。
然后我们可以先计算1∼r,然后减去1∼l−1就是l∼r这个区间内的数量。
用数位dp+记忆化,得到求二进制表示中0的个数大于1的数的个数。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int M=50;
int n,m,tot;
int a[M],f[M][M][2];
int dfs(int pos,int sum,int pre,int lim)/**判断前导零,sum*/
{if(!pos) return sum>=0?1:0;///起始sum=0,当所有情况走一遍,最后sum>0,则满足,否则不满足。if(sum+pos<0) return 0;///若sum+pos<0,明显二进制表示中1的个数大于0的数的个数,剪枝。if(!lim&&f[pos][sum][pre]!=-1)return f[pos][sum][pre];int up=lim?a[pos]:1;int ans=0,now=pre,add=0;for(int i=0;i<=up;i++){if(i==0&&now) add=1;///若前导有1,且当前位为零,此时0可算入,sum+1else if(i==1) add=-1,now=1;///若当前位为1,则sum-1;ans+=dfs(pos-1,sum+add,now,lim&(i==up));}if(!lim) return f[pos][sum][pre]=ans;return ans;
}
int so(int x)
{tot=0;while(x){a[++tot]=x%2;x>>=1;}return dfs(tot,0,0,1);
}
int main()
{memset(f,-1,sizeof(f));scanf("%d%d",&n,&m);printf("%d\n",so(m)-so(n-1));return 0;
}

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/309913.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

[C++11]常量表达式函数

constexpr修饰函数。 普通函数/类成员函数。 1.函数必须要有返回值&#xff0c;并且return返回的表达式必须是常量表达式。 代码如下: #include <iostream> using namespace std;//error 不是常量表达式函数 constexpr void func1() {int a 200;cout << a &l…

Magicodes.IE Csv导入导出

说明本章主要说明如何使用Magicodes.IE.Csv进行Csv导入导出.主要步骤1.安装包Magicodes.IE.CsvInstall-Package Magicodes.IE.Csv2.使用Magicodes.IE.Csv导出Csv通过如下代码片段我们将导出的内容通过相应的特性做出相应的处理.ExporterHeaderAttributeDisplayName&#xff1a;…

ajax获取php的数组,使用AJAX请求获取数组并将其传递到php数组中 - javascript

我正在为下一个问题苦苦挣扎&#xff1a;我有一个ajax请求&#xff0c;该请求将变量传递给PHP文件。 PHP处理该变量并返回一个数组。我需要取回该数组&#xff0c;所以我使用了AJAX成功回调函数&#xff0c;但是我只能打印出数组&#xff0c;仅此而已。我想使用该数组。$.ajax(…

D-query SPOJ - DQUERY(主席树求区间中不同的数的个数)

题意 给出n个数&#xff0c;m个询问&#xff0c;每个询问给出一个区间&#xff0c;需要回答这个区间中不同的数的个数 题目 {assign var“code” value“DQUERY”} {if KaTeX parse error: Expected EOF, got } at position 8: par""}̲ {assign varpa…locale} {…

微软 Build 2020开发者大会发来一张英雄帖,邀您速来赴约!

&#xff08;本文阅读时间&#xff1a;2 分钟&#xff09;微软 Build 2020开发者大会将于北京时间5 月 19 日晚上 23:00正式开启。大会将以Teams Live Event的形式面向全球开发者免费注册&#xff0c;并增设中文专家面对面&技术专场&#xff0c;方便开发者从48小时的连续技…

[C++11]不允许使用auto的四个场景

不允许使用auto的四个场景&#xff1a; 1.不能作为函数参数使用&#xff0c;因为只有在函数调用的时候才会给函数参数传递实参&#xff0c;auto要求必须要给修饰的变量赋值&#xff0c;因此二者矛盾。 代码如下: //error int func(auto a, auto b) {cout << a <<…

Network UVA - 315(Tarjan+连通性问题:求割点)

题意&#xff1a; 存在n个电话公司的网络连接站点&#xff0c;每个站点之间相互连通&#xff0c;是一个连通图&#xff0c;问&#xff0c;如果去掉一个站点&#xff0c;能够将整个网络体系变得不再连通&#xff0c;那么这样的点有几个&#xff0c;即求它的割点个数。 题目&am…

linux 进程内存开销,linux下查看最消耗CPU、内存的进程

1.CPU占用最多的前10个进程&#xff1a;ps auxw|head -1;ps auxw|sort -rn -k3|head -102.内存消耗最多的前10个进程ps auxw|head -1;ps auxw|sort -rn -k4|head -103.虚拟内存使用最多的前10个进程ps auxw|head -1;ps auxw|sort -rn -k5|head -104.也可以试试ps auxw --sortrs…

[C++11]自动类型推导auto

1.auto C11中&#xff0c;auto并不代表一种实际的数据类型&#xff0c;只是一个类型声明的"占位符"&#xff0c;auto并不是万能的在任意场景下都能够推导出变量的实际类型&#xff0c;使用auto声明的变量必须要进行初始化&#xff0c;以让编译器推导出它的实际类型&…

[最全操作指南] 在线六个项目全部迁移Linux

&#xff08;书山有路勤为径&#xff0c;学海无涯苦作舟&#xff09;开源也两年了&#xff0c;没想到自己在宣传.NetCore全栈的时候&#xff0c;也慢慢的做出了几个产品&#xff0c;毕竟也是一行一行的敲出来的&#xff0c;也是一天一夜的改出来的&#xff0c;希望每个人都能在…

操作系统习题——第一章

操作系统习题——第一章 1&#xff0e;设计现代OS的主要目标是什么&#xff1f; 答&#xff1a;&#xff08;1&#xff09;有效性 &#xff08; 2&#xff09;方便性 &#xff08; 3&#xff09;可扩充性 &#xff08; 4&#xff09;开放性 2&#xff0e; OS 的作用可表现在…

linux把svs文件分割,freeebsd,pkg_add,svsup,make改服务器的设定

第一大部分&#xff1a;几个服务器的设定pkg_add默认下载的服务器在哪改。在/etc/csh.cshrc加上setenv PACKAGESITE ftp://ftp.freebsd.org/pub/FreeBSD/ports/packages/All/如果是用PACKAGEROOT,则目录必须符合官方的规定cvsup默认的服务器cvsup -L 2 -h cvsup.freebsd.org /u…

[C++11]推荐使用auto的场景

推荐使用auto的场景&#xff1a; 1.用于STL的容器遍历。 代码如下: #include <string>#include <iostream> #include <map> using namespace std;int main() {map<int, string>mp;mp.insert(make_pair(1, "Tom"));mp.insert(make_pair(2,…

【壹刊】Azure AD 保护的 ASP.NET Core Web API (下)

一&#xff0c;引言上一节讲到如何在我们的项目中集成Azure AD 保护我们的API资源&#xff0c;以及在项目中集成Swagger&#xff0c;并且如何把Swagger作为一个客户端进行认证和授权去访问我们的WebApi资源的&#xff1f;本节就接着讲如何在我们的项目中集成 Azure AD 保护我们…

linux aspnet服务器,在Linux中安装ASPNET.Core3.0运行时的示例代码

摘要&#xff1a;# 以下示例适用于x64位runtime v3.0.0mkdir /runtimescd /runtimeswget https://... # 以下示例适用于x64位runtime v3.0.0mkdir /runtimescd /runtimeswget https://download.visualstudio.microsoft.com/download/pr/b0c44e05-b7a1-4221-94ec-a0c0d3a11eed/a…

And Then There Was One POJ - 3517(变形约瑟夫环+规律)

题意&#xff1a; 约瑟夫问题的变式。先指定第m个人必须死&#xff0c;然后每隔k个人死一个。求最后那个死的人的编号是什么。 题目 Let’s play a stone removing game. Initially, n stones are arranged on a circle and numbered 1, …, n clockwise (Figure 1). You a…

明明可以靠技术吃饭,现在却非要出来当编剧!

这是头哥侃码的第199篇原创前不久&#xff0c;有位读者深夜时在后台留言说&#xff1a;“我在某技术大会现场听过你的分享。”“说实话&#xff0c;第一次见你&#xff0c;真的很难想象一幅猛男外表的人竟然会有这样的经历和谈吐&#xff0c;这两点让我很钦佩。”这还不算完&am…

[C++11]decltype类型推导规则

在某些情况下&#xff0c;不需要或者不能定义变量&#xff0c;但是希望得到某种类型&#xff0c;这时候就可以用C11提供的decltype关键字了&#xff0c;它的作用是在编译器编译的时候推导出一个表达式的类型。 语法: decltype (表达式)decltype是"declare type “的缩写…

linux不能更改密码,Linux服务器无法更改密码的解决办法--passwd: User not known

上面仅是告知我&#xff0c;这些帐号并没有家目录&#xff0c;由于那些帐号绝大部分都是系统帐号&#xff0c; 确实也不需要家目录的&#xff0c;所以&#xff0c;那是‘正常的错误&#xff01;’,相对应的群组检查可以使用 grpck 这个指令。pwck 确保系统鉴认信息的完整性,pwc…

PowerBIDeskTop报表元数据批量更新(可用于翻译场景)

PowerBI在多国语言场景上有极大的缺陷&#xff0c;原有的Sqlserver的SSAS和Azure的AS模型层翻译功能&#xff0c;在Excel和PowerBIDeskTop客户端上均可完美适配。但到了PowerBI Pro的Service网页端时&#xff0c;竟然不支持。这个问题已经明确是官方给出的答复&#xff0c;起码…