Bound Found POJ - 2566(尺取法+前缀和创造区间变化趋势)

题意:

给定一个数组和一个值t,求一个子区间使得其和的绝对值与t的差值最小,如果存在多个,任意解都可行。

题目:

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

分析:

1、 什么情况下能使用尺取法?

尺取法通常适用于选取区间有一定规律,或者说所选取的区间有一定的变化趋势的情况,通俗地说,在对所选取区间进行判断之后,我们可以明确如何进一步有方向地推进区间端点以求解满足条件的区间,如果已经判断了目前所选取的区间,但却无法确定所要求解的区间如何进一步得到根据其端点得到,那么尺取法便是不可行的。。首先,明确题目所需要求解的量之后,区间左右端点一般从最整个数组的起点开始,之后判断区间是否符合条件在根据实际情况变化区间的端点求解答案。

摘自博客

(1)我在补挑战程序设计,所以明确知道这道题使用尺取法,但我对于 问题分析后,完全没看出来选取区间有啥规律(由于题目是求一个子区间使得其和的绝对值与t的差值最小,如果存在多个,任意解都可行。存在负数)所以对于区间端点的推进是无法正常进行的。
(2)对前缀和sum排序。然后这时候的sum就有单调性了,根据每次两个区间端点作差的值与目标值比较,对端点尝试更新。
(3)原问题就转化为了在一个升序区间中,取两个区间端点作差,求最接近 s 的值。
(4)需要care:
1、当左右端点相等时,此时为前缀和,没有意义且不可能出现,导致错误,所以我们要排除。
2、sort排序要带上起始的初始化零点,一是答案可能导致错误,二一个我们是用前缀和进行比较,所以不可或缺。

AC模板:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int M=1e5+10;
int n,m,k,l,r,x,y,ans,mi;
struct node
{int id,sum;
}s[M];
bool cmp(node x,node y)
{return  x.sum<y.sum;
}
void solve()
{l=0,r=1,mi=inf;while(l<=n&&r<=n&&mi!=0){int temp=s[r].sum-s[l].sum;if(abs(temp-k)<mi){mi=abs(temp-k);x=s[l].id;y=s[r].id;ans=temp;}if(temp>k) l++;else if(temp<k) r++;else break;if(r==l) r++;}if(x>y) swap(x,y);printf("%d %d %d\n",ans,x+1,y);
}
int main()
{while(~scanf("%d%d",&n,&m)){if(n==0&&m==0)break;s[0].sum=s[0].id=0;for(int i=1;i<=n;i++){scanf("%d",&s[i].sum);s[i].sum+=s[i-1].sum;s[i].id=i;}sort(s,s+1+n,cmp);/**要带上0项*/while(m--){scanf("%d",&k);solve();}}return 0;
}

备战ccpc分站赛ing ,题目分析简略,见谅,转载请注明出处。。。。。

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/309573.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

MESI 缓存一致性协议

MESI 缓存一致性协议 多核场景下&#xff0c;仅仅依靠CAS这一类硬件原语并不能实现同步&#xff0c;因为原子指令底层实现也可能包含多条微指令&#xff0c;而原子指令的原子性是相对于一个核而言的&#xff0c;多条原子指令在各自的CPU核上都是原子执行的。所以要解决这个问题…

15分钟从零开始搭建支持10w+用户的生产环境(一)

前言这是一个基于中小型企业或团队的架构设计。不考虑大厂。有充分的理由相信&#xff0c;大厂有绝对的实力来搭建一个相当复杂的环境。中小型企业或团队是个什么样子&#xff1f;开发团队人员配置不全&#xff0c;部分人员身兼开发过程上下游的数个职责&#xff1b;没有专职的…

Sum of Consecutive Prime Numbers POJ - 2739(线性欧拉筛+尺取法)

题意&#xff1a; 一些正整数可以由一个或多个连续质数的总和表示。给定一个的正整数n,问满足条件的有多少种情况&#xff1f; 题目&#xff1a; Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representat…

高性能IO——Reactor模式

高性能IO——Reactor模式 参考&#xff1a;https://cloud.tencent.com/developer/article/1513447 目前的IO线程处理模型一般可以分为以下三类&#xff1a; 单线程阻塞I/O服务模型&#xff1b; while(true) {socket accept();handle(socket) }多线程阻塞I/O服务模型&#xf…

X-lab 开放实验室开源创新的故事

本报告为“开源软件供应链点亮计划暑期2020活动”中的“大咖说开源”第二期的特邀嘉宾视频&#xff0c;正好借此机会给大家介绍下 X-lab 实验室目前在开源方面开展的一些事情&#xff0c;欢迎大家关注&#xff0c;也欢迎更多热爱开源的朋友们加入&#xff01;摘要&#xff1a;2…

Circle and Points POJ - 1981(单位圆覆盖最多点)

题意&#xff1a; 给你n个点和点的位置&#xff0c;问单位圆最多能覆盖多少个点。 题目&#xff1a; You are given N points in the xy-plane. You have a circle of radius one and move it on the xy-plane, so as to enclose as many of the points as possible. Find h…

Golang 匿名函数、闭包

参考&#xff1a;https://blog.csdn.net/qq_35976351/article/details/81986496 Golang 闭包 匿名函数 Golang支持匿名函数&#xff0c;即在需要使用函数时&#xff0c;再定义函数&#xff0c;匿名函数没有函数名&#xff0c;只有函数体。 匿名函数经常被用于实现回调函数、闭…

ASP.NET Core分布式项目实战(Consent 确认逻辑实现)--学习笔记

任务22&#xff1a;Consent 确认逻辑实现接下来&#xff0c;我们会在上一节的基础上添加两个按钮&#xff0c;同意和不同意&#xff0c;点击之后会把请求 post 到 ConsentController 处理&#xff0c;如果同意会通过 return url 跳转到客户端&#xff0c;如果不同意就会取消&am…

The Last Non-zero Digit POJ - 1150(n!mod p)

题意&#xff1a; 要求你求出n!(n−m)!)\frac{n!}{(n-m)!)}(n−m)!)n!​中最后一个非0的数字. 题目&#xff1a; In this problem you will be given two decimal integer numberN,M. You will have to find the last non-zero digit of the NPM^{N}P_{M}NPM​.This means n…

Istio 1.6——迈向极简主义

从 1.2 版本开始&#xff0c;Istio 进入季度发布的节奏。5 月 21 日发布的 1.6 版本可以说是最准时的一次。我们是否可以理解 Istio 架构简化后的开发工作已经步入了正轨&#xff1f;这次的更新是否会带给我们惊喜&#xff1f;亦或是还有遗憾&#xff1f;让我们一一道来。&…

[Java基础]获取Class类的对象

代码如下: package ClassObjectPack;public class Student {private String name;int age;public String address;public Student(String name, int age, String address) {this.name name;this.age age;this.address address;}public Student() {}private Student(String …

使用PInvoke互操作,让C#和C++愉快的交互优势互补

一&#xff1a;背景1. 讲故事如果你常翻看FCL的源码&#xff0c;你会发现这里面有不少方法借助了C/C的力量让C#更快更强悍,如下所示&#xff1a;[DllImport("QCall", CharSet CharSet.Unicode)][SecurityCritical][SuppressUnmanagedCodeSecurity]private static ex…

蓝桥杯2014届试题9题 小朋友排队(树状数组+类逆序对)

题目&#xff1a; 资源限制 时间限制&#xff1a;1.0s 内存限制&#xff1a;256.0MB 问题描述 n 个小朋友站成一排。现在要把他们按身高从低到高的顺序排列&#xff0c;但是每次只能交换位置相邻的两个小朋友。 每个小朋友都有一个不高兴的程度。开始的时候&#xff0c;所有…

[Java基础]反射获取构造方法并使用

代码如下: package ClassObjectPack;import java.lang.annotation.Annotation; import java.lang.reflect.Constructor; import java.lang.reflect.InvocationTargetException;public class ReflectDemo01 {public static void main(String[] args) throws ClassNotFoundExcep…

Dotnet core使用JWT认证授权最佳实践(二)

最近&#xff0c;团队的小伙伴们在做项目时&#xff0c;需要用到JWT认证。遂根据自己的经验&#xff0c;整理成了这篇文章&#xff0c;用来帮助理清JWT认证的原理和代码编写操作。第一部分&#xff1a;Dotnet core使用JWT认证授权最佳实践(一)&#xff08;接上文&#xff09;测…

题目 1886: [蓝桥杯][2017年第八届真题]包子凑数(欧几里得+完全背包)

题目&#xff1a; 时间限制: 1Sec 内存限制: 128MB 提交: 1049 解决: 365 题目描述 小明几乎每天早晨都会在一家包子铺吃早餐。他发现这家包子铺有N种蒸笼&#xff0c;其中第i种蒸笼恰好能放Ai个包子。每种蒸笼都有非常多笼&#xff0c;可以认为是无限笼。 每当有顾客想买X…

[Java基础]反射获取构造方法并使用练习

Student类代码如下: package ClassObjectPack;public class Student {private String name;int age;public String address;public Student(String name, int age, String address) {this.name name;this.age age;this.address address;}public Student() {}private Studen…

Dotnet core使用JWT认证授权最佳实践(一)

最近&#xff0c;团队的小伙伴们在做项目时&#xff0c;需要用到JWT认证。遂根据自己的经验&#xff0c;整理成了这篇文章&#xff0c;用来帮助理清JWT认证的原理和代码编写操作。一、JWTJSON Web Token (JWT)是一个开放标准(RFC 7519)&#xff0c;它定义了一种紧凑的、自包含的…