【eNSP模拟实验】单臂路由实现VLAN间通讯(复杂案例)

实验需求

如下图所示,PC1和PC2在vlan10下,PC3和PC4在vlan20下,Server1在vlan30下,需要实现这5台设备之间互相通讯。

实验操作

配置各个终端的ip地址

PC1~PC4都按照下图进行配置(注意ip地址和网关有不同的地方),注意配置好之后要点击右下角的应用

Server1配置如图下所示,配置好之后,点击保存

将S1进行如下配置

The device is running!
#进入系统模式
<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.
#关闭提示信息
[Huawei]un in en
Info: Information center is disabled.
#更改设备名称为S1
[Huawei]sysname S1
#批量创建vlan10、vlan20、vlan30
[S1]vlan batch 10 20 30
Info: This operation may take a few seconds. Please wait for a moment...done.
#进入e0/0/1接口
[S1]int e0/0/1
#设置接口类型为access
[S1-Ethernet0/0/1]port link-type access
#将接口加入vlan10
[S1-Ethernet0/0/1]port default vlan 10
#进入e0/0/2接口
[S1-Ethernet0/0/1]int e0/0/2
#设置接口类型为trunk
[S1-Ethernet0/0/2]port link-type trunk 
#允许该trunk口所有vlan通过
[S1-Ethernet0/0/2]port trunk allow-pass vlan all 

将S2进行如下配置

The device is running!<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]un in en
Info: Information center is disabled.
[Huawei]sysname S2
[S2]vlan batch 10 20 30
Info: This operation may take a few seconds. Please wait for a moment...done.
[S2]int e0/0/1
[S2-Ethernet0/0/1]port link-type access
[S2-Ethernet0/0/1]port default vlan 10
[S2-Ethernet0/0/1]int e0/0/2
[S2-Ethernet0/0/2]port link-type trunk
[S2-Ethernet0/0/2]port trunk allow-pass vlan all 

将S3进行如下配置

The device is running!<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]un in en
Info: Information center is disabled.
[Huawei]sysname S3
[S3]vlan batch 10 20 30
Info: This operation may take a few seconds. Please wait for a moment...done.
[S3]int e0/0/1
[S3-Ethernet0/0/1]port link-type access 
[S3-Ethernet0/0/1]port default vlan 20
[S3-Ethernet0/0/1]int e0/0/2
[S3-Ethernet0/0/2]port link-type trunk 
[S3-Ethernet0/0/2]port trunk allow-pass vlan all 

将S4进行如下配置

The device is running!<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]un in en
Info: Information center is disabled.
[Huawei]sysname S4
[S4]vlan batch 10 20 30
Info: This operation may take a few seconds. Please wait for a moment...done.
[S4]int e0/0/1
[S4-Ethernet0/0/1]port link-type access 
[S4-Ethernet0/0/1]port default vlan 20
[S4-Ethernet0/0/1]int e0/0/2
[S4-Ethernet0/0/2]port link-type trunk 
[S4-Ethernet0/0/2]port trunk allow-pass vlan all 

将S5进行如下配置

The device is running!<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]un in en
Info: Information center is disabled.
[Huawei]sysname S5
[S5]vlan batch 10 20 30
Info: This operation may take a few seconds. Please wait for a moment...done.
#创建接口组1
[S5]port-group 1
#将e0/0/2 ~ e0/0/5的接口都加入到端口组1中
[S5-port-group-1]group-member e0/0/2 to e0/0/5
#将接口组1中的接口批量设置为trunk口
[S5-port-group-1]port link-type trunk 
#以下自动生成
[S5-port-group-1]port link-type trunk 
[S5-Ethernet0/0/2]port link-type trunk 
[S5-Ethernet0/0/3]port link-type trunk 
[S5-Ethernet0/0/4]port link-type trunk 
[S5-Ethernet0/0/5]port link-type trunk 
#将接口组1中的接口批量允许所有vlan通过
[S5-port-group-1]port trunk allow-pass vlan all	
#以下自动生成
[S5-port-group-1]port trunk allow-pass vlan all 
[S5-Ethernet0/0/2]port trunk allow-pass vlan all 
[S5-Ethernet0/0/3]port trunk allow-pass vlan all 
[S5-Ethernet0/0/4]port trunk allow-pass vlan all 
[S5-Ethernet0/0/5]port trunk allow-pass vlan all 
#退出接口组1
[S5-port-group-1]q
#进入g0/0/1接口
[S5]int g0/0/1
#将接口设置为trunk口
[S5-GigabitEthernet0/0/1]port link-type trunk 
#允许该trunk口vlan全部通过
[S5-GigabitEthernet0/0/1]port trunk allow-pass vlan all 
#进入接口e0/0/6中
[S5-GigabitEthernet0/0/1]int e0/0/6
#将接口e0/0/6设置为access类型
[S5-Ethernet0/0/6]port link-type access 
#将接口划分到vlan30中
[S5-Ethernet0/0/6]port default vlan 30

将R1进行如下配置

<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]un in en
Info: Information center is disabled.
[Huawei]sysname R1
#进入虚拟接口g0/0/1.10
[R1]int g0/0/1.10
#给虚拟接口g0/0/1.10配置ip
[R1-GigabitEthernet0/0/1.10]ip add 192.168.10.254 24
#封装协议,加标签
[R1-GigabitEthernet0/0/1.10]dot1q termination vid 10
#开启arp广播
[R1-GigabitEthernet0/0/1.10]arp broadcast enable 
[R1-GigabitEthernet0/0/1.10]int g0/0/1.20
[R1-GigabitEthernet0/0/1.20]ip add 192.168.20.254 24
[R1-GigabitEthernet0/0/1.20]dot1q termination vid 20
[R1-GigabitEthernet0/0/1.20]arp broadcast enable 
[R1-GigabitEthernet0/0/1.20]int g0/0/1.30
[R1-GigabitEthernet0/0/1.30]ip add 192.168.30.254 24
[R1-GigabitEthernet0/0/1.30]dot1q termination vid 30
[R1-GigabitEthernet0/0/1.30]arp broadcast enable 

连通性测试

将PC1~PC4,以及Server1之间的ip互相ping测试,发现都可以互相ping通,实验成功。

错误排查

如若发生无法ping通的问题,请按照如下思路进行排查

  1. 使用ipconfig命令排查下各个终端的ip是否配置正确
  2. 使用display port vlan命令对交换机进行配置排查
  3. 使用display ip interface brief命令对路由器进行配置排查

使用命令:display port vlan

查看设备上所有接口的接口类型和缺省VLAN
其中,“Link Type”表示接口的接口类型,“PVID”表示接口上的缺省VLAN,“Trunk VLAN List”表示Trunk接口上允许通过的VLAN列表,或Hybrid接口上以Tagged方式加入的VLAN。如果接口类型是Access,或Hybrid接口没有以Tagged方式加入VLAN,该处显示“-”。

S1交换机的接口类型如下(同S2交换机)

S3交换机的接口类型如下(同S4交换机)

S5交换机的接口类型如下

检查R1接口配置

#查明接口简要配置信息
[R1]display ip interface brief

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/diannao/45615.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

【C++】继承最全解析(什么是继承?继承有什么用?)

目录 一、前言 二、什么是继承 ? &#x1f4a2;继承的概念&#x1f4a2; &#x1f4a2;继承的定义&#x1f4a2; &#x1f95d;定义格式 &#x1f347;继承权限 三、基类与派生类对象的赋值转换 四、继承的作用域 五、派生类中的默认成员函数 &#x1f4a2…

华润万家超市购物卡怎么使用?

前两天整理杂物&#xff0c;翻出来两张华润的礼品卡&#xff0c;好在还没有过期 但是那卡只能在线下使用&#xff0c;而且面值也就一百 让我专门跑一趟华润感觉太不方便了 最后朋友告诉我说&#xff0c;可以在收卡云上面把卡内的余额直接提出来&#xff0c;我两张一百的卡总…

全国最大汽车经销商被曝拖欠员工工资:车主难提车

ChatGPT狂飙160天&#xff0c;世界已经不是之前的样子。 更多资源欢迎关注 7月12日消息&#xff0c;据国内媒体报道&#xff0c;全国最大的汽车经销广汇集团被爆出深陷困境&#xff0c;不仅拖欠工资&#xff0c;旗下的门店也接连关闭。 有爆料称&#xff0c;广汇公司已经出现…

手机和电脑通过TCP传输

一.工具 手机端&#xff1a;网络调试精灵 电脑端&#xff1a;野火网络调试助手 在开始通信之前&#xff0c;千万要查看一下电脑的防火墙是否关闭&#xff0c;否则可能会无法通信 在开始通信之前&#xff0c;千万要查看一下电脑的防火墙是否关闭&#xff0c;否则可能会无法通信…

redis redisson(仅供自己参考)

redis 通过setnx实现的分布式锁有问题 如图&#xff1a; 解决的新的工具为&#xff08;闪亮登场&#xff09;&#xff1a;redisson redisson可重入锁的原理 实现语言lua&#xff1a; 加锁实现脚本语言&#xff1a; 释放锁的脚本语言&#xff1a; 加锁的lua -- 首先判断这个锁…

复合索引abc,查询的时候查c a和ac都能用到索引吗

复合索引&#xff08;也称为联合索引&#xff09;的使用遵循“最左前缀原则”。这意味着查询条件必须从索引定义的最左边开始&#xff0c;并且连续地匹配索引中的列&#xff0c;才能有效地使用该索引。具体到你提到的复合索引 abc&#xff0c;它意味着索引按照 a、b 和 c 列的顺…

基于docker-compose部署zabbix7.0

1.安装docker和docker-compose 已有可跳过&#xff0c;没有参照我的docker一件安装脚本连接放在下方 一键安装dockerv24.0.6以及docker-compose可离线_docker 24对应docker-compose-CSDN博客 2.运行zabbix-server 1.创建zabbix工作目录 mkdir /zabbix 2.编写docker-compos…

求问DAMASK求解中关于yaml文件,报错显示:type dismatch in yaml date node

&#x1f3c6;本文收录于《CSDN问答解答》专栏&#xff0c;主要记录项目实战过程中的Bug之前因后果及提供真实有效的解决方案&#xff0c;希望能够助你一臂之力&#xff0c;帮你早日登顶实现财富自由&#x1f680;&#xff1b;同时&#xff0c;欢迎大家关注&&收藏&…

Transformer神经网络回归预测的MATLAB实现

Transformer神经网络最初是为自然语言处理&#xff08;NLP&#xff09;任务设计的&#xff0c;但它们也可以成功应用于其他序列数据的处理&#xff0c;如时间序列预测和回归任务。 在回归预测中使用Transformer网络通常涉及以下关键步骤和概念&#xff1a; 1. Transformer架…

代码随想录-暑假算法第一天(数组篇)

代码随想录-暑假算法第一天(数组篇) 1. 二分查找 力扣题目链接(opens new window) 给定一个 n 个元素有序的&#xff08;升序&#xff09;整型数组 nums 和一个目标值 target &#xff0c;写一个函数搜索 nums 中的 target&#xff0c;如果目标值存在返回下标&#xff0c;否…

回车不搜索直接页面刷新问题解决

使用技术栈&#xff1a;vue3、elementUiPlus 问题&#xff1a;回车触发方法&#xff0c;会刷新整个页面&#xff0c;不执行搜索 解决方法&#xff1a;在搜索的表单中增加submit.native.prevent submit.native.prevent

GeoTrust ——适合企业使用的SSL证书!

GeoTrust是一家全球知名的数字证书颁发机构&#xff08;CA&#xff09;&#xff0c;其提供的SSL证书非常适合企业使用。GeoTrust的SSL证书为企业带来了多重优势&#xff0c;不仅在验证级别、加密强度、兼容性、客户服务等方面表现出色&#xff0c;而且其高性价比和灵活的证书选…

C 语言中如何实现图结构?

&#x1f345;关注博主&#x1f397;️ 带你畅游技术世界&#xff0c;不错过每一次成长机会&#xff01; &#x1f4d9;C 语言百万年薪修炼课程 【https://dwz.mosong.cc/cyyjc】通俗易懂&#xff0c;深入浅出&#xff0c;匠心打磨&#xff0c;死磕细节&#xff0c;6年迭代&…

[图解]分析模式-01-概述1

1 00:00:01,380 --> 00:00:01,770 好 2 00:00:02,340 --> 00:00:06,440 非常感谢大家能够来上我们 3 00:00:06,450 --> 00:00:07,960 分析模式高阶的课程 4 00:00:09,310 --> 00:00:13,440 这个内容之前在分析设计高阶 5 00:00:13,450 --> 00:00:17,840 也就…

电气常用知识

1、常开、常闭 在不加外力作用下&#xff0c;展示的状态就是常 因此&#xff0c;常开就是在不加外力作用下的 开的状态&#xff0c;也就是断开的状态 常闭就是在不加外力作用下的闭合的状态&#xff0c;也就是闭合的状态 2、单控双控 单控&#xff1a;一个东西只有两种状态…

Ubuntu 修改~/.bashrc终端选择是否使用annconda环境

首先需要明白的是anaconda虽然自带了python&#xff0c;但安装anaconda后并不会覆盖掉你原来的python&#xff08;pip也是一样的&#xff09;&#xff0c;但安装anaconda后它会把自己的bin目录&#xff08;里面有python、pip、conda等命令&#xff09;加到PATH上&#xff0c;而…

宝马退出价格战,19万买不到i3了

ChatGPT狂飙160天&#xff0c;世界已经不是之前的样子。 更多资源欢迎关注 宝马退出价格战 这一消息&#xff0c;源自知名汽车博主孙少军。 7月11日他发文称&#xff0c;“因价格战导致门店亏损严重&#xff0c;宝马7月将会开始降量保价。” 第二天他又做了补充&#xff0c…

FastAPI 学习之路(四十二)利用Docker部署发布

我们之前的部署都是基于本地的部署&#xff0c;我们这次来看下&#xff0c;如何使用docker部署我们的fastapi项目。 编写Dockerfile ①&#xff1a;首先编写一个docker镜像的制作文件Dockerfile FROM python:3.10RUN pip install fastapi uvicorn aiofiles sqlalchemy pytho…

基于蓝牙iBeacon定位技术的商场3D楼层导视软件功能详解与实施效益

在现代商场的繁华与复杂中&#xff0c;寻找目的地往往令人头疼。维小帮3D楼层导视软件以其创新技术&#xff0c;为顾客带来无缝、直观的跨楼层导航体验&#xff0c;让每一次商场消费都成为享受。 商场3D楼层导视软件功能服务 3D多楼层导视地图&#xff0c;商场布局一览无遗 …

Linux进程——进程的概念

文章目录 PCB进程排队进程标识符pid终止进程获取进程id父进程与子进程 我们在上一节内容中有简单谈到进程的感性理解&#xff0c;他在课本上的概念是&#xff0c;程序的一个执行实例或正在执行的程序 但在本质上&#xff0c;他其实就是一个被分配了系统资源&#xff08;CPU&am…