一.实验拓扑图
二.实验要求
1、R6为ISP,接口IP地址均为公有地址,该设备只能配置IP地址,之后不能再对其进行任何配置;
2、R1-R5为局域网,私有IP地址192.168.1.0/24,请合理分配;
3、R1、R2、R4,各有两个环回IP地址;R5,R6各有一个环回地址;所有路由器上环回均代表连接用户的接口;
4、R3下面的两台PC通过DHCP自动获取IP地址;
5、选路最佳,路由表尽量小,避免环路;
6、R1-R5均可以访问R6的环回;
7、R6 telnet R5的公有地址时,实际登录到R1上;
8、R4与R5正常通过1000M链路,故障时通过100m链路;
三.实验思路
1.根据网段数并且简化路由再划分IP
2.配置DHCP服务,下发给主机IP
3.配置静态路由,使得内网全通
4.配置路由防止成环
5. R4与R5正常通过1000M链路,故障时通过100m链路,即修改优先级
6.配置Easy IP技术,使得公网与私网互通
7.R6telentR5,实则登录R1
四.实验步骤
IP地址的划分
IP地址的配置实现全网可达
//R1的环回地址的配置
[R1]interface LoopBack 0
[R1-LoopBack0]ip address 192.168.1.33 28
[R1-LoopBack0]quit
[R1]interface LoopBack 1
[R1-LoopBack1]ip address 192.168.1.49 28
[R1-LoopBack1]quit
//接口ip的配置
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip ad 192.168.1.1 30
Mar 20 2024 10:40:04-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
[R1-GigabitEthernet0/0/0]quit
[R1]interface g0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.9 30
Mar 20 2024 10:44:21-08:00 R1 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
on the interface GigabitEthernet0/0/1 has entered the UP state.
//路由表的配置
[R1]ip route-static 192.168.1.16 30 192.168.1.10
[R1]ip route-static 192.168.1.20 30 192.168.1.10
[R1]ip route-static 12.0.0.0 24 192.168.1.10
[R1]ip route-static 192.168.1.4 30 192.168.1.2
[R1]ip route-static 192.168.1.12 30 192.168.1.10
[R1]ip route-static 192.168.1.32 27 192.168.1.2
[R1]ip route-static 192.168.1.96 27 192.168.1.2
[R1]ip route-static 192.168.1.128 27 192.168.1.10
[R1]ip route-static 192.168.1.160 27 192.168.1.10
[R1]ip route-static 0.0.0.0 0 192.168.1.10
//避免环路
[R1]ip route-static 192.168.1.32 27 null 0
//R2环回地址的配置
[R2]interface LoopBack 0
[R2-LoopBack0]ip ad 192.168.1.65 28
[R2-LoopBack0]q
[R2]interface LoopBack 1
[R2-LoopBack1]ip ad 192.168.1.81 28
[R2-LoopBack1]quit
//接口IP的配置
[R2]interface g0/0/0
[R2-GigabitEthernet0/0/0]ip ad 192.168.1.2 30
Mar 20 2024 11:19:36-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
[R2-GigabitEthernet0/0/0]quit
[R2]interface g0/0/1
[R2-GigabitEthernet0/0/1]ip ad 192.168.1.6 30
Mar 20 2024 11:20:30-08:00 R2 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
on the interface GigabitEthernet0/0/1 has entered the UP state.
//路由表的配置
[R2]ip route-static 192.168.1.8 30 192.168.1.1
[R2]ip route-static 192.168.1.16 30 192.168.1.1
[R2]ip route-static 12.0.0.0 24 192.168.1.1
[R2]ip route-static 192.168.1.20 30 192.168.1.1
[R2]ip route-static 192.168.1.12 30 192.168.1.5
[R2]ip route-static 192.168.1.32 27 192.168.1.1
[R2]ip route-static 192.168.1.128 27 192.168.1.1
[R2]ip route-static 192.168.1.96 27 192.168.1.5
[R2]ip route-static 192.168.1.160 27 192.168.1.1
[R2]ip route-static 0.0.0.0 0 192.168.1.1
//避免环路
[R2]ip route-static 192.168.1.64 27 null 0
//接口IP的配置
[R3]interface g0/0/1
[R3-GigabitEthernet0/0/1]ip ad 192.168.1.14 30
Mar 20 2024 11:09:09-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface GigabitEthernet0/0/1 has entered the UP state.
[R3]interface g0/0/0
[R3-GigabitEthernet0/0/0]ip ad 192.168.1.5 30
Mar 20 2024 11:09:46-08:00 R3 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
[R3]interface g0/0/2
[R3-GigabitEthernet0/0/0]ip ad 192.168.1.97 27
Mar 20 2024 11:09:46-08:00 R3 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
//路由表的配置
[R3]ip route-static 192.168.1.0 30 192.168.1.6
[R3]ip route-static 192.168.1.8 30 192.168.1.13
[R3]ip route-static 192.168.1.16 30 192.168.1.13
[R3]ip route-static 192.168.1.20 30 192.168.1.13
[R3]ip route-static 12.0.0.0 24 192.168.1.13
[R3]ip route-static 192.168.1.32 27 192.168.1.6
[R3]ip route-static 192.168.1.64 27 192.168.1.6
[R3]ip route-static 192.168.1.128 27 192.168.1.13
[R3]ip route-static 192.168.1.160 27 192.168.1.13
[R3]ip route-static 0.0.0.0 0 192.168.1.13
//R4环回地址
[R4]interface LoopBack 0
[R4-LoopBack0]ip address 192.168.1.129 28
[R4]interface LoopBack 1
[R4-LoopBack1]ip address 192.168.1.145 28
//接口ip的配置
[R4]interface g0/0/0
[R4-GigabitEthernet0/0/0]ip address 192.168.1.10 30
Mar 20 2024 10:49:04-08:00 R4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
[R4]interface g0/0/1
[R4-GigabitEthernet0/0/1]ip ad 192.168.1.13 30
Mar 20 2024 10:49:34-08:00 R4 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
on the interface GigabitEthernet0/0/1 has entered the UP state.
[R4]interface g4/0/0
[R4-GigabitEthernet4/0/0]ip ad 192.168.1.17 30
[R4-GigabitEthernet4/0/0]
Mar 20 2024 10:50:03-08:00 R4 %%01IFNET/4/LINK_STATE(l)[2]:The line protocol IP
on the interface GigabitEthernet4/0/0 has entered the UP state.
[R4]interface g0/0/2
[R4-GigabitEthernet0/0/2]ip ad 192.168.1.21 30
Mar 20 2024 10:50:31-08:00 R4 %%01IFNET/4/LINK_STATE(l)[3]:The line protocol IP
on the interface GigabitEthernet0/0/2 has entered the UP state.
//路由表的配置
[R4]ip route-static 12.0.0.0 24 192.168.1.18
[R4]ip route-static 1.0.0.0 24 192.168.1.18
[R4]ip route-static 192.168.1.0 30 192.168.1.9
[R4]ip route-static 192.168.1.4 30 192.168.1.14
R4]ip route-static 192.168.1.32 27 192.168.1.9
[R4]ip route-static 192.168.1.64 27 192.168.1.9
[R4]ip route-static 192.168.1.96 27 192.168.1.14
[R4]ip route-static 192.168.1.160 27 192.168.1.18
[R4]ip route-static 0.0.0.0 0 192.168.1.18
//避免环路
[R4]ip route-static 192.168.1.128 27 null 0
//R5环回地址的配置
[r5]interface LoopBack 0
[r5-LoopBack0]ip ad 192.168.1.161 27
//接口IP的配置
[r5]interface g0/0/2
[r5-GigabitEthernet0/0/2]ip address 192.168.1.18 30
Mar 20 2024 10:54:52-08:00 r5 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface GigabitEthernet0/0/2 has entered the UP state.
[r5]interface g0/0/0
[r5-GigabitEthernet0/0/0]ip address 192.168.1.22 30
Mar 20 2024 10:55:37-08:00 r5 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
[r5]interface g0/0/1
[r5-GigabitEthernet0/0/1]ip address 12.0.0.1 24
Mar 20 2024 10:56:04-08:00 r5 %%01IFNET/4/LINK_STATE(l)[2]:The line protocol IP
on the interface GigabitEthernet0/0/1 has entered the UP state.
//路由表的配置
[r5]ip route-static 192.168.1.0 30 192.168.1.17
[r5]ip route-static 192.168.1.8 30 192.168.1.17
[r5]ip route-static 192.168.1.12 30 192.168.1.17
[r5]ip route-static 192.168.1.4 30 192.168.1.17
[r5]ip route-static 192.168.1.32 27 192.168.1.17
[r5]ip route-static 192.168.1.64 27 192.168.1.17
[r5]ip route-static 192.168.1.96 27 192.168.1.17
[r5]ip route-static 192.168.1.128 27 192.168.1.17
[r5]ip route-static 192.168.1.160 27 192.168.1.17
[r5]ip route-static 0.0.0.0 0 12.0.0.2
//R6环回地址的配置
[R6]interface LoopBack 0
[R6-LoopBack0]ip ad 1.0.0.1 24
//接口IP的配置
[R6]interface g0/0/0
[R6-GigabitEthernet0/0/0]ip ad 12.0.0.2 24
Mar 20 2024 11:05:52-08:00 R6 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
DHCP协议的设置
[R3]dhcp enable
Info: The operation may take a few seconds. Please wait for a moment.done.
[R3]ip pool rjw
Info: It's successful to create an IP address pool.
[R3-ip-pool-rjw]network 192.168.1.96 mask 27
[R3-ip-pool-rjw]gateway-list 192.168.1.97
[R3-ip-pool-rjw]dns-list 114.114.114.114
[R3-ip-pool-rjw]q
[R3]interface g0/0/2
[R3-GigabitEthernet0/0/2]dhcp select global
R5配置easy IP :
[r5]acl 2000
[r5-acl-basic-2000]rule 10 permit source 192.168.1.0 0.0.255.255
[r5-acl-basic-2000]int g0/0/1
[r5-GigabitEthernet0/0/1]nat out
[r5-GigabitEthernet0/0/1]nat outbound 2000
telnet协议:
//R1路由器上的配置
[R1]aaa
[R1-aaa]local-user admin privilege level 15 password cipher 123456
[R1-aaa]local-user admin service-type telnet
[R1]user-interface vty 0 4
[R1-ui-vty0-4]authentication-mode aaa
//R5配置
[R5-GigabitEthernet0/0/1]nat server protocol tcp global current-interface 23 ins
ide 192.168.1.1 23
Warning:The port 23 is well-known port. If you continue it may cause function fa
ilure.
Are you sure to continue?[Y/N]:y
R6验证:
<R6>telnet 12.0.0.2