给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N
(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>using namespace std;const int N = 35;struct Node
{int val;struct Node* lchild;struct Node* rchild;
}a[N];
int id;int pre[N],in[N];Node* build_tree(int in[],int inl,int inr,int pre[],int prel,int prer)
{if(inl > inr) return NULL;Node* root = &a[id++];root->val = pre[prel];int tmp = 0;for(tmp = inl;in[tmp] != pre[prel];tmp++);root->lchild = build_tree(in,inl,tmp - 1,pre,prel + 1,prel + tmp - inl);root->rchild = build_tree(in,tmp + 1,inr,pre,prel + tmp - inl + 1,prer);return root;
}void test(Node* root)//测试用
{if(!root) return;cout << root->val << " ";test(root->lchild);test(root->rchild);
}void tree_reverse(Node* root)
{if(root == NULL) return;tree_reverse(root->lchild);tree_reverse(root->rchild);swap(root->lchild,root->rchild);
}void order_level(Node* root)
{if(root == NULL) return;queue<Node*> q;q.push(root);int flag = 0;while(q.size()){Node* t = q.front();q.pop();if(flag) cout << " ";cout << t->val;flag = 1;if(t->lchild) q.push(t->lchild);if(t->rchild) q.push(t->rchild);}
}
int main()
{int n = 0;cin >> n;for(int i = 0;i < n;i++) cin >> in[i];for(int i = 0;i < n;i++) cin >> pre[i];Node* root = build_tree(in,0,n - 1,pre,0,n - 1);tree_reverse(root);// test(root);order_level(root);return 0;
}
注:
不会的可以借鉴这个视频的方法。
L2-006 树的遍历 (25 分)_哔哩哔哩_bilibili
结果: