Fliptile【搜索】

Fliptile

 POJ - 3279 

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

这题有点坑,一开始完全没想到搜索,思路是想将第一行所有踩的情况遍历一遍,后面搜索到第n行,从第二行到第n行每一行的目的都是将其前一行的1转化为0,最后判断第n行是否为全为0.

以下是我的代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
int ans;
int num;
int s[20][20];
int mapp[20][20];
int m,n;
int a[20][20];
int b[20][20];
void play(int x)
{ms(a);rep(i,1,n) {rep(j,1,m) {s[i][j]=mapp[i][j];}}num=0;lep(j,m,1) {if(x&1) {s[1][j-1]=!s[1][j-1];s[1][j+1]=!s[1][j+1];s[1][j]=!s[1][j];s[2][j]=!s[2][j];a[1][j]=1;num++;}x>>=1;}rep(i,2,n) {rep(j,1,m) {if(s[i-1][j]==1) {s[i][j-1]=!s[i][j-1];s[i][j+1]=!s[i][j+1];s[i][j]=!s[i][j];s[i+1][j]=!s[i+1][j];s[i-1][j]=!s[i-1][j];a[i][j]=1;num++;}}}rep(i,1,n) {rep(j,1,m) {if(s[i][j]==1)num+=ans;}}
}
void cp()
{rep(i,1,n) {rep(j,1,m) {b[i][j]=a[i][j];}}
}
int main() 
{//freopen("in.txt", "r", stdin);//freopen("out.txt", "w", stdout);ios::sync_with_stdio(0),cin.tie(0);cin>>n>>m;ms(b);rep(i,1,n) {rep(j,1,m) {cin>>mapp[i][j];}}ans=maxn;int x=(1<<m);rep(i,0,x-1) {play(i);if(num<ans) {ans=num;cp();}}if(ans==maxn) {cout<<"IMPOSSIBLE"<<endl;}else {rep(i,1,n) {rep(j,1,m) {cout<<b[i][j]<<" ";}cout<<endl;} 
}return 0;
}

 

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/536399.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

JS异步开发总结

1 前言 众所周知&#xff0c;JS语言是单线程的。在实际开发过程中都会面临一个问题&#xff0c;就是同步操作会阻塞整个页面乃至整个浏览器的运行&#xff0c;只有在同步操作完成之后才能继续进行其他处理&#xff0c;这种同步等待的用户体验极差。所以JS中引入了异步编程&…

迷宫问题【广搜】

迷宫问题 POJ - 3984 定义一个二维数组&#xff1a; int maze[5][5] {0, 1, 0, 0, 0,0, 1, 0, 1, 0,0, 0, 0, 0, 0,0, 1, 1, 1, 0,0, 0, 0, 1, 0,}; 它表示一个迷宫&#xff0c;其中的1表示墙壁&#xff0c;0表示可以走的路&#xff0c;只能横着走或竖着走&#xff0c;不能…

大虾对51单片机入门的经验总结

回想起当初学习AT89S52的日子还近在眼前:毕业后的第一年呆在亲戚公司做了10个月设备管理.乏味的工作和繁杂的琐事让我郁闷不已.思考很久后终于辞职.投奔我的同学去了,开始并不曾想到要进入工控行业,知识想找一份电子类技术职业,至于什么职业我根本没有目标可言.经过两个多月的挫…

mac安装cnpm

1.先安装node node的下载地址&#xff1a;http://nodejs.cn/download/ 这个没什么好说的&#xff0c;安装完成后测试一下&#xff0c;在终端输入&#xff1a;node -v 这时候就可以看到安装的node版本号&#xff0c;再输入&#xff1a;npm -v 这时候就会看到npm的版本号了 2.用n…

A计划【广搜】

A计划 HDU - 2102 可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后&#xff0c;而今&#xff0c;不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主&#xff0c;因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚&#xff0c;告招天…

WordPress忘记密码的5种解决方法

为什么80%的码农都做不了架构师&#xff1f;>>> 无意中忘记wordpress的密码了&#xff0c;恰巧在后台又没来得及设置邮件&#xff0c;只好四处苦寻解决办法&#xff0c;还好总算找到了…… 1. WordPress内置的找加密码方法 如果你的admin帐户的电子邮件地址是正确的…

记录一次,事务遇到消息发送,疏忽给自己挖坑

场景&#xff1a;一个异步重算功能&#xff08;任务新建后发送消息到RocketMq&#xff09;&#xff0c;每次重算单条记录的时候&#xff0c;可以计算正确&#xff0c;但是当多条记录批量重算时&#xff0c;结果总是莫名其妙的不对。排查了很久&#xff0c;终于找到原因 原因&am…

在linux上执行.net Console apps

为什么80%的码农都做不了架构师&#xff1f;>>> 有个程序&#xff0c;在.net下写了半天&#xff0c;总算跑起来了&#xff0c;发现有个问题&#xff0c;在windows上不好弄&#xff0c;而同事前一段时间已经有Linux下的解决方法了&#xff0c;于是想直接将.net程序放…

Android4.0设置界面修改总结

为什么80%的码农都做不了架构师&#xff1f;>>> 笔者前段时间完成设置的圆角item风格的修改&#xff0c;但最近&#xff0c;客户新增需求&#xff0c;想把设置做成Tab风格的&#xff0c;没办法&#xff0c;顾客就是上帝&#xff0c;咱得改啊。今天算是初步改完了&a…

敌兵布阵【线段树】

敌兵布阵 HDU - 1166 C国的死对头A国这段时间正在进行军事演习&#xff0c;所以C国间谍头子Derek和他手下Tidy又开始忙乎了。A国在海岸线沿直线布置了N个工兵营地,Derek和Tidy的任务就是要监视这些工兵营地的活动情况。由于采取了某种先进的监测手段&#xff0c;所以每个工兵…

Android之仿网易V3.5新特性

为什么80%的码农都做不了架构师&#xff1f;>>> 最近&#xff0c;网易新闻更新到V3.5了&#xff0c;给我印象最深的是第一次进应用时显示新特性的ViewPager变成垂直滑动了。于是&#xff0c;小小的模仿了一下&#xff0c;我们来看看效果&#xff1a; 本文源码下载地…

Android_内存泄露

2019独角兽企业重金招聘Python工程师标准>>> 1.资源对象没关闭造成的内存泄漏 描述&#xff1a; 资源性对象比如&#xff08;Cursor&#xff0c;File文件等&#xff09;往往都用了一些缓冲&#xff0c;我们在不使用的时候&#xff0c;应该及时关闭它们&#xff0c;以…

CYQ.Data 轻量数据层之路 使用篇三曲 MAction 取值赋值(十四)

2019独角兽企业重金招聘Python工程师标准>>> 上一篇&#xff1a;CYQ.Data 轻量数据层之路 使用篇二曲 MAction 数据查询(十三&#xff09; 内容概要 本篇继续上一篇内容&#xff0c;本节介绍所有取值与赋值的相关操作。1&#xff1a;原生&#xff1a;像操作Row一样…

CYQ.Data 数据框架 发放V1.5版本源码

2019独角兽企业重金招聘Python工程师标准>>> 本篇的内容很简单&#xff0c;就发放V1.5版本源码&#xff0c;同时补充了所有发布版本的API文档。 具体相关下载地址见&#xff1a; 秋色园下载中心&#xff1a;http://www.cyqdata.com/download/article-detail-426 如何…

New Bus Route

New Bus Route CodeForces - 792A There are n cities situated along the main road of Berland. Cities are represented by their coordinates — integer numbers a1, a2, ..., an. All coordinates are pairwise distinct. It is possible to get from one city to …

爱说说技术原理:与TXT交互及MDataTable对Json的功能扩展(二)

2019独角兽企业重金招聘Python工程师标准>>> 关于爱说说在技术选型的文章见&#xff1a;"爱说说"技术原理方案的定选思考过程 本篇将讲述“爱说说”比较重大的技术问题点及解决手段&#xff1a; 爱说说&#xff1a;http://speak.cyqdata.com/ 杂说几句&am…

ActiveXObject 安装

将后缀名为ocx的文件拷贝至目录 c:\Windows\SysWOW64\。执行如下命令&#xff0c;进行注册&#xff1a;regsvr32 c:\Windows\SysWOW64\x.ocx转载于:https://www.cnblogs.com/Currention/p/11024354.html

如何制作VSPackage的安装程序

2019独角兽企业重金招聘Python工程师标准>>> 第一步&#xff0c;生成一个REG文件&#xff1a; 收钱进入目录: C:\Program Files\Microsoft Visual Studio 2008 SDK\VisualStudioIntegration\Tools\Bin 这是SDK的目录&#xff0c;使用regpkg.exe 命令 命令格式为: …

MyBatis学习总结(1)——MyBatis快速入门

2019独角兽企业重金招聘Python工程师标准>>> 一、Mybatis介绍 MyBatis是一个支持普通SQL查询&#xff0c;存储过程和高级映射的优秀持久层框架。MyBatis消除了几乎所有的JDBC代码和参数的手工设置以及对结果集的检索封装。MyBatis可以使用简单的XML或注解用于配置和…

MyEclipse+Tomcat+MAVEN+SVN项目完整环境搭建

2019独角兽企业重金招聘Python工程师标准>>> 这次换了台电脑&#xff0c;所以需要重新配置一次项目开发环境&#xff0c;过程中的种种&#xff0c;记录下来&#xff0c;便于以后再次安装&#xff0c;同时给大家一个参考。 1.JDK的安装 首先下载JDK&#xff0c;这个从…