Fliptile
POJ - 3279
Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.
As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.
Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".
Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0
这题有点坑,一开始完全没想到搜索,思路是想将第一行所有踩的情况遍历一遍,后面搜索到第n行,从第二行到第n行每一行的目的都是将其前一行的1转化为0,最后判断第n行是否为全为0.
以下是我的代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
int ans;
int num;
int s[20][20];
int mapp[20][20];
int m,n;
int a[20][20];
int b[20][20];
void play(int x)
{ms(a);rep(i,1,n) {rep(j,1,m) {s[i][j]=mapp[i][j];}}num=0;lep(j,m,1) {if(x&1) {s[1][j-1]=!s[1][j-1];s[1][j+1]=!s[1][j+1];s[1][j]=!s[1][j];s[2][j]=!s[2][j];a[1][j]=1;num++;}x>>=1;}rep(i,2,n) {rep(j,1,m) {if(s[i-1][j]==1) {s[i][j-1]=!s[i][j-1];s[i][j+1]=!s[i][j+1];s[i][j]=!s[i][j];s[i+1][j]=!s[i+1][j];s[i-1][j]=!s[i-1][j];a[i][j]=1;num++;}}}rep(i,1,n) {rep(j,1,m) {if(s[i][j]==1)num+=ans;}}
}
void cp()
{rep(i,1,n) {rep(j,1,m) {b[i][j]=a[i][j];}}
}
int main()
{//freopen("in.txt", "r", stdin);//freopen("out.txt", "w", stdout);ios::sync_with_stdio(0),cin.tie(0);cin>>n>>m;ms(b);rep(i,1,n) {rep(j,1,m) {cin>>mapp[i][j];}}ans=maxn;int x=(1<<m);rep(i,0,x-1) {play(i);if(num<ans) {ans=num;cp();}}if(ans==maxn) {cout<<"IMPOSSIBLE"<<endl;}else {rep(i,1,n) {rep(j,1,m) {cout<<b[i][j]<<" ";}cout<<endl;}
}return 0;
}