poj 1836 Alignment

题目大意:

给定一排人的身高,求踢出最少的人可以使队列身高如下形状:

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4





/*


/*
/*#include <iostream>
#include<cstdio>
using namespace std;
int r_dp[1010];
int l_dp[1010];
double num[1010];
int maxn;
int main()
{
     int n;
     cin>>n;
     for(int i=1;i<=n;i++)
     {
          cin>>num[i];
          l_dp[i]=r_dp[i]=1;
     }
     maxn=0;
     for(int i=1;i<=n;i++)
     {
          maxn=0;
          for(int j=1;j<i;j++)
          {
                if(num[i]>num[j])
                    maxn=max(maxn,l_dp[j]);
          }
          l_dp[i]=maxn+1;
     }
     for(int i=n;i>=1;i--)
     {
           maxn=0;
           for(int j=n;j>i;j--)
           {
                if(num[i]>num[j])
                    maxn=max(maxn,r_dp[j]);
           }
           r_dp[i]=maxn+1;
     }
     for(int i=1;i<=n;i++)
        l_dp[i]=max(l_dp[i],l_dp[i-1]);
     for(int i=n;i>=1;i--)
        r_dp[i]=max(r_dp[i+1],r_dp[i]);
     maxn=0;
     for(int i=1;i<=n;i++)
     {
          maxn=max(maxn,r_dp[i+1]+l_dp[i]);
     }
     cout<<n-maxn<<endl;
    return 0;
}*/
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
        int n,i,j;
        double a[1010];
        int lenl[1010],lenr[1010];
        int maxn;
        cin>>n;
        for(i=0;i<n;i++)
            cin>>a[i];
            lenl[0]=1;
        for(i=1;i<n;i++)
        {
             maxn=0;
             for(j=0;j<i;j++)
             {
                   if(a[i]>a[j]&&maxn<lenl[j])
                    maxn=lenl[j];
             }
             lenl[i]=maxn+1;
        }
        lenr[n-1]=1;
        for(i=n-2;i>=0;i--)
        {
               maxn=0;
               for(j=i+1;j<n;j++)
               {
                     if(a[i]>a[j]&&maxn<lenr[j])
                        maxn=lenr[j];
               }
               lenr[i]=maxn+1;
        }
        maxn=0;
        for(i=0;i<n-1;i++)
        {
              for(j=i+1;j<n;j++)
              {
                    if(lenl[i]+lenr[j]>maxn)
                        maxn=lenl[i]+lenr[j];
              }
        }
        cout<<n-maxn<<endl;
}

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/509167.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

Qt程序崩溃原因

Qt写的程序在执行过程中莫名其妙的出现崩溃&#xff0c;代码没有任何问题。最后发现原因是因为Release版本的程序链接了Debug版的lib文件&#xff0c;所以导致程序执行过程中莫名其妙的出现崩溃。此类错误出现了很多次了&#xff0c;查找起来异常困难&#xff0c;需要注意&…

【转载】jvm内存回收

1.java的内存 java的内存结构分为 堆 (是gc的主要区域) 线程共享,主要是用于分配实例对象和数组 栈 线程私有,它的生命周期和线程相同,又分成 虚拟机栈和本地方法栈,只有它会报 StackOverFlowError,栈深度超标 方法区 线程共享 用于储存被虚拟机加载的类的信息,静态变量 常量和…

2016杭州ccpc

Kingdom of Obsession 标签&#xff1a; 二分图最大匹配2016-10-29 16:23 51人阅读 评论(2) 收藏 举报分类&#xff1a;二分图和最大匹配&#xff08;2&#xff09; 版权声明&#xff1a;本文为棒&#xff08;xian&#xff09;棒&#xff08;yu&#xff09;博主原创文章&#x…

深入理解C语言的函数调用过程

本文主要从进程栈空间的层面复习一下C语言中函数调用的具体过程&#xff0c;以加深对一些基础知识的理解。 先看一个最简单的程序&#xff1a; 点击(此处)折叠或打开 /*test.c*/#include <stdio.h> int foo1(int m,int n,int p){ int x m n p; …

【转载保存】RunTime.getRunTime().addShutdownHook 添加钩子

https://blog.csdn.net/gongxinju/article/details/69963099

Unity3D打包后日志文件输出目录

Unity3D打包后日志文件输出目录&#xff0c;包括日志文件和崩溃时记录文件 C:\Users\Administrator\AppData\LocalLow\长沙迪迈科股份有限公司\镍矿探秘 其中"..\长沙迪迈科股份有限公司\镍矿探秘" 为unity的公司和产品设置

【转载保存】Jsoup使用

https://blog.csdn.net/ricky73999/article/details/54989972

Unity3d LookAt参数说明

Unity3d LookAt参数说明 //// 摘要: // Rotates the transform so the forward vector points at targets current position.//// 参数: // target:// Object to point towards.//// worldUp:// Vector specifying the upward direction.public void LookAt(…

SteamVR导致场景相机不正常

在Unity3D项目中导入SteamVR和VRTK后&#xff0c;有时候会导致非VR场景中的相机运行后异常&#xff0c;姿态和位置不对。 导致的原因可能是&#xff0c;工程设置不对&#xff08;SteamVR和VRTK依赖一些预定义宏&#xff09;&#xff0c;需要将相应的工程设置ProjectSettings文…

【转载保存】java优先队列使用

PriorityBlockingQueue是一个带优先级的阻塞队列,提供了阻塞获取操作。元素按优先级顺序被移除&#xff0c;该队列也没有上限&#xff08;看了一下源码&#xff0c;PriorityBlockingQueue是对 PriorityQueue的再次包装&#xff0c;是基于堆数据结构的&#xff0c;而PriorityQue…

【转载保存】HtmlUnit的使用

信息来源&#xff1a; https://blog.csdn.net/moneyshi/article/details/78799949 https://blog.csdn.net/qq_36176250/article/details/77199595

初入职场的你不应错过的一些书籍

在职场中&#xff0c;听过最接地气的一句话就是&#xff1a;在职场中要眼睛里有活儿&#xff0c;知道什么该说什么不该说&#xff0c;也不要说自己不确定的事情。今天来推荐一些职场老手建议看的书 《好好说话》 有太多人初入职场不会说话&#xff0c;而说话的能力是可以培养的…

关于 Unity WebGL 的探索

转自:https://www.cnblogs.com/yaukey/p/unity_webgl_explore_1.html 查找了 Unity 的官方资料&#xff0c;我们如果需要使用 WebGL 需要面对以下几个挑战&#xff1a; Native Plugin&#xff1a;也就是说各种原生插件&#xff08;C/C等编译的本地机器码库&#xff09;&#…

【转载保存】cookie在登录时的使用

地址:https://blog.csdn.net/df19900725/article/details/78066468?locationNum4&fps1 浏览器按F12点击network中其中一个文件&#xff0c;查看右边信息&#xff0c;把带有Cookie:这种放在addCookie(“Cookie”,“Cookie:”)这种格式

TCP/IP协议详解 卷一(阅读指导)

1. 为了利用网络知识理解服务端网络架构、排查问题、解决问题. 真的没有必要背, wireshark 工具都给你解析的不能再细了。有没有重传&#xff0c;有没有乱序&#xff0c;数据包接收的时间&#xff0c;发送窗口多大&#xff0c;数据有没有拥塞&#xff0c;等等.... 以及协议的解…

Unity脚本生命周期与执行顺序

目录 脚本生命周期 MonoBehavior生命周期图脚本执行顺序 自定义执行顺序 (文章目录) 在Unity中&#xff0c;脚本可以理解为附加在游戏对象上的用于定义游戏对象行为的指令代码。必须绑定在游戏对象上才能开始它的生命周期。游戏对象可以理解为能容纳各种组件的容器&#xff0c…

【转载保存】Java丨jsoup网络爬虫登录得到cookie并带上cookie访问

优秀文章:https://blog.csdn.net/wisdom_maxl/article/details/65631825 jsoup使用cookie&#xff1a; Set<Cookie> cookie_set LoadCSDN.load(); // WebClient wc new WebClient();HashMap<String, String> map new HashMap<String,String>();for (Cook…

Unity3D(UE4)加载倾斜摄影数据OSGB格式

在Unity3D平台动态加载调度倾斜摄影数据&#xff0c;利用多线程动态加载瓦片数据&#xff0c;可以顺畅加载海量的瓦片数据。目前测试可流畅加载100G左右数据&#xff0c;支持加载本地数据&#xff0c;数据可不放在Unity工程内&#xff0c;也可以将数据放置在服务器上实现网络加…

【转载保存】Jsoup解析html常用方法

首先我们要清楚 class的继承关系 Document 继承于 Element 继承于 Node 继承于 Object 首先 我们先研究一下 Element 中的函数作用: 01 addClass(String className) --> 添加一个class名字 到这个元素的class属性上. 02 after(Node node) --> 将指定的节点添加…