1053 Path of Equal Weight (30分)
Given a non-empty tree with root R, and with weight W
i
assigned to each tree node T
i
. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2
30
, the given weight number. The next line contains N positive numbers where W
i
(<1000) corresponds to the tree node T
i
. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A
1
,A
2
,⋯,A
n
} is said to be greater than sequence {B
1
,B
2
,⋯,B
m
} if there exists 1≤k<min{n,m} such that A
i
=B
i
for i=1,⋯,k, and A
k+1
>B
k+1
.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
思路:
步骤1:
一颗普通性质树,以结构体node存放数据域和指针域,其中指针域使用vector存放孩子节点编号,考虑到最后输出需要按权值从大到小排序,因此在数据读入时就进行节点排序。
步骤2:
用vector path对路径进行记录,接下来进行dfs,
如果weight>输入的权重num,返回;
如果weight==输入的权重num,进行节点判断,如果为叶子节点,输出路径,否则return;
如果weight<输入的权重num,进入下一层递归
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 101;
int n, m, num;
struct info
{int data;//数据域,存储节点的weightvector<int>v;//指针域,存储孩子节点
}node[maxn];//节点数组
vector<int>path;
bool cmp(int a, int b)//节点数据域从大到小排序
{return node[a].data > node[b].data;
}
void dfs(int root,int weight)
{if (weight > num)return;//当前总重量大于numif (weight == num)//{if (node[root].v.size() > 0)return;//存在叶子节点for (int i = 0; i < path.size(); i++)//为叶子节点{if (i == 0)cout << node[path[i]].data;else cout << " " << node[path[i]].data;}cout << endl;return;}for (int i = 0; i < node[root].v.size(); i++){path.push_back(node[root].v[i]);//用path存储路径dfs(node[root].v[i], weight + node[node[root].v[i]].data);path.pop_back();//回溯时记得弹出}
}
int main()
{cin >> n >> m >> num;for (int i = 0; i < n; i++){cin >> node[i].data;}for (int i = 0; i < m; i++){int parent,k,child;cin >> parent >> k;for (int j = 0; j < k; j++){cin >> child;node[parent].v.push_back(child);}sort(node[parent].v.begin(), node[parent].v.end(),cmp);}path.push_back(0);//将节点0先存入路径dfs(0, node[0].data);
}