1110 Complete Binary Tree (25分)
Given a tree, you are supposed to tell if it is a complete binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.
Sample Input 1:
9
7 8
0 1
2 3
4 5
Sample Output 1:
YES 8
Sample Input 2:
8
4 5
0 6
2 3
- 7
-
-
Sample Output 2:
NO 1
#include<iostream>
#include<string>
using namespace std;
struct node {int l;int r;
}no[21];
int maxn = -1;
int ans;
void dfs(int root, int index)
{if (index > maxn){maxn = index;ans = root;}if (no[root].l != -1)dfs(no[root].l, 2 * index);if (no[root].r != -1)dfs(no[root].r, 2 * index + 1);
}
int main()
{int n;string str1,str2;int fa[21]{0};cin >> n;for (int i = 0; i < n; i++){cin >> str1>>str2;if (str1 == "-"){no[i].l = -1;}else{no[i].l = stoi(str1);fa[no[i].l] = 1;}if (str2 == "-"){no[i].r = -1;}else{no[i].r = stoi(str2);fa[no[i].r] = 1;}}int i;for (i = 0; i < n; i++){if (fa[i] == 0){break;}}dfs(i, 1);if (maxn == n)cout << "YES " << ans;elsecout << "NO " << i;return 0;}