输入不超过1000的正整数n,输出n的阶乘的精确结果
样例输入:30
样例输出:265252859812191058636308480000000
分析:
为了保存结果,需要分析1000!有多大。用计算器算一算不难知道,1000!约等于4*10^2567,因此可以用一个3000个元素的数组f保存。为方便起见,让f【0】保存个位,f【1】保存十位等等,,,(方便向后进位);然后逆序除零输出即可
- <span style="font-size:24px;"><strong>#include<iostream>
- #include<cstring>
- using namespace std;
- const int maxn = 3000;
- int f[maxn];
- int main()
- {
- int i, j, n; //n!
- cin>>n;
- memset(f, 0, sizeof(f)); //对f数组初始化
- f[0]=1; //从1开始乘积
- for(i=2;i<=n;i++)
- {
- int c=0;
- for(j=0;j<maxn;j++)
- {
- int s = f[j]*i + c;
- f[j] = s % 10;
- c = s / 10;
- }
- }
- for(j=maxn-1;j>=0;j--)
- if(f[j])
- break;
- for(i=j;i>=0;i--)
- cout<<f[i];
- cout<<endl;
- system("pause");
- return 0;
- }
- </strong></span>