题干:
Our protagonist is the handsome human prince Aragorn comes from The Lord of the Rings. One day Aragorn finds a lot of enemies who want to invade his kingdom. As Aragorn knows, the enemy has N camps out of his kingdom and M edges connect them. It is guaranteed that for any two camps, there is one and only one path connect them. At first Aragorn know the number of enemies in every camp. But the enemy is cunning , they will increase or decrease the number of soldiers in camps. Every time the enemy change the number of soldiers, they will set two camps C1 and C2. Then, for C1, C2 and all camps on the path from C1 to C2, they will increase or decrease K soldiers to these camps. Now Aragorn wants to know the number of soldiers in some particular camps real-time.
Input
Multiple test cases, process to the end of input.
For each case, The first line contains three integers N, M, P which means there will be N(1 ≤ N ≤ 50000) camps, M(M = N-1) edges and P(1 ≤ P ≤ 100000) operations. The number of camps starts from 1.
The next line contains N integers A1, A2, ...AN(0 ≤ Ai ≤ 1000), means at first in camp-i has Ai enemies.
The next M lines contains two integers u and v for each, denotes that there is an edge connects camp-u and camp-v.
The next P lines will start with a capital letter 'I', 'D' or 'Q' for each line.
'I', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, increase K soldiers to these camps.
'D', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, decrease K soldiers to these camps.
'Q', followed by one integer C, which is a query and means Aragorn wants to know the number of enemies in camp C at that time.
Output
For each query, you need to output the actually number of enemies in the specified camp.
Sample Input
3 2 5 1 2 3 2 1 2 3 I 1 3 5 Q 2 D 1 2 2 Q 1 Q 3
Sample Output
7 4 8
Hint
1.The number of enemies may be negative.2.Huge input, be careful.
题目大意:
给定一颗树,有点权。
要求支持三种操作,将一条路径上的所有点权值增加k,减少k,询问某点的权值。
解题报告:
板子题。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
struct Edge {int u,v;int ne;
} e[MAX];
struct TREE {int l,r;int sum;int laz;
} tr[MAX<<2];
int a[MAX],n,m,q;
int head[MAX],tot;
char op[5];
int c1,c2,k;
int dep[MAX],size[MAX],son[MAX],fa[MAX],top[MAX],tp;
int p[MAX],fp[MAX],pos;//pos 反pos
int len(int cur) {return tr[cur].r - tr[cur].l + 1;
}
void pushup(int cur) {tr[cur].sum = tr[cur*2].sum + tr[cur*2+1].sum;
}
void pushdown(int cur) {if(tr[cur].laz == 0) return;int tmp = tr[cur].laz;tr[cur].laz = 0;tr[cur*2].sum += len(cur*2) * tmp;tr[cur*2+1].sum += len(cur*2+1) * tmp;tr[cur*2].laz += tmp;tr[cur*2+1].laz += tmp;
}
void build(int l,int r,int cur) {tr[cur].l = l;tr[cur].r = r;tr[cur].laz = 0;if(l == r) {tr[cur].sum = a[fp[l]];return;}int m = (l+r)/2;build(l,m,cur*2);build(m+1,r,cur*2+1); pushup(cur);
}
void update(int pl,int pr,int val,int cur) {if(pl <= tr[cur].l && pr >= tr[cur].r) {tr[cur].sum += len(cur) * val;tr[cur].laz += val;return;}pushdown(cur);if(pl <= tr[cur*2].r) update(pl,pr,val,cur*2);if(pr >= tr[cur*2+1].l) update(pl,pr,val,cur*2+1);pushup(cur);
}
int query(int tar,int cur) {if(tr[cur].l == tr[cur].r) return tr[cur].sum;pushdown(cur);if(tar <= tr[cur*2].r) return query(tar,cur*2);if(tar >= tr[cur*2+1].l) return query(tar,cur*2+1);
}
void add(int u,int v) {e[++tot].u = u; e[tot].v = v;e[tot].ne = head[u]; head[u] = tot;
}
void dfs1(int cur,int rt) {size[cur] = 1;son[cur] = 0;fa[cur] = rt;dep[cur] = dep[rt] + 1;for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].v;if(v == rt) continue;dfs1(v,cur);size[cur] += size[v];if(size[v] > size[son[cur]]) son[cur] = v;}
}
void dfs2(int cur,int tp) {top[cur] = tp;p[cur] = ++pos;fp[pos] = cur;if(son[cur]) dfs2(son[cur],tp);for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].v;if(v == fa[cur] || v == son[cur]) continue;dfs2(v,v);}
}
void init() {tot=pos=0;for(int i = 1; i<=n; i++) head[i] = -1;
}
void change(int u,int v,int val) {while(top[u] != top[v]) {if(dep[top[u]] < dep[top[v]]) swap(u,v);//让u的top始终是深度大的那个 update(p[top[u]],p[u],val,1);u = fa[top[u]];}if(dep[u] > dep[v]) swap(u,v);//让u是深度小的,因为深度小的在序列的前面update(p[u],p[v],val,1);
}
int main()
{while(~scanf("%d%d%d",&n,&m,&q)) {init();for(int i = 1; i<=n; i++) scanf("%d",a+i);for(int a,b,i = 1; i<=m; i++) {scanf("%d%d",&a,&b);add(a,b);add(b,a);}dfs1(1,0);dfs2(1,1);build(1,n,1);while(q--) {scanf("%s",op);if(op[0] == 'I') {scanf("%d%d%d",&c1,&c2,&k);change(c1,c2,k);}else if(op[0] == 'D') {scanf("%d%d%d",&c1,&c2,&k);change(c1,c2,-k);}else {scanf("%d",&k);printf("%d\n",query(p[k],1));}}}return 0 ;
}