【HDU - 4597】Play Game(博弈dp)

题干:

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input

The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤bi≤10000).

Output

For each case, output an integer, indicating the most score Alice can get.

Sample Input

2 1 
23 
53 3 
10 100 20 
2 4 3 

Sample Output

53 
105 

题目大意:

Alice和Bob玩一个游戏,有两个长度为N的正整数数字序列,每次他们两个只能从其中一个序列,选择两端中的一个拿走。他们都希望可以拿到尽量大的数字之和,并且他们都足够聪明,每次都选择最优策略。Alice先选择,问最终Alice能拿到的数字总和是多少?

解题报告:

直接dp[][][][]就行了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 20 + 5;
int dp[MAX][MAX][MAX][MAX],sa[MAX],sb[MAX];
int a[MAX],b[MAX];
int n,sum;
int dfs(int l,int r,int L,int R) {if(dp[l][r][L][R] != -1) return dp[l][r][L][R];int res = 0;int ssum = sa[r]-sa[l-1] + sb[R]-sb[L-1];if(l<=r) res = max(res,ssum - dfs(l+1,r,L,R)),res = max(res,ssum - dfs(l,r-1,L,R));if(L<=R) res = max(res,ssum - dfs(l,r,L+1,R)),res = max(res,ssum - dfs(l,r,L,R-1));return dp[l][r][L][R] = res;
}
int main()
{int t;cin>>t;while(t--) {scanf("%d",&n);sum=0;memset(dp,-1,sizeof dp);for(int i = 1; i<=n; i++) scanf("%d",a+i),sum += a[i],sa[i] = sa[i-1] + a[i];for(int i = 1; i<=n; i++) scanf("%d",b+i),sum += b[i],sb[i] = sb[i-1] + b[i];printf("%d\n",dfs(1,n,1,n));} return 0 ;
}

 

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/439956.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

1.3)深度学习笔记------浅层神经网络

目录 1&#xff09;Neural Network Overview 2&#xff09;Neural Network Representation 3&#xff09;Computing a Neural Network’s Output&#xff08;重点&#xff09; 4&#xff09;Vectorizing across multiple examples 5&#xff09;Activation functions 6&a…

git 实战

配置ssh git config --global user.name "用户名" git config --global user.email "邮箱"ssh-keygen -t rsa -C "邮箱"需要进行确认:1. 确认秘钥的保存路径(不需要改直接回车)2. 如果上一步置顶的保存路径下已经有秘钥文件&…

SpringMVC 的执行流程

SpringMVC 的执行流程 1&#xff09;用户向服务器发送请求&#xff0c;请求被 Spring 前端控制 Servelt DispatcherServlet捕获&#xff1b; 2&#xff09;DispatcherServlet 对请求 URL 进行解析&#xff0c;得到请求资源标识符&#xff08;URI&#xff09;。然后根据该 URI&…

【POJ - 2987】Firing(最大权闭合图,网络流最小割,输出方案最小,放大权值法tricks)

题干&#xff1a; You’ve finally got mad at “the world’s most stupid” employees of yours and decided to do some firings. You’re now simply too mad to give response to questions like “Don’t you think it is an even more stupid decision to have signed …

kafka初识

kafka中文文档 本文环境&#xff1a;ubuntu:18.04 kafka安装、配置与基本使用(单节点) 安装kafka 下载 0.10.0.1版本并解压缩 > tar -xzf kafka_2.11-0.10.0.1.tgz > cd kafka_2.11-0.10.0.1.tgzkafka简单配置 > vi config/server.properties主要注意三个地方&a…

1.4)深度学习笔记------深层神经网络

目录 1&#xff09;Deep L-layer neural network 2&#xff09;Forward Propagation in a Deep Network(重点) 3&#xff09;Getting your matrix dimensions right 4&#xff09;Building blocks of deep neural networks 5&#xff09;Forward and Backward Propagation…

Struts1工作原理

Struts1工作原理图 1、初始化&#xff1a;struts框架的总控制器ActionServlet是一个Servlet&#xff0c;它在web.xml中配置成自动启动的Servlet&#xff0c;在启动时总控制器会读取配置文件(struts-config.xml)的配置信息&#xff0c;为struts中不同的模块初始化相应的对象。(面…

【洛谷 - P1772 】[ZJOI2006]物流运输(dp)

题干&#xff1a; 题目描述 物流公司要把一批货物从码头A运到码头B。由于货物量比较大&#xff0c;需要n天才能运完。货物运输过程中一般要转停好几个码头。物流公司通常会设计一条固定的运输路线&#xff0c;以便对整个运输过程实施严格的管理和跟踪。由于各种因素的存在&am…

RabbitMQ初识

官方介绍 - 中文 本文环境&#xff1a;ubuntu:20.04 RabbitMQ安装、配置与基本使用 安装RabbitMQ # 简易脚本安装 curl -s https://packagecloud.io/install/repositories/rabbitmq/rabbitmq-server/script.deb.sh | sudo bash sudo apt-get install rabbitmq-server -y --f…

Apollo进阶课程 ⑦ | 高精地图的采集与生产

目录 1.高精地图采集过程中需要用到的传感器 1.1&#xff09;GPS 1.2&#xff09;IMU 1.3&#xff09;轮速计 2.高精地图采集过程中的制图方案 2.1&#xff09;方案一 激光雷达 2.2&#xff09;Camera融合激光雷达 原文链接&#xff1a;Apollo进阶课程 ⑦ | 高精地图的采…

【BZOJ 3831】【Poi2014】Little Bird(单调队列优化dp)

题干&#xff1a; Description In the Byteotian Line Forest there are trees in a row. On top of the first one, there is a little bird who would like to fly over to the top of the last tree. Being in fact very little, the bird might lack the strength to f…

你看不懂的spring原理是因为不知道这几个概念

背景 问题从一杯咖啡开始。 今天我去楼下咖啡机买了一杯「粉黛拿铁」。制作过程中显示&#xff1a; 我取了做好的粉黛拿铁&#xff0c;喝了一口&#xff0c;果然就是一杯热巧克力。咦咦咦&#xff0c;说好的拿铁呢&#xff1f;虽然我对「零点吧」的咖啡评价很高&#xff0c;觉…

EasyOcr 安装(linux、docker)、使用(gin、python)

EasyOcr git地址 EasyOCR是一款用python语言编写的OCR第三方库&#xff0c;同时支持GPU和CPU&#xff0c;目前已经支持超过70种语言. 安装(CPU) 注意&#xff1a; 本文是在仅在cpu下使用。如要使用CUDA版本&#xff0c;请在pytorch网站上选择正确的&#xff0c;并关闭此文章。…

Python之Numpy入门实战教程(2):进阶篇之线性代数

Numpy、Pandas、Matplotlib是Python的三个重要科学计算库&#xff0c;今天整理了Numpy的入门实战教程。NumPy是使用Python进行科学计算的基础库。 NumPy以强大的N维数组对象为中心&#xff0c;它还包含有用的线性代数&#xff0c;傅里叶变换和随机数函数。 本文主要介绍Numpy库…

【牛客 - 369F】小D的剑阵(最小割建图,二元关系建图,网络流最小割)

题干&#xff1a; 链接&#xff1a;https://ac.nowcoder.com/acm/contest/369/F 来源&#xff1a;牛客网 题目描述 现在你有 n 把灵剑&#xff0c;其中选择第i把灵剑会得到的 wiw_iwi​ 攻击力。 于此同时&#xff0c;还有q个约束&#xff0c;每个约束形如&#xff1a; …

一步步编写操作系统 1 部署工作环境 1

1.1工欲善其事&#xff0c;必先利其器。 如果您觉得操作系统已属于很底层的东西&#xff0c;我双手赞成。但是如果您像我之前一样&#xff0c;觉得底层的东西无法用上层高级的东西来构建&#xff0c;现在可以睁大眼睛好好看看下面要介绍的东西了。 首先&#xff0c;操作系统是…

多用户操作git“远程仓库“(本地)

设置本地远程仓库 准备远程仓库文件 cd ~/git-repo.git初始化 git init --shared修改git的接收配置 git config receive.denyCurrentBranch ignore初始化git仓库 git config user.email "fxmfxm.com" git config user.name "fxm" git add . git commit -m …

10点43博客文章汇总(2018年度)

今天是春节后上班第一天&#xff0c;将2018年度的文章进行汇总。总共分为三类&#xff1a;翻译、转载、原创。 1.翻译 翻译类目前完结的有Kaggle上的文章和斯坦福CS231n的文章。 Kaggle Learn的Python课程的中文翻译&#xff0c;链接为&#xff1a;Python&#xff1b;Kaggle …

【HDU - 3870】Catch the Theves(平面图转对偶图最短路,网络流最小割)

题干&#xff1a; A group of thieves is approaching a museum in the country of zjsxzy,now they are in city A,and the museum is in city B,where keeps many broken legs of zjsxzy.Luckily,GW learned the conspiracy when he is watching stars and told it to zjsxz…

一步步编写操作系统 2 部署工作环境 2

1.22汇编语言编译器新贵&#xff0c;NASM "新"是相对于旧来说的&#xff0c;老的汇编器MASM和TASM已经过时了&#xff0c;从名称上可以看出字母n是在m之后&#xff0c;其功能必然有所超越才会被大家接受。 请用一句话概括NASM优势在哪里&#xff1f;免费语法简洁使…