题干:
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?
Input
The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤bi≤10000).
Output
For each case, output an integer, indicating the most score Alice can get.
Sample Input
2 1
23
53 3
10 100 20
2 4 3
Sample Output
53
105
题目大意:
Alice和Bob玩一个游戏,有两个长度为N的正整数数字序列,每次他们两个只能从其中一个序列,选择两端中的一个拿走。他们都希望可以拿到尽量大的数字之和,并且他们都足够聪明,每次都选择最优策略。Alice先选择,问最终Alice能拿到的数字总和是多少?
解题报告:
直接dp[][][][]就行了。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 20 + 5;
int dp[MAX][MAX][MAX][MAX],sa[MAX],sb[MAX];
int a[MAX],b[MAX];
int n,sum;
int dfs(int l,int r,int L,int R) {if(dp[l][r][L][R] != -1) return dp[l][r][L][R];int res = 0;int ssum = sa[r]-sa[l-1] + sb[R]-sb[L-1];if(l<=r) res = max(res,ssum - dfs(l+1,r,L,R)),res = max(res,ssum - dfs(l,r-1,L,R));if(L<=R) res = max(res,ssum - dfs(l,r,L+1,R)),res = max(res,ssum - dfs(l,r,L,R-1));return dp[l][r][L][R] = res;
}
int main()
{int t;cin>>t;while(t--) {scanf("%d",&n);sum=0;memset(dp,-1,sizeof dp);for(int i = 1; i<=n; i++) scanf("%d",a+i),sum += a[i],sa[i] = sa[i-1] + a[i];for(int i = 1; i<=n; i++) scanf("%d",b+i),sum += b[i],sb[i] = sb[i-1] + b[i];printf("%d\n",dfs(1,n,1,n));} return 0 ;
}