题干:
You’ve finally got mad at “the world’s most stupid” employees of yours and decided to do some firings. You’re now simply too mad to give response to questions like “Don’t you think it is an even more stupid decision to have signed them?”, yet calm enough to consider the potential profit and loss from firing a good portion of them. While getting rid of an employee will save your wage and bonus expenditure on him, termination of a contract before expiration costs you funds for compensation. If you fire an employee, you also fire all his underlings and the underlings of his underlings and those underlings’ underlings’ underlings… An employee may serve in several departments and his (direct or indirect) underlings in one department may be his boss in another department. Is your firing plan ready now?
Input
The input starts with two integers n (0 < n ≤ 5000) and m (0 ≤ m ≤ 60000) on the same line. Next follows n + m lines. The first n lines of these give the net profit/loss from firing the i-th employee individually bi (|bi| ≤ 107, 1 ≤ i ≤ n). The remaining m lines each contain two integers i and j (1 ≤ i, j ≤ n) meaning the i-th employee has the j-th employee as his direct underling.
Output
Output two integers separated by a single space: the minimum number of employees to fire to achieve the maximum profit, and the maximum profit.
Sample Input
5 5
8
-9
-20
12
-10
1 2
2 5
1 4
3 4
4 5
Sample Output
2 2
Hint
As of the situation described by the sample input, firing employees 4 and 5 will produce a net profit of 2, which is maximum.
题目大意:
公司解雇员工,每个员工有一个权值,可正可负可为零(为正代表解雇员工可以获得的利润,为负代表获得的利润为负)。然后给出一些员工上下级的关系,如果解雇一个员工(比如经理主管之类的),那么他手下的所有员工都会被解雇。注意一点:公司有很多部门,每个人可能不只效力于一个部门,所以有可能在这个部门A是B的上司,在另一个部门内B是A的上司。(其实就是代表图中可能有环)问对公司获利最大的解雇计划以及最少的解雇员工人数。
解题报告:
看起来就是个最大权闭合图。但是不知道怎么证明这样得到的就是最少的解雇人数了、、
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 5e5 + 5;
int n,m;
int tot;
const ll INF = 0x3f3f3f3f3f3f3f3f;
struct Edge {int to,ne;ll w;
} e[MAX];
int head[MAX];
int st,ed;
ll a[MAX],dis[MAX];
int q[MAX];//一共多少个点跑bfs,dis数组和q数组就开多大。
void add(int u,int v,ll w) {e[++tot].to=v;e[tot].w=w;e[tot].ne=head[u];head[u]=tot;
}
bool bfs(int st,int ed) {memset(dis,-1,sizeof(dis));int front=0,tail=0;q[tail++]=st;dis[st]=0;while(front<tail) {int cur = q[front];if(cur == ed) return 1;front++;for(int i = head[cur]; i!=-1; i = e[i].ne) {if(e[i].w&&dis[e[i].to]<0) {q[tail++]=e[i].to;dis[e[i].to]=dis[cur]+1;}}}if(dis[ed]==-1) return 0;return 1;
}
ll dfs(int cur,ll limit) {//limit为源点到这个点的路径上的最小边权 if(limit==0||cur==ed) return limit;ll w,flow=0;for(int i = head[cur]; i!=-1; i = e[i].ne) { if(e[i].w&&dis[e[i].to]==dis[cur]+1) {w=dfs(e[i].to,min(limit,e[i].w));e[i].w-=w;e[i^1].w+=w;flow+=w;limit-=w;if(limit==0) break;}}if(!flow) dis[cur]=-1;return flow;
}
ll dinic() {ll ans = 0;while(bfs(st,ed)) ans+=dfs(st,INF);//0x7fffffff可能就不对了? return ans;
}
int ans2;
bool vis[MAX];
void dfs2(int cur) {if(cur == ed) return;vis[cur] = 1;ans2++;for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].to;if(e[i].w == 0 || vis[v]) continue;dfs2(v);}
}
int main()
{cin>>n>>m;st=0;ed=n+1;tot=1;ll sum = 0;for(int i = 0; i<=n+1; i++) head[i] = -1;for(int i = 1; i<=n; i++) {scanf("%lld",a+i);if(a[i] > 0) sum += a[i],add(st,i,a[i]),add(i,st,0);if(a[i] < 0) add(i,ed,-a[i]),add(ed,i,0);}for(int a,b,i = 1; i<=m; i++) {scanf("%d%d",&a,&b);add(a,b,INF);add(b,a,0);}ll ans = sum - dinic();dfs2(st);printf("%d %lld\n",ans2-1,ans);return 0;
}
玄学方法:
这题的特殊之处就是要输出最少辞退员工数。
怎么办呢?
利用一个经典的trick:多关键字
建图前,对所有b[i],执行变换b[i]=b[i]*10000-1,然后,会惊异地发现,
此时最大流所对应的方案就是满足辞退最少人数的了。
为什么?显然,变换后的流量r2除以10000后再取整就等于原来的流量,但是
r2的后四位却蕴含了辞退人数的信息:每多辞退一个人,流量就会少1。
剩下的就是如何根据一个网络流输出方案。
我的做法:从源点开始沿着残余网络dfs(只走没有满载的边),
能dfs到的点对应的人就是需要辞退的。
int main()
{cin>>n>>m;st=0;ed=n+1;tot=1;ll sum = 0;for(int i = 0; i<=n+1; i++) head[i] = -1;for(int i = 1; i<=n; i++) {scanf("%lld",a+i);a[i] = a[i]*10000-1;if(a[i] > 0) sum += a[i],add(st,i,a[i]),add(i,st,0);if(a[i] < 0) add(i,ed,-a[i]),add(ed,i,0);}for(int a,b,i = 1; i<=m; i++) {scanf("%d%d",&a,&b);add(a,b,INF);add(b,a,0);}ll ans = sum - dinic();dfs2(st);printf("%d %lld\n",ans2-1,(ans+9999)/10000);return 0;
}
或者不用dfs2:
int main()
{cin>>n>>m;st=0;ed=n+1;tot=1;ll sum = 0;for(int i = 0; i<=n+1; i++) head[i] = -1;for(int i = 1; i<=n; i++) {scanf("%lld",a+i);a[i] = a[i]*10000 - 1;if(a[i] > 0) sum += a[i],add(st,i,a[i]),add(i,st,0);if(a[i] < 0) add(i,ed,-a[i]),add(ed,i,0);}for(int a,b,i = 1; i<=m; i++) {scanf("%d%d",&a,&b);add(a,b,INF);add(b,a,0);}ll ans = sum - dinic();
// ans2 = -(ans % 10000 - 10000) % 10000 ;//这两个用哪个都可以ans2 = (10000 - ans%10000)%10000 ;//别忘最后要%10000!!不然ans==10000的时候就WA了ans = (ans+ans2)/10000;
// dfs2(st);printf("%d %lld\n",ans2,ans);return 0;
}