POJ 3991 Seinfeld

Seinfeld
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1285 Accepted: 599
Description

I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:

An empty string is stable.

If S is stable, then {S} is also stable.

If S and T are both stable, then ST (the concatenation of the two) is also stable.

All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
Input

Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)
Output

For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Sample Input

}{
{}{}{}

{{{}

Sample Output

  1. 2
  2. 0
  3. 1
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <stdio.h>using namespace std;
char  a[2005];
char b[2005];
int top;
int main()
{int cas=0;while(scanf("%s",a)!=EOF){if(a[0]=='-')break;int len=strlen(a);top=-1;int ans=0;for(int i=0;i<len;i++){if(a[i]=='{')b[++top]=a[i];else{if(top==-1){b[++top]='{';ans++;}else{if(b[top]=='{')top--;}}}ans+=(top+1)/2;printf("%d. %d\n",++cas,ans);}return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228778.html

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/404213.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

HTML面试题汇总

【HTML】 [html] 你有使用过MediaRecorder吗&#xff1f;说说它的运用场景有哪些&#xff1f; [html] 进入编辑页面时&#xff0c;如何把光标聚焦到第一个input&#xff1f; [html] 如何给input的右上角加个清除的按钮 [html] 举例说明只用html和css如何使得一个列表编号倒…

H264参数语法文档: SPS、PPS、IDR

From: http://blog.csdn.net/heanyu/article/details/6205390 H.264码流第一个 NALU 是 SPS&#xff08;序列参数集Sequence Parameter Set&#xff09; 对应H264标准文档 7.3.2.1 序列参数集的语法进行解析 SPS参数解析// fill sps with content of p[cpp] view plaincopyint …

悬浮动态分层导航

1、首先在<head>里面引用一个JQUERY的文件以用来制作鼠标点击动画效果&#xff08;从网站上下载即可&#xff09; 1 <script language"javascript" type"text/javascript" src"js/jquery-1.4.2.min.js"></script> 2、插入div&…

[Redux/Mobx] Redux怎么添加新的中间件?

[Redux/Mobx] Redux怎么添加新的中间件&#xff1f; applyMiddleware 个人简介 我是歌谣&#xff0c;欢迎和大家一起交流前后端知识。放弃很容易&#xff0c; 但坚持一定很酷。欢迎大家一起讨论 主目录 与歌谣一起通关前端面试题

php操作xml

<?php $xmlfile_get_contents("c.xml"); $simplenew SimpleXMLElement($xml); //var_dump($simple); //1查询 echo "<table border1>"; foreach ($simple->book as $book) {$attr$book->attributes();//获取节点属性echo "<tr>…

h264 图像、帧、片、NALU

From: http://blog.csdn.net/zqnihao917/article/details/7760170 图像、帧、片、NALU 是学习 H.264的人常常感到困惑的一些概念&#xff0c;我在这里对自己的理解做一些阐述&#xff0c;欢迎大家讨论&#xff1a;H.264 是一次概念的革新&#xff0c;它打破常规&#xff0c;完全…

Vue面试题汇总目录

【Vue】 [vue] vue组件里的定时器要怎么销毁&#xff1f; [vue] &#xff1c;template&#xff1e;&#xff1c;/template&#xff1e;有什么用&#xff1f; [vue] 你有使用过JSX吗&#xff1f;说说你对JSX的理解 [vue] 使用vue渲染大量数据时应该怎么优化&#xff1f;说下…

EXEC与sp_executesql的区别及应用

execute&#xff0c;简写为exec,除了用来执行存储过程&#xff0c;一般都用来执行动态Sql sp_executesql&#xff0c;sql2005中引入的新的系统存储过程&#xff0c;也是用来处理动态sql的,如&#xff1a; exec sp_executesql sql, Ncount int out,id varchar(20), cou out ,i…

React封装一个组件弹出框

目录 前言 代码 简要 引用 效果 前言 我是歌谣 放弃很容易 但是坚持一定很酷 为了保证react代码的一个简洁性 最近开始封装组件, 直接上代码 因为都很简单的模式 这边直接进行讲解 代码 //取消机构和取消讲师的方法封装 //params visible控制弹框的一个现实和隐藏 import…

h264 Nalu 详解

From: http://blog.csdn.net/d_l_u_f/article/details/7260772 1&#xff0e;引言 H.264的主要目标&#xff1a; 1&#xff0e;高的视频压缩比 2&#xff0e;良好的网络亲和性 解决方案&#xff1a; VCL video coding layer 视频编码层 NAL network abstraction layer …

Pytorch项目(模型训练与优化),肺癌检测项目之六

数据优化方案 数据优化方案1&#xff1a;重复抽样 &#xff08;1&#xff09;对多数类的样本实施欠采样&#xff0c;减少多数类数量 &#xff08;2&#xff09;对少数类的样本实施过采样&#xff0c;增加少数类数量 数据优化方案2&#xff1a;数据增强 数据增强&#xff08…

Oracle 中文排序

按照拼音顺序(常用) ORDER BY nlssort(NAME, NLS_SORTSCHINESE_PINYIN_M) 按照部首顺序 ORDER BY nlssort(NAME, NLS_SORTSCHINESE_RADICAL_M) 按照笔画顺序 ORDER BY nlssort(NAME, NLS_SORTSCHINESE_STROKE_M) 转载于:https://www.cnblogs.com/xcxcxcxc/p/554…

mac苹果屏幕截图快捷键

From: http://blog.csdn.net/w88193363/article/details/12647233 一般在Mac上用Command-Shif-3/4来截图。注&#xff1a;Command苹果键 其实还有几个辅助键&#xff0c;来起到不同的截图功能…… 011)Command-Shift-3&#xff08;适用于OS9,10.1X和10.2&#xff09; 02将整…

【数据库】SQL查询强化篇

查询是数据库的基本应用之一&#xff0c;oracle中的SQL查询语法&#xff0c;一方面遵循了SQL标准&#xff0c;另一方面又有自己的独特之处。 从而使得oracle中的SQL查询功能更加强大。接下来将会涉及oracle中的SQL查询语句&#xff0c;包括&#xff1a; 基本查询&#xff1a;主…

[python3] pyton socket 同步通信举例

本文比较简单&#xff0c;适合入门用&#xff0c;作个笔记&#xff0c;方便日后抄写 一个服务端&#xff0c;一个客户端&#xff0c;而且是阻塞方式&#xff0c;一次只能接受一个客户端连接并通信噢。 客户端发送‘bye, 结束与服务端的通信&#xff0c;如果发送’shutdown&…

做中学

陈鹤琴提出了 “做中教&#xff0c;做中学&#xff0c;做中求进步。”这个方法论,突出了以儿童为学习主体的思想及一个“活”字&#xff0c;一个“做”字&#xff0c;使儿童处于主动学习的地位&#xff0c;体现了陈鹤琴先生的儿童观和教育观。也就是说,陈鹤琴先生认为孩子应该在…

学习进度02

第二周学习进度 这是第二周了&#xff0c;感觉上了软件工程好累啊&#xff0c;但是在累的过程中&#xff0c;也积累了不少东西&#xff0c;很值&#xff01; 第二周所花时间&#xff08;包括上课&#xff09; 410 ..... 代码量&#xff08;行&#xff09; 18545行 博客量&#…