Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:
Swap(0, 1) => {4, 1, 2, 0, 3} Swap(0, 3) => {4, 1, 2, 3, 0} Swap(0, 4)
=> {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
Input Specification:
Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.
Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9
#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
#include<string>
#include<map>
using namespace std;
int hashtable[100010];int main(){int n;int count=0;
int wrong=0;
scanf("%d",&n);
for(int i=0;i<n;i++){int num;scanf("%d",&num);if(num!=i&&num!=0) wrong++;hashtable[num]=i;
}int k=1;
while(wrong>0){if(hashtable[0]==0){ while(k<n){if(hashtable[k]!=k){hashtable[0]=hashtable[k];hashtable[k]=0;count++;break;}k++;}
// for(int i=0;i<n;i++){
// for(int j=0;j<n;j++){
// if(hashtable[j]==i){
// printf("%d ",j);
// }
// }
//
// }
// printf("\n");}else{swap(hashtable[0],hashtable[hashtable[0]]);count++;wrong--;
//for(int i=0;i<n;i++){
// for(int j=0;j<n;j++){
// if(hashtable[j]==i){
// printf("%d ",j);
// }
// }
//
// }
// printf("\n");}
}printf("%d\n",count);return 0;}
第一遍做其实思路还挺清晰的,不过有个小地方出了错,导致测试用例有两个地方超时,一个地方错误。原因就在于我设置的“wrong”这个字段,不应该包含0,也就是说wrong表达的意思是除0以外不在本位上的数。
还有,如果每次都从1开始找下一个不在本位上的数,计算量太大会超时,因此我设置了一个k来记住上一次遍历到的数,这样避免了循环计算太多次。这样做的原理是,已经遍历过的数要么是原本就在自己的位置上,要么不在自己的位置上被遍历到然后更正,不会出现遍历过后又乱序的情况。