You are given two long strings A and B. They are comprised of lowercase letters. You should compute how many suffixes of A are the prefixes of B.
Input
In the first line is a number T (0<T≤100) , indicating the cases following.
In the next T lines each line contains two strings — A and B.
( 0<|A|≤105,0<|B|≤105)
Output
There should be exactly T lines.
Each line contain a number — the answer.
Sample Input
1
abcc ccba
Sample Output
2
HINT
In the first case, cc and c are two of the suffixes of string A, and they are the prefixes of string B.
题解:很简单的字符串hash问题,
设i是从 0 循环到min(lenA,lenB)
hasha += Base^n * A[lenA-1-i];
hashb = hashb * Base + B[i];
然后判断hasha == hashb 那么cnt++
代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef unsigned long long ull;
const ull Base = 100000007;
const ull MAX = 1e5+5;
char A[MAX],B[MAX];
int main()
{int T;scanf("%lld",&T);while(T--){scanf("%s %s",A,B);ull lenA = strlen(A),ull asum = 0;ull lenB = strlen(B),ull bsum = 0;ull t = 1;int ans = 0;for(int i = 0;i < min(lenA,lenB);i++){asum += t*A[lenA-1-i];bsum = bsum * Base + B[i];t *= Base;if(asum == bsum) ans++;}cout<<ans<<endl;}return 0;
}