题意:
给你n个木棍的长度和重量,让其成为上升序列,如果不能达到,就需要重新一分钟设置。
a)第一个木棍的准备时间为1分钟。
b)在处理长度为l和重量为w的棒之后,如果l <= l’并且w <= w’,则机器将不需要设置长度为l’和重量为w’的棒的设置时间。否则,将需要1分钟进行设置。
题目:
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l <= l’ and w <= w’. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,…, ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
分析:
因为这道题有两个变量需要我们考虑,所以先固定一个,使其先成为上升子序列后,然后只讨论一个,类似很久之前的一道拦截导弹的题,找最长上升子序列,然后每次找到后状态转移到下一个。
AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int M=5e3+10;
int t,n,ans;
int book[M];
struct node{int a,b;
}s[M];
bool cmp(node x,node y){if(x.b==y.b)return x.a<y.a;return x.b<y.b;
}
int main(){scanf("%d",&t);while(t--){ans=0;memset(book,0,sizeof(book));scanf("%d",&n);for(int i=0;i<n;i++)scanf("%d%d",&s[i].a,&s[i].b);sort(s,s+n,cmp);for(int i=0;i<n;i++){if(!book[i]){book[i]=1;for(int j=i+1;j<n;j++){if(s[i].a<=s[j].a&&!book[j]){s[i].a=s[j].a;book[j]=1;}}ans++;}}printf("%d\n",ans);}return 0;
}