java起源英文_Abbreviation 英文词组缩写(来源:南阳理工大学ACM)java

As we know, we often use a short sequence of characters in place of some words with a very long name. For example, ACM is an abbreviation of “Association for Computing Machinery”. Now we are using an acronymic method to get the abbreviation. An acronym is generated from a long name by capitalizing the first letter of every word in the name and concatenating them together. There is an exception: some words are ignored when generating the abbreviation. These words( case insensitive) meet the following rules:

1. The common words “and”, “for”, and “the”.

2. The words with length less than 3, such as “a”, “of”, “to”. Your job is to get the abbreviation of a given string by using the acronymic method.

输入

Input starts with an integer T (T <= 100), denoting the number of test cases. Each case contains a line with several words seperated by space(s). The length of each line is less than 100. And you can assume that there is at least one available word for each case.

输出

For each case, print the abbreviation of the word.

样例输入

5

Online Judge

Association for Computer Machinery

Institute of Electrical and Electronics Engineers

The Lord of the Rings

netease

样例输出

OJ

ACM

IEEE

LR

N

import java.util.Scanner;

/**

*

* @author admin

*As we know, we often use a short sequence of characters in place of some words with

*a very long name. For example, ACM is an abbreviation of “Association for Computing

*Machinery”. Now we are using an acronymic method to get the abbreviation. An acronym

*is generated from a long name by capitalizing the first letter of every word in the

*name and concatenating them together. There is an exception: some words are ignored

*when generating the abbreviation. These words( case insensitive) meet the following rules:

*

*1. The common words “and”, “for”, and “the”.

*

*2. The words with length less than 3, such as “a”, “of”, “to”.

*Your job is to get the abbreviation of a given string by using the acronymic method.

*

*输入

*Input starts with an integer T (T <= 100), denoting the number of test cases.

*Each case contains a line with several words seperated by space(s). The length

*of each line is less than 100. And you can assume that there is at least one

*available word for each case.

*输出

*For each case, print the abbreviation of the word.

*实例:

*输入:

*5

*Online Judge

*Association for Computer Machinery

*Institute of Electrical and Electronics Engineers

*The Lord of the Rings

*netease

*输出:

*OJ

*ACM

*IEEE

*LR

*N

*/

public class Abbreviation {

public static void main(String[] args) {

Scanner input=new Scanner(System.in);

int num=Integer.valueOf(input.nextLine());

String[] strArr=new String[num];

for (int i = 0; i < strArr.length; i++) {

strArr[i]=input.nextLine();

}

input.close();

for (int i = 0; i < strArr.length; i++) {

computer(strArr[i]);

}

}

public static void computer(String str)

{

String[] word=str.split(" ");

String tempStr="";

for (int i = 0; i < word.length; i++) {

tempStr+=getWord(word[i]);

}

System.out.println(tempStr);

}

public static String getWord(String str)

{

if(str.length()<3||"and".equals(str)||"for".equals(str)||

"the".equals(str)||"And".equals(str)||"For".equals(str)||"The".equals(str))

{

return"";

}

return str.substring(0, 1).toUpperCase();

}

}

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/281782.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

【C# Personal Handbook】运行环境

一、CLR、CLI、CTS、CLS、BCL、FCL简介CLI&#xff08;公共语言基础&#xff09;CLI是微软公司向ECMA提交的一份语言和数据格式规范&#xff0c;CLR是目前为止唯一一个公共语言基础的实现版本。CLI包括了公共类型系统&#xff08;CTS&#xff09;、公共中间语言&#xff08;CIL…

如何完善自己的知识结构

★领域 &#xff08;本来想用“学科”这个词&#xff0c;后来觉得“学科”的范畴还是偏小&#xff0c;就改用“领域”&#xff09;  按照传统的习惯&#xff0c;通常会把知识归类到不同的领域&#xff08;比如&#xff1a;文学、数学、计算机、烹调、等等&#xff09;。 ◇领…

MATLAB编程与应用系列-关于MATLAB编程入门教程的总体编写安排

本系列教程来源于出版设计《基于MATLAB编程基础与典型应用书籍》&#xff0c;如涉及版权问题&#xff0c;请联系&#xff1a;156204968qq.com。 出版社&#xff1a;人民邮电出版社&#xff0c; 页数&#xff1a;525。 本系列教程目前基于MATLABR2006a&#xff0c;可能对于更高级…

python语言特性-------python2.7教程学习【廖雪峰版】(一)

开始学习廖雪峰的py2.7教程&#xff1a; 2017年6月5日12:54:28 笔记&#xff1a; 廖雪峰python2.7教程1.用任何编程语言来开发程序&#xff0c;都是为了让计算机干活。 2.Python是一种相当高级的语言。代码少还不好&#xff1f;代码少的代价是运行速度慢。3.用Python可以做什么…

java调c++代码_Java中调用C++代码的实现 | 学步园

JNI为 Java Native Interface 即Java本地接口&#xff0c;使用此种方式可以对C/C代码进行调用&#xff0c;其在本质上是对C/C生成的动态库进行调用而不是直接对C/C代码进行调用Java代码如下&#xff1a;public class TestJNI{//JNI在本质上是调用C/C的动态库来实现的&#xff…

jeesite1.X 集成多数据源

2019独角兽企业重金招聘Python工程师标准>>> 网上看了几个例子&#xff0c;都是相同数据源的动态切换&#xff0c;如果不是同一种数据库类型&#xff0c;分页查询就出问题。经过研究解决问题。 jeesite.properties配置多数数据源地址,这里以mysql5.7和sqlserver2008…

k8s HPA(HorizontalPodAutoscaler)-自动水平伸缩

Horizontal Pod Autoscaling in Kubernetes写在前面我们平时部署web服务&#xff0c;当服务压力大撑不住的时候&#xff0c;我们会加机器(加钱)&#xff1b;一般没有上容器编排是手动加的&#xff0c;临时加的机器&#xff0c;临时部署的服务还要改Nginx的配置&#xff0c;最后…

jQuery 基金会和 Dojo 基金会合并:Open Web

统一基金会&#xff0c;服务开发人员&#xff0c;推动开放 Web 技术发展jQuery 基金会和 Dojo 基金会今天宣布计划联合&#xff0c;旨在建立最大&#xff0c;最多样化和最全面的基金会&#xff0c;通过服务开发者&#xff0c;他们的项目&#xff0c;他们的社区来构建开放的 Web…

spark java 逻辑回归_逻辑回归分类技术分享,使用Java和Spark区分垃圾邮件

原标题&#xff1a;逻辑回归分类技术分享&#xff0c;使用Java和Spark区分垃圾邮件由于最近的工作原因&#xff0c;小鸟很久没给大家分享技术了。今天小鸟就给大家介绍一种比较火的机器学习算法&#xff0c;逻辑回归分类算法。回归是一种监督式学习的方式&#xff0c;与分类类似…

jQuery.extend()方法

定义和用法jQuery.extend()函数用于将一个或多个对象的内容合并到目标对象。 注意&#xff1a; 1. 如果只为$.extend()指定了一个参数&#xff0c;则意味着参数target被省略。此时&#xff0c;target就是jQuery对象本身。通过这种方式&#xff0c;我们可以为全局对象jQuery添加…

1066. 图像过滤(15)

原题: https://www.patest.cn/contests/pat-b-practise/1066 思路: 开胃小菜 实现: #include <stdio.h>int main (void) {int m;int n;int a;int b;int c;char ch;int tmp;int i;int j;scanf("%d %d %d %d %d", &m, &n, &a, &b, &c);// 题…

Wget用法、参数解释的比较好的一个文章

一个语句就可以下载cvpr2016的全部论文&#xff1a; wget -c -N --no-clobber --convert-links --random-wait -r -p -E -e robotsoff -U mozilla http://www.cv-foundation.org/openaccess/CVPR2016.py 其中&#xff0c;-c表示断点续传&#xff1b;-N表示已经下载的内容不再重…

.NET VS智能提示汉化 (.Net6)

先上现成的.net6汉化文件&#xff0c;可以手动下载后参照 [如何为 .NET 安装本地化的 IntelliSense 文件 ](https://learn.microsoft.com/zh-cn/dotnet/core/install/localized-intellisense)进行安装。或者使用后文的工具进行自动安装。无对照英文在前中文在前汉化内容来自 官…

go 返回mysql数组_Go基础之--操作Mysql(一)

关于标准库database/sqldatabase/sql是golang的标准库之一&#xff0c;它提供了一系列接口方法&#xff0c;用于访问关系数据库。它并不会提供数据库特有的方法&#xff0c;那些特有的方法交给数据库驱动去实现。database/sql库提供了一些type。这些类型对掌握它的用法非常重要…

Vue CLI 3开发中屏蔽烦人的EsLint错误

问题 Vue开发中&#xff0c;特别是当你阅读分析别人的其中早期版本的Vue代码时往往会遭遇到满屏幕的烦人的EsLint错误。有关EsLint这个工具的作用不再赘述。查阅网上参考文档&#xff0c;大多是针对早起版本Vue CLI工具项目的&#xff0c;在我最新使用的Vue CLI 3生成的工程中根…

pyinstaller---将py文件打包成exe

pyinstaller可将Python脚本打包成可执行程序&#xff0c;使在没有Python环境的机器上运行。 1.pyinstaller在windows下的安装 直接在命令行用pip安装 pyinstaller&#xff0c; 在windows下&#xff0c;pyinstaller需要PyWin32的支持。当用pip安装pyinstaller时未找到PyWin32&am…

老人寻求到一名程序员,用2W行代码给自己打造了一幅肖像画

今天翻墙看了下国外的论坛&#xff0c;看到了一位版主给一位老人描绘肖像画的文章&#xff0c;不得不说这位大佬是真的厉害&#xff0c;近20000行代码&#xff0c;而且还画的很像&#xff0c;像小编我这种手残党&#xff0c;用笔也不能画出来&#xff0c;不得不服&#xff0c;今…

一题多解,ASP.NET Core应用启动初始化的N种方案[下篇]

[接上篇]“天下大势&#xff0c;分久必合&#xff0c;合久必分”&#xff0c;ASP.NET应用通过GenericWebHostService这个承载服务被整合到基于IHostBuilder/IHost的服务承载系统中之后&#xff0c;也许微软还是意识到Web应用和后台服务的承载方式还是应该加以区分&#xff0c;于…

java jpa 模糊查询_JPA 以SQL实现分页不模糊查询(参数可能为空)

repository代码:package com.fancy.miniflow.repository;import java.util.List;import org.springframework.data.jpa.repository.JpaRepository;import org.springframework.data.jpa.repository.JpaSpecificationExecutor;import org.springframework.data.jpa.repository.Q…

GitHub服务中断24小时11分钟事故分析报告\n

上周&#xff0c;GitHub经历了一次事故&#xff0c;导致服务降级24小时11分钟。虽然平台的某些部分不受事故影响&#xff0c;但仍然有多个内部系统受到了影响&#xff0c;向用户显示了过时且不一致的内容。所幸没有用户数据丢失&#xff0c;但针对几秒钟数据库写入的手动调整工…