poj2594(二分图,最小路径覆盖变形)

Treasure Exploration
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 7611 Accepted: 3126

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

题意:有很多机器人和1个图,每个机器人从该图的一个点出发,然后现在要求机器人走遍所有的点,求最小的机器人的数量。(2个机器人可以从不同方向走过同一点)。

思路:显然相当于求最路径覆盖嘛,只不过就是最小路径覆盖是每个点不能被走两次的,而现在可以走两次了,所以想一个办法就是把本身不能走的点连起来,比如一个机器人能从a->b->c,可是现在b已经被另一个机器人走过了,最短路径覆盖又不能让一个点被两个人走,可是该机器人必须从a->c才是最优解,所有用floyd将所有点有联系的都连接起来,这样子仍然是原来的最小路径覆盖的问题了。


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int N=555;
bool tu[N][N];
int from[N];///记录右边的点如果配对好了它来自哪里
bool use[N];///记录右边的点是否已经完成了配对
int color[N];
int n,m;
bool dfs(int x)
{for(int i=1; i<=m; i++) ///m是右边,所以这里上界是mif(!use[i]&&tu[x][i]){use[i]=1;if(from[i]==-1||dfs(from[i])){from[i]=x;return 1;}}return 0;
}
int hungary()
{int tot=0;memset(from,-1,sizeof(from));for(int i=1; i<=n; i++) ///n是左边,所以这里上界是n{memset(use,0,sizeof(use));if(dfs(i))tot++;}return tot;
}
int main()
{int k;while(cin>>n>>k&&n+k){m=n;memset(tu,0,sizeof(tu));while(k--){int a,b;cin>>a>>b;tu[a][b]=1;}for(int k=1; k<=n; k++)for(int i=1; i<=n; i++)for(int j=1; j<=n; j++)if(tu[i][k]&&tu[k][j])tu[i][j]=1;printf("%d\n",n-hungary());}return 0;
}


转载于:https://www.cnblogs.com/martinue/p/5490459.html

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/255805.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

【机器视觉】——相机镜头篇

目录 一、相关概念 1、相机 2、镜头 二、相关参数 1、相机参数 1)芯片尺寸

闭包(计算机科学)

在计算机科学中&#xff0c;闭包&#xff08;Closure&#xff09;又称词法闭包或函数闭包。是引用了自由变量的函数。这个被引用的自由变量将会和函数在一起。即使离开了创建它的环境也不例外。所以另一种关于闭包的说法&#xff1a;由函数和其引用相关的环境构成的实体。闭包在…

C语言小机器人

[cpp] view plaincopyprint? # include <stdio.h> # include <stdlib.h> # define MAXSTR 200 # define REBOT "小C说: " # define YOUR "您 说: " # define EXIT "-e\n" # define NOREPLY "我不知道你说什么呢…

分享12306抢票心得-终极秒杀思路篇

12306抢票的关键拼的就是整点出票的速度&#xff0c;快的几秒钟&#xff0c;慢的几分钟&#xff0c;本文提供终极抢票攻略&#xff0c;通过多线程扫描上万个CDN&#xff0c;来大幅度提升出票速度。准备一&#xff1a;需要了解CDN和切站的机制&#xff0c;请参考&#xff1a;分享…

JVM内幕:Java虚拟机详解

为什么80%的码农都做不了架构师&#xff1f;>>> 这篇文章解释了Java 虚拟机&#xff08;JVM&#xff09;的内部架构。下图显示了遵守 Java SE 7 规范的典型的 JVM 核心内部组件。 上图显示的组件分两个章节解释。第一章讨论针对每个线程创建的组件&#xff0c;第二章…

【机器视觉】——光源篇(分类、选型)

目录 ​ 一、光源相关知识 1、光的作用 2、光的颜色 二、光源的种类

ABB机器人 系统参数配置

系统参数用于定义系统配置并在出厂时根据客户的需要定义。 可使用 FlexPendant 或 RobotStudio Online 编辑系统参数。 此步骤介绍如何查看 系统参数配置。 操作 &#xff1a; 1. 在 ABB 菜单上&#xff0c;点击控制面板。 2. 点击配置。显示选定主题的可用类型列表。 3. 点…

MFC BCGControlBar 库 使用方法

安装 BCGControlBar 库到你的计算机&#xff1a; 解压缩 BCGControlBar.zip &#xff08;比如&#xff0c;到 c:\bcg 目录中&#xff09;把 c:\bcg\bin 增加到你的 path 环境变量中&#xff0c;运行 Visual C 并且打开 Tools | Options 对话框&#xff0c;切换到Directories 页…

四则运算2开发简介

四则运算2在四则运算1的基础之上&#xff0c;又添加了新的功能&#xff0c;但是我觉得四则运算2的难度比四则运算1增大了很多&#xff0c;我在编程的过程中&#xff0c;遇到的最大难度就是不知该如何更好的融合各个功能之间的关系。 写到现在&#xff0c;四则运算2主要实现了以…

ABB机器人的 备份与恢复

保存内容 备份功能可保存上下文中的所有系统参数、系统模块和程序模块。 备份内容 数据保存于用户指定的目录中。 默认路径可加以设置。 目录分为四个子目录&#xff1a;Backinfo、Home、Rapid 和 Syspar。 System.xml 也保存于包含用户设置的 ../backup &#xff08;根…

flask项目开发中,遇到http 413错误

在flask项目中&#xff0c;上传文件时后台报http 413 Request Entity Too Large 请求体太大错误&#xff01; 解决的2种方法&#xff1a; 1.在flask配置中设置 MAX_CONTENT_LENGTH的值; 如设置为20M ( MAX_CONTENT_LENGTH20*1024*1024) 这时小于20M的文件都可以上传 相关连接&…

【机器视觉】——畸变与矫正

目录 一、什么是畸变?畸变的原因是什么? 1、径向畸变(桶形畸变和枕形畸变)

ApplicationContextAware 接口

一、这个接口有什么用&#xff1f; 当一个类实现了这个接口&#xff08;ApplicationContextAware&#xff09;之后&#xff0c;这个类就可以方便获得ApplicationContext中的所有bean。换句话说&#xff0c;就是这个类可以直接获取spring配置文件中&#xff0c;所有有引用到的be…

Java之泛型练习

package cn.itcast.generics;import java.util.Comparator; import java.util.Iterator; import java.util.TreeSet;/** 方法一&#xff1a;实现Comparable接口*/ //class Person implements Comparable<Person> {//实现Comparable接口&#xff0c;使得集合元素具备可比较…

ABB 配置文件

配置文件 配置文件是列出系统参数值的文本文件。 注意&#xff1a; 如果该参数指定默认值&#xff0c;那么就不会被列在 配置文件。 控制器中有六个配置区域&#xff0c;配置文件保存为后缀 .CFG文件。 配置文件默认保存在系统文件夹SYSPAR&#xff0c;例如.. \ MySystem\ …

巨杉db

巨杉数据库 and mongo db ,分布式数据库&#xff0c; 转载于:https://www.cnblogs.com/feiyun8616/p/8178116.html

【深度学习】——物体检测细节处理(NMS、样本不均衡、遮挡物体)

目录 一、候选框大量重叠问题 1、NMS核心思想 2、 步骤&#xff1a; 3、缺陷 4、改进 1&#xff09;soft NMS——衰减的方式来减小预测框的分类得分 2&#xff09;softer nms——增加了位置置信度 二、样本不平衡问题 1、不平滑的来源&#xff08;3方面&#xff09; 1&a…

忙着,快乐着

无比充实的周末&#xff0c;好久没有这样忙过了&#xff0c;周六早上七点多起床去上考研课&#xff0c;上了整整一天&#xff0c;晚上回到寝室用吃饭的时间让自己放松一下&#xff0c;看了一会儿综艺节目&#xff0c;吃晚饭就开始写这次的代码&#xff0c;写累了就去洗洗睡了&a…

ABB Fronius TPS 4000/5000 IRC5 接口

在RobotStudio生成机器人系统时&#xff0c;选择&#xff1a; Power Source option 650-9 Fronius TPS 4000/5000。Fronius的设备类别和设置被激活。此选项支持福尼斯TPS 4000/5000弧焊电机&#xff0c;包括支持三种焊接模式&#xff1a; 1 Job模式 2 修正的Job模式 …