作业
网络拓扑图如下所示:
要求:做适当的截图,表示完成相应的操作。
- 按照网络拓扑要求搭建网络结构,按照个人学号配置每个节点的IP地址,其中X为班级号,Y为学号末尾2位;Y+1为学号末尾2位+1(如我的学号是5号表示5+1=6);按图所示配置路由器和交换机名(要求为姓名首字母+R1,如:我的姓名是张三,则R1改为“ZS_R1”),
提交:拓扑中PC1和PC2不用配置IP地址,使用DHCP方式分配IP地址。在Server1和Server2上都启动HTTP服务。
2.配置好几个交换机和路由器的接口IP地址,注意交换机在配置IP地址前要建立好相应的VLAN,设备用于连接计算机时使用的IP地址最后一部分为254,连接其它网络设备时则自己确定IP地址。拓扑中SW3、SW4、SW5接口不做配置。
3.将SW1、SW2两台交换机之间的两条链路进行聚合,聚合编号为本人的两位学号,并允许所有VLAN的报文通过。
4.在R1、SW1、SW2三台设备上都配置默认路由(缺省路由)通往外网。在R1、SW1、SW2三台设备上运行OSPF协议,实现内部各网段之间的全网通信,要求:在OSPF中进行宣告时R1上不能宣告外网地址,即内部路由器不学习外网的各个网段。
5.在SW1上做DHCP的全局服务器,在SW2上对应的接口做DHCP中继,用于给“192.X.Y+4.0/24”网段中两台计算机分配相应的IP地址。
6.在SW2上配置TELNET,能够在R1上进行远程TELNET,要求使用AAA认证,用户名为:自己的姓名拼音首字母,密码为两位学号(如:我是50号张三,则用户名:zs,密码:50)。
7、R1和R2之间运行PPP并进行CHAP认证,用户名为:自己的姓名拼音首字母,密码为两位学号(如:我是50号张三,则用户名:zs,密码:50)。
8.使用Easy IP方式的NAT,使内网中的192.168.1.0/24、192.168.2.0/24和192.168.3.0/24三个网段都能够访问外网中的Server2服务器。对内容中的Server1服务器的80端口映到出口网关外网地址上,使外网能够访问到此计算机提供的WWW服务。
9.在SW1上做ACL,要求192.168.1.0/24网段不能访问内网中的服务器Server3.
r1
#
sysname XFL_R1
#
acl number 3000
rule 5 permit ip source 192.52.3.0 0.0.0.255
rule 15 permit ip source 192.3.48.0 0.0.0.255
#
aaa
local-user xfl password cipher %$%$;{6[)K7EF,j"G)9;r5!Yp{&O%$%$
local-user xfl service-type ppp
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface Serial1/0/0
link-protocol ppp
ppp authentication-mode chap
ip address 200.52.1.1 255.255.255.0
nat server protocol tcp global 200.52.1.3 8888 inside 192.52.2.253 www
nat outbound 3000
#
interface Serial1/0/1
link-protocol ppp
#
interface GigabitEthernet0/0/2
ip address 192.52.1.2 255.255.255.0
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 192.52.1.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 200.52.1.2
r2
sysname XFL_R2
#
firewall zone Local
priority 15
#
interface Serial1/0/0
link-protocol ppp
ppp chap user xfl
ppp chap password cipher %$%$*8,("8n1WF"Fy^*wd+Y<,,zq%$%$
ip address 200.52.1.2 255.255.255.0
#
interface Serial1/0/1
link-protocol ppp
interface GigabitEthernet0/0/1
ip address 200.52.3.1 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 200.52.2.1 255.255.255.0
s1
#
sysname XFL_S1
#
vlan batch 10 20 30 40 50 100 200
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
acl number 3001
rule 5 deny ip source 192.168.1.0 0.0.0.255 destination 192.52.2.254 0
#
drop-profile default
#
ip pool vlan10
gateway-list 192.3.48.1
network 192.3.48.0 mask 255.255.255.0
#
interface Vlanif40
ip address 192.52.2.1 255.255.255.0
#
interface Vlanif100
ip address 192.168.1.1 255.255.255.0
dhcp select global
#
interface Vlanif200
ip address 192.52.1.1 255.255.255.0
#
interface MEth0/0/1
#
e-trunk 44
#
interface Eth-Trunk1
port link-type trunk
#
interface Eth-Trunk44
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 40
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 200
interface GigabitEthernet0/0/9
eth-trunk 44
#
interface GigabitEthernet0/0/10
eth-trunk 44
ospf 1
area 0.0.0.0
network 192.168.1.0 0.0.0.255
network 192.52.1.0 0.0.0.255
network 192.52.2.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 192.52.1.2
#
s2
#
sysname XFL_s2
#
vlan batch 10 20 30 40 50 100
#
cluster enable
ntdp enable
ndp enable
aaa
local-user xfl password cipher $DN*U+!,&^!NZPO3JBXBHA!!
local-user xfl privilege level 15
local-user xfl service-type telnet
local-user admin password simple admin
local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif10
ip address 192.3.48.1 255.255.255.0
dhcp select interface
dhcp select relay
dhcp relay server-ip 192.168.1.1
#
interface Vlanif20
ip address 192.52.3.1 255.255.255.0
#
interface Vlanif100
ip address 192.168.1.2 255.255.255.0
#
interface MEth0/0/1
#
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface Eth-Trunk44
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface Eth-Trunk55
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 20
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk pvid vlan 10
port trunk allow-pass vlan 10
interface GigabitEthernet0/0/9
eth-trunk 44
#
interface GigabitEthernet0/0/10
eth-trunk 44
#
ospf 1
area 0.0.0.0
network 192.52.3.0 0.0.0.255
network 192.3.48.0 0.0.0.255
network 192.168.1.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 192.168.1.1
#